Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-04-05, 05:46 PM   #1
MattMann
Registered User
 
Join Date: May 2005
Posts: 3
Default Black screen after starting X with new 'nvidia' driver

I am in the process of building a new SourceMage Linux machine. I have installed the latest versions of Xorg (v6.8.2) and the latest nVidia Display Driver (v1.0-7174).

When starting X with the 'nvidia' driver specified, I gert a black screen, and my monitor's status LED blinks (as if it were in sleep mode or something). The entire computer doesn't freeze, though - I can CTR+ALT+BACKSPACE to kill X. I still cannot see the console after killing X, but I know it's there because I can type 'reboot' blindly and the system will reboot, displaying garbled colors while shuts down. So it seems as though the nVidia driver is doing something to the video buffer or something.

But if I modify my xorg.conf file and replace the driver with 'nv', X starts fine and so does KDE (v3.4).

I have tried all kinds of thing, from recompiling the drivers, to recompiling Xorg, and even recompiling the kernel - nothing helps at all. Searching the 'net with Google turns up many similar problems, but nothing there helps either.

Here is an interesting note: if I start X remotely through SSH, I have no errors - X starts up fine and so does KDE (of course, I don't see X through SSH - just the text). Within the same SSH terminal, I can do a 'ps -eaf' and see that X and KDE are running. But on the monitor itself, I see nothing.

Just so no one will say it's a resolution problem, I even tried to start X in 8-bit 800x600 and it did the same thing.

I am using kernel version 2.6.11.8 on an AMD Athlon64 (running in 32-bit mode, not 64-bit) and an nVidia nForce3 250GB board. The video card is a plain GeForce 6800 (128MB version), and the monitor attached is a Samsung T213 connected to the DVI.

Attached is the xorg.conf file, xorg.0.log file, and the nvidia-bug-report.log file. Sorry for such a long post - I wanted to be thorough
Attached Files
File Type: txt xorg.conf.txt (5.6 KB, 151 views)
File Type: txt Xorg.0.log.txt (32.4 KB, 146 views)
File Type: txt nvidia-bug-report.log.txt (84.4 KB, 179 views)

Last edited by MattMann; 05-04-05 at 06:03 PM.
MattMann is offline   Reply With Quote
Old 05-04-05, 06:10 PM   #2
MattMann
Registered User
 
Join Date: May 2005
Posts: 3
Default Re: Black screen after starting X with new 'nvidia' driver

I think I may have fixed this, I wrote this reply while at work logged into the machine remotely vis SSH, so I have no way of testing out this theory until my lunch break.

Wat I did was added: Option "ConnectedMonitor" "DFP".

When I get a lunch break, I'll be able to see whether it worked or not. Please reply with your input in the mean time - it might still be helpful. Still a possibility that I got it fixed and that it probably not a broken driver...

Last edited by MattMann; 05-04-05 at 06:53 PM.
MattMann is offline   Reply With Quote
Old 05-04-05, 08:39 PM   #3
MattMann
Registered User
 
Join Date: May 2005
Posts: 3
Default Re: Black screen after starting X with new 'nvidia' driver

Yes, adding [Option "ConnectedMonitor" "DFP"] fixed my problem. Didn't see this ANYWHERE in all the searching I did, nor was it in any README file I found.

I hope I didn't waste anyone's time, but at the same time I hop this helps someone else.
MattMann is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 12:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.