Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-13-05, 11:13 PM   #1
naruto
Registered User
 
Join Date: Jun 2005
Posts: 1
Unhappy color bars after using driver

Hi all,
Could someone help me with the 1.0-7664 nvidia linux driver . After installing the driver, the desktop shrunk, vertical color bars appear on the right side 1" of the screen and the bottom 1" displays a mirror image of the top part of the destop. The color bars and mirror image starts appearing during the nvidia logo.
I'm using a dell inspiron 8200 with nvidia geforce4 440 go (rev a3). With the original driver (nv) there's no prob.

Cheers.
naruto is offline   Reply With Quote
Old 09-02-05, 12:38 AM   #2
aurelieng
Registered User
 
Join Date: Nov 2004
Posts: 18
Default Re: color bars after using driver

I have exactly the same problem, did you manage to find any fix ?

Quote:
Originally Posted by naruto
Hi all,
Could someone help me with the 1.0-7664 nvidia linux driver . After installing the driver, the desktop shrunk, vertical color bars appear on the right side 1" of the screen and the bottom 1" displays a mirror image of the top part of the destop. The color bars and mirror image starts appearing during the nvidia logo.
I'm using a dell inspiron 8200 with nvidia geforce4 440 go (rev a3). With the original driver (nv) there's no prob.

Cheers.
aurelieng is offline   Reply With Quote
Old 09-02-05, 04:14 PM   #3
bluelan
Registered User
 
Join Date: Feb 2005
Posts: 1
Default Re: color bars after using driver

I had the exact same problem with a dell latitude c840. It took some work to fix.

First, add some parameters to your nvidia module on load.
NVreg_Mobile=0

You'll have to figure out how to make that permanent yourself. But, you can try it once by doing:

rmmod nvidia
modprobe --first-time -v nvidia NVreg_Mobile=0

on the command line.

I also had to change xorg.conf. Look for the Monitor section and add the lines:

HorizSync 30.5 - 75.0
VertRefresh 30.0 - 85.0

to that section. Those numbers work for my LCD. You might need something slightly different for yours.

I don't know why this worked, since I'm mis-specifying the LCD panel, and then telling nvidia's module to autodetect the best resolution. But, there it is.

Let me know if this works for you.
bluelan is offline   Reply With Quote
Old 01-26-06, 04:30 PM   #4
benussi
Registered User
 
Join Date: Jan 2005
Posts: 6
Default Re: color bars after using driver

hi bluelan,
your hint worked for my c840 with FC4 (2.6.14-1.1656_FC4) and nvidia 1.0-8178. Same settings you suggest....but at any reboot I have to repeat the procedure? Any more usefull hint?

THaNK
benussi is offline   Reply With Quote
Old 02-05-06, 07:19 PM   #5
tecsyndicate
Registered User
 
Join Date: Feb 2006
Posts: 1
Default Re: color bars after using driver

thanks for this great tip... really helpful.

Getting this to work from boot:

I added the NVreg_Mobile=0 option to /etc/modprobe.conf

before:
Code:
options nvidia NVreg_ModifyDeviceFiles=0
after:
Code:
options nvidia NVreg_Mobile=0 NVreg_ModifyDeviceFiles=0
Good Luck!!
tecsyndicate is offline   Reply With Quote
Old 02-18-06, 11:39 PM   #6
mauilion
Registered User
 
Join Date: Jan 2005
Location: San Francisco
Posts: 4
Send a message via AIM to mauilion Send a message via MSN to mauilion Send a message via Yahoo to mauilion
Default Re: color bars after using driver

While that does solve the color bar problem when I try to use DPMS it flashed the LCD bright white in kind of a scary way. So DPMS doesn't work when NVreg_Mobile=0



I have added a rendering of the color bar window and a nvidia bug report.

using a Dell c840 and 2.6.15 R1 with nvidia driver 8178

I am posting nvidia.zip to this link

http://mauilion.com/nvidia.zip

as it is 524K I can not upload it.

Last edited by mauilion; 02-19-06 at 04:38 PM.
mauilion is offline   Reply With Quote
Old 02-20-06, 07:56 PM   #7
dzr
Registered User
 
Join Date: Jul 2004
Location: Edinburgh, UK
Posts: 9
Send a message via AIM to dzr Send a message via MSN to dzr Send a message via Yahoo to dzr
Default Re: color bars after using driver

You may want to take a look at this thread here:

http://www.nvnews.net/vbulletin/showthread.php?t=63168
dzr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-13-12 07:58 AM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
failing to initialize NV driver PsyShook NVIDIA Linux 10 09-19-02 12:41 PM
Nvidia Driver causes crash on Standby/Suspend dasher NVIDIA Linux 5 09-16-02 05:57 PM

All times are GMT -5. The time now is 04:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.