Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-11-05, 04:03 AM   #1
Mark19961
Registered User
 
Join Date: Aug 2004
Posts: 4
Default geforce 4 mx440 no-go

Hi guys,
In the off chance that I did this wrong... here is what I have done.
installed the driver
altered /etc/driver_aliases with the following:
nvidia "pci10de,181"
(I was already using xorg, so no change needed there)

the output of 'scanpci' is as follows:
pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x10de device 0x0181
nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x]

to make a long story short, I see the driver load at boot.. just looks more or less normal
(I use the linux nvidia drivers all the time, its a similar message)

when X attempts to start, it drops back to the console and complains about it.
so, uplon logging in and examining the logfile, I see that it says it failed to initialise the graphics hardware, or something to that effect.
so, it sees the module loaded but apparently cant do anything with the card itself.

based on this I would assume I got the pci id and other stuff right.

another little tidbit, I figured I would just revert back to the 'nv' driver by changing it in xorg.conf, but this led to system crashes. (understandably, the nvidia module was loading)
so I just removed the driver_aliases entry to cause the module to fail at boot.
hopefully one of you guys has an idea what might be wrong. I dont have another nvidia card free to try, or I would. (not unless I swipe it from another machine.)

ideas? or do I need to wait for then to update the driver for this card?
Mark19961 is offline   Reply With Quote
Old 06-11-05, 10:19 AM   #2
gireeshbhat
Registered User
 
Join Date: Feb 2005
Posts: 13
Default Re: geforce 4 mx440 no-go

How did you enter the pci10de,181 in /etc/driver_aliases?
You need to issue the following command

update_drv -a -i '"pci10de,181"'

Do not forget the ' and the ".
gireeshbhat is offline   Reply With Quote
Old 06-11-05, 11:53 AM   #3
Mark19961
Registered User
 
Join Date: Aug 2004
Posts: 4
Default Re: geforce 4 mx440 no-go

did that, this is how I did it:

update_drv -a -i '"pci10de,181"' nvidia

it worked, no complaints.
this is the bottom of the Xorg.0.log file:

(II) Setting vga for screen 0.
(++) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF4000000
(--) NVIDIA(0): MMIO registers at 0xF2000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.
Mark19961 is offline   Reply With Quote
Old 06-11-05, 09:36 PM   #4
gireeshbhat
Registered User
 
Join Date: Feb 2005
Posts: 13
Default Re: geforce 4 mx440 no-go

Hmm dont know what else to say.
I had a machine I built with a MX440 but sold it recently or I could have tried on it.
One thing you might want to do to get X back is run kdmconfig and change from Xorg to Xsun to atleast get it working temporarily.
gireeshbhat is offline   Reply With Quote
Old 06-11-05, 10:08 PM   #5
Mark19961
Registered User
 
Join Date: Aug 2004
Posts: 4
Default Re: geforce 4 mx440 no-go

X works, just a matter of nuking the driver and changing back to the xorg unaccelerated driver.

oh well, perhaps nvidia has some suggestions
Mark19961 is offline   Reply With Quote
Old 06-18-05, 09:12 PM   #6
gireeshbhat
Registered User
 
Join Date: Feb 2005
Posts: 13
Default Re: geforce 4 mx440 no-go

Alright try this:
make sure you have a valid xorg.conf
make sure you have the NVidia driver installed and the xorg server selected.
Let the system get to the point where it tries to load the xorg server and fails.
Get to the root prompt (it should look like this #).
run the following command

# reboot -- -r

Your system hopefully will load the Xorg server with NVidia driver after the reboot.
gireeshbhat is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 05:20 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 07:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 02:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 10:28 AM

All times are GMT -5. The time now is 11:26 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.