Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-08-02, 10:53 AM   #1
rcoscali
Guest
 
Posts: n/a
Unhappy 'Can't map registers' at kernel driver init

Hello all

I just upgraded my kernel from 2.2.20 to 2.4.19 and when trying to use NVDIA_kernel-2960, at startup of nvidia driver, the kernel module fails with the message:

nvidia: couldn't map registers!
NV0: nv_map_device failed



Please I need a clue to fix it ?
Note that with 2.2 the nvidia driver was running perfectly ...

thanks for any help !!!!
  Reply With Quote
Old 08-08-02, 11:13 AM   #2
rcoscali
Guest
 
Posts: n/a
Lightbulb Looked at the code

Actually the message is clear and after a look at the code I think I have a clue about what is going on.
My 2.4 kernel have been builded with the rivafb frame buffered console driver.
The register set for the video controler have already been mapped by this driver (BAR0 & 1: for control regs and FB regs).
These reg sets might also be reserved by nvidia_kernel driver.

Does this make sense ?
  Reply With Quote
Old 08-08-02, 11:30 AM   #3
rcoscali
Guest
 
Posts: n/a
Thumbs up Fixed

It seems to be why the nvidia kernel module was not loading correctly.

Would it be possible to merge both driver ? or at least to get mapped & bus addresses from rivafb driver ? (just a silly idea)
  Reply With Quote
Old 08-08-02, 11:37 AM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

One thing: NEVER EVER USE RIVAFB. It is very, very buggy. It causes various problems in X (drawing ones for example) and it causes VT switching problems and instability. If you want a framebuffer use vesafb.
Thunderbird is offline   Reply With Quote
Old 08-08-02, 03:15 PM   #5
rcoscali
Guest
 
Posts: n/a
Default

Thanks for the trick
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[BUG] nvidia crashes kernel with 'Xid 13' and attempted to yield the CPU while atomic rockob NVIDIA Linux 36 09-26-12 08:48 AM
upgrade to xorg server 1.13 damaged Geforce 7300 GT KDE NVIDIA Linux 2 09-07-12 09:04 AM
Fatal upgrade: from bad (8800 GTS) to worse 9GTX 560 Ti) ssnyder NVIDIA Linux 1 07-01-12 09:14 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM

All times are GMT -5. The time now is 10:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.