Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Thread Tools
Old 12-18-02, 11:04 AM   #1
Registered User
Join Date: Dec 2002
Location: USA
Posts: 81
Unhappy X server does not load. No errors printed out. One Warning.

Hi. I have AMD Duron 700MHz with 768Ram. My motherboard is MSI K7T pro 2-A.

I installed RedHat8.0 and applied the latest Errata.

When I installed the nvidia and GLX ( NO problem), I wanted to start the X server with startx and with X. But it wouldn't load. Only one warning. I am listind the log XFree86 log and configeration files.

One thing that is good to mention is when I installed the nvidia drivers, I did not kill the X server, but I only switched to text mode ( with Cnrl-Alt-F1). I changed the run-level to 3 then rebooted the machine. When I found that the start x would't load, I installed the NVidia drivers again (so, this time x-server is not running, but the problem presist.

When I type the srartx command, the X session shuts down after the statement:
(II) [GLX]: Initializing GLX extension

from /var/log/XFree86.0.log:
(WW) NVIDIA(0): Failure reading EDID parameters for display device 0.
# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"

# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

RgbPath "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

FontPath "unix/:7100"


Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"

# Option "AutoRepeat" "500 5"

# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.0-69.0
VertRefresh 59.0-86.0
Option "dpms"


Section "Device"
# no known options
Identifier "NVIDIA GeForce 2 MX (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 2 MX (generic)"
BoardName "NVIDIA GeForce 2 MX (generic)"


Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"
Monitor "Monitor0"
DefaultDepth 16

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"


Section "DRI"
Mode 0666

Last edited by saqer; 12-18-02 at 01:49 PM.
saqer is offline   Reply With Quote
Old 12-18-02, 11:12 AM   #2
Registered User
Join Date: Dec 2002
Location: USA
Posts: 81

I am sorry, but the log file is too long to list here.
saqer is offline   Reply With Quote
Old 12-18-02, 03:12 PM   #3
Registered User
Join Date: Sep 2002
Posts: 2,262

So attach it as a txt file...
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-19-02, 12:16 AM   #4
Registered User
Join Date: Dec 2002
Location: USA
Posts: 81

Here is the file:
Attached Files
File Type: txt xfree86.0.log.txt (22.0 KB, 148 views)
saqer is offline   Reply With Quote
Old 12-20-02, 11:46 PM   #5
Registered User
Join Date: Dec 2002
Location: USA
Posts: 81
Default OK, I fixed the problem

I could not wait. I reinstalled redhat ( my previous load was fresh anyways).
It is not enough to only exit the X server. You must kill it or better to log in in text mode.

First I logged in in text mode. installed the driver and made sure the startx works fine. then changed back the /etc/inittab to run level 5.

Thanks anyways.
saqer is offline   Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
First look: Windows Server 2012 brings the cloud down to earth News Archived News Items 0 09-04-12 04:50 PM
Windows Home Server is dead, but we shouldn't mourn it News Archived News Items 0 07-08-12 01:10 AM
New Windows Server 2012 puts virtualization front and center News Archived News Items 0 07-05-12 09:30 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Unable to load 3d driver rebol NVIDIA Linux 3 09-29-02 04:58 PM

All times are GMT -5. The time now is 04:48 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.