Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-07, 02:53 AM   #169
balou
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: first display on twinview

Ok, at first it seemed to work fine, but I discovered a bug. I'm running the following nvidia-drivers version: 1.0.9746. All windows start on my CRT, which is connected to my laptop, as intended. Till I start vmplayer. Vmplayer itself starts on the CRT, but all other windows I start once vmwareplayer is running start on the DFP of the laptop again. It seems like vmwareplayer is disabling the TwinViewXineramaInfoOrder option. I'm running vmwareplayer version 1.0.3 build-34685.

If I close vmwareplayer again, everything works as intended.

Last edited by balou; 01-12-07 at 03:05 AM.
balou is offline   Reply With Quote
Old 01-12-07, 11:43 AM   #170
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: first display on twinview

Or vmplayer isn't dealing with Xinerama info correctly. This sounds like a vmplayer bug.
netllama is offline   Reply With Quote
Old 01-15-07, 06:38 AM   #171
balou
Registered User
 
Join Date: Jan 2007
Posts: 2
Default Re: first display on twinview

Could be, but why is that other applications also start on my DFP once vmware player is running? I mean one non-xinerama aware application shouldn't disable xinerama support for other applications right?
balou is offline   Reply With Quote
Old 01-27-07, 03:47 AM   #172
WMCoolmon
Registered User
 
Join Date: Jan 2007
Posts: 1
Default Re: first display on twinview

Hi. I just wanted to say to NVIDIA, Thank you, for taking the time to implement this new feature. I'm still working on getting everything working properly with my new Linux setup (So I may be in here asking for tech support ).

But one of the reasons that I bought an NVIDIA card (and barely looked at ATI cards) was because it was universally agreed that NVIDIA had far better Linux support than ATI. Things like this may not seem like it's worth the time and effort, but it does give NVIDIA an edge over the competition.
WMCoolmon is offline   Reply With Quote
Old 02-22-07, 12:44 PM   #173
tkbletsc
Registered User
 
Join Date: Feb 2006
Posts: 6
Default Re: first display on twinview

Thanks you to nVidia and to everyone in this thread who posted helpful xorg.conf examples. I finally have LCD+CRT twinview!

I have a 1280x1024 LCD as my main display, and a little 800x600@75 CRT on an upper shelf for watching background jobs and/or movies. I'm using the 97.46 driver on Ubuntu 6.10. The card is a GeForce FX 5200. Here's my complete xorg.conf:

Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)

Section "Files"
  FontPath "/usr/share/X11/fonts/misc"
  FontPath "/usr/share/X11/fonts/cyrillic"
  FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
  FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
  FontPath "/usr/share/X11/fonts/Type1"
  FontPath "/usr/share/X11/fonts/100dpi"
  FontPath "/usr/share/X11/fonts/75dpi"
  FontPath "/usr/share/fonts/X11/misc"
  # path to defoma fonts
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "type1"
  Load "vbe"
  load "glx"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "us"
  option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ExplorerPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  option "Device" "/dev/wacom"# Change to 
  option "Type" "stylus"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
  # /dev/input/event
  # for USB
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  option "Device" "/dev/wacom"# Change to 
  option "Type" "eraser"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
  # /dev/input/event
  # for USB
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  option "Device" "/dev/wacom"# Change to 
  option "Type" "cursor"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
  # /dev/input/event
  # for USB
EndSection

Section "Device"
  identifier "nvdevice"
  boardname "nv"
  busid "PCI:1:0:0"
  driver "nvidia"
	Option "NvAGP" "2"
	Option "RenderAccel" "0"
	Option "CursorShadow" "1"
	Option "Coolbits" "1"
	Option "ConnectedMonitor" "dfp, crt"
	Option "NoPowerConnectorCheck"
	Option "TwinView" "1"
	Option "TwinViewOrientation" "Below"
	Option "TwinViewXineramaInfoOrder" "DFP-0, CRT-0"
	Option "Metamodes" "800x600,1280x1024"
	Option "SecondMonitorHorizSync" "30-70"
	Option "SecondMonitorVertRefresh" "56-85"
  screen 0
EndSection

Section "Monitor"
  identifier "lcdmonitor"
  vendorname "Dell"
  modelname "Dell 1800FP (Digital)"
  HorizSync 30.0-70.0
  VertRefresh 56.0-85.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  modeline  "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline  "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  modeline  "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
  modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  gamma 1.0
EndSection

Section "Screen"
  Identifier "lcdscreen"
  device "nvdevice"
  monitor "lcdmonitor"
  DefaultDepth 24
	#ViewPort 0 0
  SubSection "Display"
    depth 24
    modes "1280x1024@60" "1400x1050@60" "1280x960@60" "1152x864@75" "1024x768@60" "1024x768@70" "1024x768@75" "1024x768@85" "832x624@75" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
  EndSubSection
EndSection

Section "ServerLayout"
  Identifier "Twinview Layout"
      Option       "Xinerama"  "Off"
  screen 0 "lcdscreen" 0 0
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
  Mode 0666
EndSection

Section "ServerFlags"
  option "Xinerama" "true"
EndSection
These sites were useful in getting things tweaked right:
http://www.ublug.org/ubuntu/twinview...to-breezy.html
http://gentoo-wiki.com/HOWTO_Dual_Monitors#TwinView

Also, you can set movies to play fullscreen on the second display with one mplayer command:

$ mplayer -fs -xineramascreen 2 "The Blues Brothers.avi"
tkbletsc is offline   Reply With Quote
Old 02-23-07, 04:06 AM   #174
MamiyaOtaru
Registered User
 
MamiyaOtaru's Avatar
 
Join Date: May 2004
Posts: 45
Default Re: first display on twinview

Figures. This bug finally gets fixed just in time for me to have a new card with two dvi outputs, so it doesn't matter to me anymore. Thanks nonetheless!
MamiyaOtaru is offline   Reply With Quote
Old 05-02-07, 10:43 AM   #175
angrypanda
Registered User
 
Join Date: Jun 2005
Posts: 14
Default Re: first display on twinview

Only in time for them to break it again latest X86_64 driver.

I just did a nvidia-installer -f -q to update my video driver (following a kernel patch on my SuSE machine), now the TwinViewXineramaInfoOrder line is just ignored.

Before my machine was happily displaying the login window on the DFP, with a flat panel attached to the D-SUB (VGA) connector as the secondary monitor. Now the *only* output I get is on the secondary monitor - nothing at all on the DFP.

I guess it might be something other than the display order, but I can't find out what?????

Cheers, Jon
angrypanda is offline   Reply With Quote
Old 05-02-07, 10:57 AM   #176
aos101
Registered User
 
Join Date: Aug 2006
Posts: 7
Default Re: first display on twinview

It sounds like something other than TwinViewXineramaInfoOrder being broken to me. I think if that didn't work you would still get an image on both monitors, but Gnome/KDE/whatever would just put a lot of stuff on the wrong monitor. Does the X log file (/var/log/Xorg.0.log) give any clues what is happening?
aos101 is offline   Reply With Quote

Old 05-02-07, 05:17 PM   #177
angrypanda
Registered User
 
Join Date: Jun 2005
Posts: 14
Wink Re: first display on twinview

Hi,

You're absolutely right - I must have been having a bad day, I hadn't even bothered to check whether I could get the OSD to appear on the suspect flat panel - it doesn't QED Monitor is kapput. Now I can see why Relisys went bust.

Oh well, that's 160 down the pan.

A very grumpy Angrypanda
angrypanda is offline   Reply With Quote
Old 05-08-07, 06:06 PM   #178
tic
Registered User
 
Join Date: May 2007
Posts: 1
Default Re: first display on twinview

I have a 19" 1280x1024 on the left and want it as my primary monitor, and have 15" 1024x768 on the other side of the room to the right.

I dont understand what more i can do. It still has errors constantly. I've used the nvidia settings manager to create the xorg.conf and then added in lines to make my DVI as primary monitor. Now it will startup fine, and login will be on the correct screen, and programs launch to the correct screen, but as soon as I try playing a video (several tried) it will open to the small screen and from then on all programs will open on the small screen until X is reset. Please help, heres my xorg:
Quote:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Mon Feb 26 23:39:38 PST 2007

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AMT M1-150T"
HorizSync 30.0 - 62.0
VertRefresh 50.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900 GT/GTO"
Option "NoLogo"
# Option "TwinViewXineramaInfoOrder" "DFP-1,CRT-0"
Option "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
Option "UseDisplayDevice" "DFP-1, CRT-0"
Option "TwinViewOrientation" "DFP-1 LeftOf CRT-0"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "backingstore" "True"
Option "TripleBuffer" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT: 1024x768 +1280+0, DFP: 1280x1024 +0+0; CRT: 832x624 +1280+0, DFP: nvidia-auto-select +0+0; CRT: 800x600 +1280+0, DFP: nvidia-auto-select +0+0; CRT: 640x480 +1280+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
tic is offline   Reply With Quote
Old 05-26-07, 05:04 PM   #179
Astro96
Registered User
 
Join Date: Jun 2006
Posts: 6
Default Re: first display on twinview

Thanks NVIDIA! I'm glad to have this bug solved. Like WMCoolmon, I also only looked at NVIDIA cards when I was building my new computer precisely for this kind of Linux support. Thanks again!
Astro96 is offline   Reply With Quote
Old 07-01-07, 09:20 AM   #180
joejohnston77
Registered User
 
Join Date: Jul 2007
Posts: 1
Default Re: first display on twinview

First off: Thanks to nvidia for providing a way to set the primary monitor.

I have a slight problem and I'm wondering if others are having the same problem. Everything works great on my primary monitor except popup notifications. For example: Thunderbird's e-mail notification always opens on my CRT-0 display (which should be set as secondary). Also, kopete and opera's popup notification end up on my secondary display as well.

I have the option:
Code:
Option      "TwinViewXineramaInfoOrder" "DFP-0,CRT-0"
I'm using Fedora 7 and KDE.

Dose anyone else have this situation? Is there a way to fix it?

Thanks,

Joe
joejohnston77 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 04:10 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Suse 8.0 Dual display on Quadro 4 700XGL TheCowStir NVIDIA Linux 3 08-10-02 12:16 PM
Dual Display with main CRT, and secondary TV-out BlackDogg NVIDIA Linux 3 08-10-02 09:52 AM

All times are GMT -5. The time now is 03:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.