Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-19-05, 12:53 PM   #1
alvarad
Registered User
 
Join Date: Mar 2005
Posts: 4
Angry openGL problems with QuadroFX 3400

We are having some problems getting the nvidia drivers to work properly on a new system running Suse 9.3. Our system is a Dell Precision 670n with a QuadroFX 3400 256MB card and two Dell 1905FP LCDs. One problem is that TwinView is not working but we are also having several other problems with the actual nvidia driver.

We installed the most recent driver update through YOU updates in YAST2 and we dutifully edited the xorg.conf file to use Driver "nvidia", Load "glx", and ensured that the "dri" and "glcore" were not loaded. For some time we would get a black screen when starting X but after 5 reinstallations of Suse we now seem to be avoiding that.

Our problem now is that even though the nvidia driver loads, the system does not seem to be using the nvidia glx libraries. It is still loading the Mesa openGL. The results of ldd /usr/X11R6/bin/glxgears are here:

libGL.so.1 => /usr/lib64/libGL.so.1 (0x00002aaaaabc2000)
libXp.so.6 => /usr/X11R6/lib64/libXp.so.6 (0x00002aaaaad66000)
libXext.so.6 => /usr/X11R6/lib64/libXext.so.6 (0x00002aaaaae70000)
libX11.so.6 => /usr/X11R6/lib64/libX11.so.6 (0x00002aaaaaf81000)
libpthread.so.0 => /lib64/tls/libpthread.so.0 (0x00002aaaab190000)
libm.so.6 => /lib64/tls/libm.so.6 (0x00002aaaab2a6000)
libc.so.6 => /lib64/tls/libc.so.6 (0x00002aaaab3fd000)
libXxf86vm.so.1 => /usr/X11R6/lib64/libXxf86vm.so.1 (0x00002aaaab623000)
libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab729000)
/lib64/ld-linux-x86-64.so.2 (0x00002aaaaaaab000)

One problem we see is that libGLcore.so.1 does not show up there. We have seen many posts online about problems with the nvidia drivers and the resulting black screens, but there have been no reasonable solutions that we have seen so far. Does anyone have any suggestions?

Thanks.
alvarad is offline   Reply With Quote
Old 08-19-05, 01:51 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: openGL problems with QuadroFX 3400

Just search your system for all libGL.* (so, a ..) and the same for all libGLcore files. Remove all those files and reinstall the nvidia drivers. In most cases it works fine then if mesa stuff was around. (check /usr/lib, /usr/lib64, /usr/X11R6/lib, /usr/X11R6/lib/modules/extensions and so on)
Thunderbird is offline   Reply With Quote
Old 08-19-05, 01:57 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: openGL problems with QuadroFX 3400

alvarad,
Please see here for instructions on how to properly install the NVIDIA driver in SuSE-9.3:
ftp://ftp.suse.com/pub/suse/i386/sup...taller-HOWTO#4

You should not need to edit xorg.conf.

If you're still having problems with TwinView after (re)installing the nvidia driver per the instructions above, please generate & attach an nvidia-bug-report.log for review and detail how the problem can be reproduced.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-19-05, 04:16 PM   #4
alvarad
Registered User
 
Join Date: Mar 2005
Posts: 4
Default Re: openGL problems with QuadroFX 3400

Quote:
Originally Posted by Thunderbird
Just search your system for all libGL.* (so, a ..) and the same for all libGLcore files. Remove all those files and reinstall the nvidia drivers. In most cases it works fine then if mesa stuff was around. (check /usr/lib, /usr/lib64, /usr/X11R6/lib, /usr/X11R6/lib/modules/extensions and so on)
Thank you but this caused us to get the black screen again. We can now only boot using "nv" driver.
alvarad is offline   Reply With Quote
Old 08-19-05, 04:38 PM   #5
alvarad
Registered User
 
Join Date: Mar 2005
Posts: 4
Default Re: openGL problems with QuadroFX 3400

Quote:
Originally Posted by netllama
alvarad,
Please see here for instructions on how to properly install the NVIDIA driver in SuSE-9.3:
ftp://ftp.suse.com/pub/suse/i386/sup...taller-HOWTO#4

You should not need to edit xorg.conf.

If you're still having problems with TwinView after (re)installing the nvidia driver per the instructions above, please generate & attach an nvidia-bug-report.log for review and detail how the problem can be reproduced.

Thanks,
Lonni
Lonni -
Thanks for the information. We have tried to install using the directions you sent many times over the last two weeks. We did the install again just now using first YOU updates. Result: black screen when Driver set to "nvidia". Then we tried to install by downloading the NVIDIA-Linux-x86_64-1.0-7676-pkg2.run driver and compiling the kernel. Result: black screen.

WE CAN ONLY BOOT USING "nv" DRIVER.

Attached are the nvidia-bug-report.log and the nvidia-installer.log.

Thanks.
Attached Files
File Type: zip nvidia-bug-report.log.zip (29.6 KB, 120 views)
File Type: txt nvidia-installer.log.txt (27.2 KB, 140 views)
alvarad is offline   Reply With Quote
Old 08-19-05, 04:49 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: openGL problems with QuadroFX 3400

alvarad,
The bug report shows that your system is still using the 'nv' driver, which is known not to work with the Quadro FX3400. As such, your bug report didn't capture what is happening when you start X with the nvidia driver.
What command are you issuing that results in a 'black screen'? What are the results from running this command?
sax2 -m 0=nvidia

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-19-05, 04:54 PM   #7
alvarad
Registered User
 
Join Date: Mar 2005
Posts: 4
Default Re: openGL problems with QuadroFX 3400

Quote:
Originally Posted by netllama
alvarad,
The bug report shows that your system is still using the 'nv' driver, which is known not to work with the Quadro FX3400. As such, your bug report didn't capture what is happening when you start X with the nvidia driver.
What command are you issuing that results in a 'black screen'? What are the results from running this command?
sax2 -m 0=nvidia

Thanks,
Lonni
a black screen. We cannot even ssh into the machine when it is hung. So we cannot possibly capture the bug report when booting with nvidia driver.
alvarad is offline   Reply With Quote
Old 08-19-05, 05:00 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: openGL problems with QuadroFX 3400

If the system is hanging, please setup a serial console to capture any kernel messages that might be getting generated when this problem occurs. Also, you might want to try updating the kernel you're using as its not the most recent that SuSE has released for 9.3.

Thanks,
Lonni
netllama is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 09:55 AM
Unity 5.12 Fixes Ubuntu OpenGL Performance Problems News Archived News Items 0 06-11-12 02:20 PM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 10:58 PM
OpenGL SDK compilation problems gib bogle NVIDIA Linux 2 09-18-02 10:15 AM
Slow OpenGL on 7.3 kl899 NVIDIA Linux 1 08-04-02 08:58 PM

All times are GMT -5. The time now is 12:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.