Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-26-02, 06:33 AM   #1
hippynerd
Registered User
 
Join Date: Dec 2002
Posts: 3
Send a message via ICQ to hippynerd
Question glxinfo problem, RH8.0 & 4191

Hi,

I'm having problems with my glx libraries, if I try running glxinfo i get

glxinfo: relocation error: /usr/lib/libGLU.so.1: undefined symbol: __gxx_personality_v0

Also if I try making any of the demo mesa programs (i've followed the Nvidia OpenGL Configuration mini-HOWTO step by step), I'll get

../si-glu/.libs/libGLU.so: undefined reference to `operator new[](unsigned)'
../si-glu/.libs/libGLU.so: undefined reference to `vtable for __cxxabiv1::__si_c
lass_type_info'
../si-glu/.libs/libGLU.so: undefined reference to `operator delete(void*)'
../si-glu/.libs/libGLU.so: undefined reference to `__gxx_personality_v0'

etc when I attempt to make any of the files in the Mesa-5.0/demos dir

I've got the kernel-headers installed, I've run ldconfig, however I'm not sure how to run it properly.

I'm sure someone with a bit of exp could pick out whats wrong pretty quickly, if anyone can i'd appreciate it

running RH8.0, 2.4.18-14, just installed 4191 drivers, athlon 1.1ghz, geforce2mx

Last edited by hippynerd; 12-26-02 at 06:40 AM.
hippynerd is offline   Reply With Quote
Old 12-27-02, 12:32 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Looks vaguely like a problem where the linker doesn't understand C++... though GLU shouldn't EVER require a C++ linker.

Which libGLU are you using? Is it the one from Mesa, or right from the XFree86 package?

Is libstdc++ (and -devel) installed? What about gcc-c++? (or gcc-g++, I'm not sure which it is...)
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 12-27-02, 01:55 PM   #3
hippynerd
Registered User
 
Join Date: Dec 2002
Posts: 3
Send a message via ICQ to hippynerd
Default

Looks like i've got libstdc and gcc-c++ installed:

[root@potatojuice demos]# rpm -qa | grep libstdc
libstdc++-devel-3.2-7
libstdc++-3.2-7
compat-libstdc++-7.3-2.96.110

[root@potatojuice demos]# rpm -qa | grep gcc-c++
gcc-c++-3.2-7

I'm not too sure which libGLU i'm running (how can i find out?) I've got libGLU.so files in both /usr/lib/libGLU and /usr/X11R6/lib/

From my output in my previous post, it looks like both /usr/lib/libGLU.so.1 and ./usr/src/Mesa-5.0/.si-glu/.libs/libGLU.so had the same problem
hippynerd is offline   Reply With Quote
Old 12-27-02, 02:05 PM   #4
mtrr
Registered User
 
Join Date: Jul 2002
Location: Germany
Posts: 234
Send a message via ICQ to mtrr
Default

bwkaz: the si-glu needs indeed c++, ask SGI why

cheers
mtrr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
Screen flash briefly problem tamahome NVIDIA Windows Graphics Drivers 8 09-19-02 12:07 PM
Problem when compiling with SDL on Nvidia/Nforce... superconti NVIDIA Linux 3 09-13-02 12:25 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 09:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.