Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-06-05, 05:30 AM   #1
codfather
Registered User
 
Join Date: Sep 2005
Posts: 4
Default Problem with nvidia driver and Compaq Presario

Hello,
I have just bought the above machine, model SR1000, and I have successfully installed both Fedora core 4 and Mandriva 2005LE, which both work with the xorg driver "nv". I have tried installing both 7667 and 7676, which complete successfully, but lock the machine dead, when I modify xorg.conf to use the nvidia driver. It is 100% reproducable.

The kernel module is loaded successfully when checked using 'lsmod'.

Has anyone successfully got this working on this box or any similar compaq box?

Are there any known issues with the BIOS or BIOS settings on this box?

There are no clear markings on the card except for the following:
Lancer-210-MD4
HP PN 5187-4908
MS 8917 Ver 2.10

I have taken this card out, and placed it in another box, and it works fine with the nvidia driver installed in that box, so it's not the card, more the system setup somewhere.

Any hints and tips gratefully recieved, as this is driving me nuts ;-).

I have contacted Compaq support, and they use their standard line 'we are only trained to support Windoze.....blah blah blah'

I have both the Xorg.log and the nvidia-install.log if that would be of use.

TIA

Nick
codfather is offline   Reply With Quote
Old 09-06-05, 06:56 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Problem with nvidia driver and Compaq Presario

codfather,
Have you checked to see if there are any BIOS updates for the motherboard? Are you certain that the entire OS is locking up, and not just X?

Also, are you able to setup a serial console to capture any kernel messages when the system locksup?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-07-05, 02:48 AM   #3
codfather
Registered User
 
Join Date: Sep 2005
Posts: 4
Default Re: Problem with nvidia driver and Compaq Presario

Yes, the machine is locked, the keyboard becomes unresponsive, can't enable/disable num-lock etc, unable to re-start X with the usual ctrl-alt backspace, have to use the big red switch, not good.

I have not checked for a BIOS upgrade, but I will certainly have a look and give it a go.

I have noticed reading thorugh the forums about a BSOD, but that just seems to stop X, and not the machine like in my case.

Thanks for the reply.

Nick
codfather is offline   Reply With Quote
Old 09-07-05, 07:47 AM   #4
icanicant
Registered User
 
Join Date: Jun 2005
Posts: 2
Default Re: Problem with nvidia driver and Compaq Presario

I have a similar problem with a Compaq SR1440, but unfortunately have been unable to find a solution yet.

This machine has AMD64, MS7093 mobo, nVidia 6200 PCI-E. With the free "nv" drivers, the machine stays up forever. With the "nvidia" driver loaded (even without glx loaded), the machine regularly hangs completely. It sometimes runs for a few hours without crashing, but running something like glxgears crashes it within minutes.

I've got the latest Compaq bios updates, I've tried various versions of the drivers, I've fiddled with all the settings people recommend on this forum, I've tried running 32 and 64 bit, but nothing has worked for me. The fact that the card works with the free nv driver indicates that it's probably a bug in the nvidia drivers. I'm just using the free driver for now but unfortunately that leaves me with no TV out. I hope nVidia can figure this one out.
icanicant is offline   Reply With Quote
Old 09-07-05, 11:33 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Problem with nvidia driver and Compaq Presario

icanicant,
Are you able to setup a serial console to try to capture any kernel messages that might be getting generated when the system locks up? That would be most helpful in the debugging effort right now.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-07-05, 12:01 PM   #6
codfather
Registered User
 
Join Date: Sep 2005
Posts: 4
Default Re: Problem with nvidia driver and Compaq Presario

Netllama, do you have a link on how to set this console connection up, so I can get this info for you.

Cod
codfather is offline   Reply With Quote
Old 09-07-05, 02:26 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Problem with nvidia driver and Compaq Presario

Serial console instructions are included with the kernel source in /usr/src/linux/Documentation/serial-console.txt

Setting up a serial console is not difficult, however it requires a 2nd system, as well as a serial cable (also known as a null modem cable).

Attach the serial cable to the serial ports of the two systems.

On your target system, add the following additional kernel parameters:
console=ttyS0,9600 console=tty0

On the 2nd system, you can use 'screen' to capture the serial output:
screen /dev/ttyS0

Note that I referenced the first serial port, /dev/ttyS0, in my examples above. You can grep dmesg output for ttyS to see if your systems are using a different serial port.

If everything is setup correctly, you should see the boot time output in the serial console, and then you should also be able to capture any kernel messages that are generated when the system crashes.

thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-08-05, 03:37 AM   #8
codfather
Registered User
 
Join Date: Sep 2005
Posts: 4
Default Re: Problem with nvidia driver and Compaq Presario

I will do that this weekend, and post back the results.

Cod
codfather is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.