Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-07-05, 10:24 PM   #1
directedition
Registered User
 
Join Date: Nov 2004
Posts: 41
Default GLU missing?

hardware:
Geforce 6600 GT (PCI-Express)
Athlon 64 3000

software:
nvidia 7676 amd64
gentoo 2005.1

I finished setting up gentoo last night, but I'm stuck on the nvidia driver. It installed fine, but for some reason it won't install GLU libraries. Things like UT2004 installs fine and plays as it normally would. But most everything else gives me errors when I try to configure them.

Running configure on Armagetron gives me this:
You need GLU to compile Armagetron; it SHOULD have come with OpenGL.

compiling smpeg (which is needed for 90% of open source games) gives me this: x86_64-pc-linux-gnu/bin/ld: cannot find -lGLU
collect2: ld returned 1 exit status

Does anyone know why nvidia-installer doesn't give me GLU?

Thanks
directedition is offline   Reply With Quote
Old 09-08-05, 12:21 AM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: GLU missing?

Sorry, but gentoo doesn't use the nvidia installer. Instead it installs through emerge. You may have to do some crafty work to repair your system, eg use opengl-update.
whig is offline   Reply With Quote
Old 09-08-05, 02:48 AM   #3
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: GLU missing?

libGLU isn't shipped with the nvidia drivers depending on the distribution there's lets say a libGLU package or it is part of mesa and so on.
Thunderbird is offline   Reply With Quote
Old 09-08-05, 10:00 AM   #4
directedition
Registered User
 
Join Date: Nov 2004
Posts: 41
Default Re: GLU missing?

Would anyone know where libGLU is on Gentoo? As for the emerge nvidia thing, it installs a very old version of the driver that doesn't support my version of the card.
directedition is offline   Reply With Quote
Old 09-09-05, 12:37 AM   #5
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: GLU missing?

Run the command "emerge -s glu" and look at the results. To install a package in "testing" refer to this,

http://gentoo-wiki.com/Masked
whig is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Video Modes Enverex NVIDIA Linux 0 06-22-12 06:30 AM
NVIDIA 302.17 - missing apps: nvidia-settings, nvidia-installer, nvidia-xconfig zbiggy NVIDIA Linux 6 06-20-12 04:54 PM
IBM Courts the Missing Middle with Platform Computing and One-Stop Shopping News Archived News Items 0 06-04-12 10:20 AM
Missing GL extensions barole NVIDIA Linux 4 10-08-02 10:25 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 11:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.