Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-21-09, 01:15 PM   #1
penggull
Registered User
 
Join Date: Sep 2009
Posts: 4
Default I can't set up dual monitors with TwinView/Xinerama/Separate X

Hi, I installed Ubuntu Jaunty (64-bit) and I'm trying to make my two identical monitors work on it with an Nvidia Quadro FX580 gcard. I have installed the supported nVidia driver (180.44). In the Nvidia X Server Settings I could configure TwinView, but I get what I can only describe as 'color static' in a couple of columns. In the meantime the primary monitor looks perfect.

I tried the same hardware with Windows XP on it and I was able to set up everything perfectly. It seems to be a Linux issue.

Anybody have any idea?
penggull is offline   Reply With Quote
Old 09-25-09, 06:56 AM   #2
penggull
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: I can't set up dual monitors with TwinView/Xinerama/Separate X

bump
penggull is offline   Reply With Quote
Old 09-25-09, 02:21 PM   #3
AireTamStrm
Registered User
 
Join Date: Nov 2006
Posts: 49
Default Re: I can't set up dual monitors with TwinView/Xinerama/Separate X

What connections are the monitors using?
Do you have a picture of the behavior?

Could you show a screenshot of how you have nvidia-settings enabled?
Please send the output of the command "xrandr -q".
AireTamStrm is offline   Reply With Quote
Old 09-28-09, 01:01 PM   #4
penggull
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: I can't set up dual monitors with TwinView/Xinerama/Separate X

Hi!

The monitors have VGA out only, the Quadro has one DVI-I and two DisplayPorts. The monitor on the DVI-I works fine, the one on the DisplayPort doesn't.

I'm trying to attach a picture of the 'color static', hope it'll work. The picture is of the secondary monitor plugged into the DisplayPort.

I tried to tweak the Nvidia settings, but everything gives me the same output: the static on the secondary monitor. I tried TwinView, Xinerama, Separate X, the only difference is that with some settings I get a black second monitor, the primary always works. Help?

xrandr -q:

Screen 0: minimum 3840 x 1200, current 3840 x 1200, maximum 3840 x 1200
default connected 3840x1200+0+0 0mm x 0mm
3840x1200 50.0*
Attached Thumbnails
Click image for larger version

Name:	09282009.jpg
Views:	148
Size:	296.0 KB
ID:	38297  
penggull is offline   Reply With Quote
Old 09-28-09, 01:44 PM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: I can't set up dual monitors with TwinView/Xinerama/Separate X

Please try a newer driver (e.g. the 190.36 beta release). There have been a number of DisplayPort fixes since the 180.xx timeframe.
AaronP is offline   Reply With Quote
Old 10-09-09, 07:16 AM   #6
penggull
Registered User
 
Join Date: Sep 2009
Posts: 4
Default Re: I can't set up dual monitors with TwinView/Xinerama/Separate X

Phewww... This wasn't easy for a first time Linux user. (Even exiting X properly was a challenge, but on the upside I now know what it actually is, let alone exiting, restarting, I can do all... Ok, I can do a few things with X.) Eventually I got to install 190.36, which works fine-ish, thanks for the tip, AaronP!

Two questions though:
1/ In the X server settings I can set the primary monitor resolution to 1920x1200, which I should because its a 24" widescreen monitor. On the identical secondary monitor I can go only up to 1440x900. Why is that?

2/ After I installed the 190.36 driver, I ran an update on my system, lots of staff was installed, and the driver went to kaboom. I ended up reinstalling Ubuntu, running all the updates, and as a last step installing the driver. Now it works fine. But I'm worried to have to run a major update and it would compromise the graphics driver somehow. Is there a proper procedure to update (I run Update Manager) that would avoid all this?

Bottom line, I'm a happy Linux convert, multiple monitors was essential for this, thanks guys!
penggull is offline   Reply With Quote
Old 10-09-09, 10:15 AM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: I can't set up dual monitors with TwinView/Xinerama/Separate X

Thanks for trying it, penggull. I'm happy to hear that the new driver fixed the DisplayPort problem. As for your other two problems,
#1: Please run "nvidia-xconfig --mode-debug", restart X with both monitors attached, and then generate and attach an nvidia-bug-report.log.gz file.
#2: Please describe "kaboom" in more detail. When the kernel is upgraded, you'll need to reinstall the driver to build a kernel module for your newly-installed kernel. Similarly, if you upgrade the X server it may replace libglx.so with Mesa's, so you may need to reinstall the driver to fix that. This should all be documented in the README, so please let me know if the documentation was insufficient.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:36 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.