Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-29-08, 07:41 PM   #1
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default How can I play WMA files in Untuntu...

Ubuntu 8.04 would be the perfect alternative OS to Windows for me, if only I could play my music. I know I can alway burn all of my songs to CD, as either MP3s or regular audio CDs, and play 'em that way. But that's a lot of CDs, and a lot of burning.

So, I'm hoping somebody here might know of a simple way to get WMA files to play in Ubuntu. Is there a special application I should be using? Special plugin for a specific player? I tried installing Wine, and then Windows Media Player 11 and 10. But neither worked. Both would fail to start.

Any help is greatly appreciated.
Redeemed is offline   Reply With Quote
Old 03-30-08, 01:21 AM   #2
bacon12
Registered User
 
bacon12's Avatar
 
Join Date: Jul 2007
Posts: 3,532
Default Re: How can I play WMA files in Untuntu...

Quote:
Originally Posted by Redeemed
Ubuntu 8.04 would be the perfect alternative OS to Windows for me, if only I could play my music. I know I can alway burn all of my songs to CD, as either MP3s or regular audio CDs, and play 'em that way. But that's a lot of CDs, and a lot of burning.

So, I'm hoping somebody here might know of a simple way to get WMA files to play in Ubuntu. Is there a special application I should be using? Special plugin for a specific player? I tried installing Wine, and then Windows Media Player 11 and 10. But neither worked. Both would fail to start.

Any help is greatly appreciated.
Very easily... try this command "sudo apt-get install win-32 codecs", without the quotes.

If you wanna watch dvds go ahead and grab those as well, "sudo apt-get install libdvdcss2''

You may have to enable a different repo, so if that command doesn't find it try enabling universe, or multiverse I can't remember which.

Ubuntu has very good documentation, so check the wiki and forums, as any question you have in the future will most likely be answered there.
http://ubuntuforums.org/showthread.php?t=182902
bacon12 is offline   Reply With Quote
Old 03-30-08, 11:49 AM   #3
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: How can I play WMA files in Untuntu...

Quote:
Originally Posted by bacon12
Very easily... try this command "sudo apt-get install win-32 codecs", without the quotes.

If you wanna watch dvds go ahead and grab those as well, "sudo apt-get install libdvdcss2''

You may have to enable a different repo, so if that command doesn't find it try enabling universe, or multiverse I can't remember which.

Ubuntu has very good documentation, so check the wiki and forums, as any question you have in the future will most likely be answered there.
http://ubuntuforums.org/showthread.php?t=182902
Hey, thanks! I cannot get WMAs to play, but I did get a DVD to play- although there were visual artifacts. I'll try what you recommended and see if that solves the issue.
Redeemed is offline   Reply With Quote
Old 03-30-08, 11:52 AM   #4
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: How can I play WMA files in Untuntu...

It said "couldn't find package win-32". I tried multiple times, making sure I typed it correctly. Nothing.
Redeemed is offline   Reply With Quote
Old 03-30-08, 12:24 PM   #5
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: How can I play WMA files in Untuntu...

Well, all the methods I've seen so far are for Ubuntu 7.10- I'm running the 8.04 beta. It appears I might be out of luck.

Oh well, guess I can just hook my MP3 player directly to my stereo and enjoy my tunes that way. As for DVDs... I seldom watch any. Was just in a 3:10 To Yuma mood last night. I can wait till later this week when I get my Vista rig put together. Thanks for the input though.
Redeemed is offline   Reply With Quote
Old 03-30-08, 03:59 PM   #6
bacon12
Registered User
 
bacon12's Avatar
 
Join Date: Jul 2007
Posts: 3,532
Default Re: How can I play WMA files in Untuntu...

Redeemed try to open synaptic, and go into settings>> repositories. Enable the mulitverse repo, (by ticking the box)

First do "sudo apt-get update"
Then "sudo apt-get install win-32 codecs"

That should grab them for you, I would also suggest you install amarok, as it is the best media audio player IMHO. You can find it with a synaptic search.

They have to keep the non free, or "dirty" codecs in a non standard repo because of legal reasons. I think they are all hosted in the UK.
bacon12 is offline   Reply With Quote
Old 03-30-08, 05:16 PM   #7
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: How can I play WMA files in Untuntu...

Quote:
Originally Posted by bacon12
Redeemed try to open synaptic, and go into settings>> repositories. Enable the mulitverse repo, (by ticking the box)

First do "sudo apt-get update"
Then "sudo apt-get install win-32 codecs"

That should grab them for you, I would also suggest you install amarok, as it is the best media audio player IMHO. You can find it with a synaptic search.

They have to keep the non free, or "dirty" codecs in a non standard repo because of legal reasons. I think they are all hosted in the UK.
Multiverse is enabled already. I'll try that again though...

"Couldn't find package win-32" is what it says.
Redeemed is offline   Reply With Quote
Old 03-30-08, 08:20 PM   #8
bacon12
Registered User
 
bacon12's Avatar
 
Join Date: Jul 2007
Posts: 3,532
Default Re: How can I play WMA files in Untuntu...

Hmmmm. Do you mind if I point you to a small forum where I know you can get help with this? I will pm you the details.
bacon12 is offline   Reply With Quote

Old 05-14-08, 10:42 AM   #9
AyIi
Registered User
 
Join Date: May 2008
Posts: 2
Default Re: How can I play WMA files in Untuntu...

The codecspack is called "w32codecs", isnt it? So first add the medibuntu-repo for hardy:
sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list
Then add the GPG Key:
sudo apt-get update && sudo apt-get install medibuntu-keyring && sudo apt-get update
When its done you should be able to install the codecs with: sudo apt-get install w32codecs
EDIT: Well I should look at the date... maybe its helpfully for others
AyIi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockstar condemns Max Payne 3 cheaters to play only against each other News Gaming Headlines 0 06-13-12 06:20 PM
DivX Play 8.2.3 News Latest Tech And Game Headlines 0 06-13-12 06:00 AM
US argues it shouldn't have to give Megaupload user his legit files News Latest Tech And Game Headlines 0 06-11-12 01:20 PM

All times are GMT -5. The time now is 04:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.