Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-18-05, 05:20 PM   #1
beettlle
Registered User
 
Join Date: Sep 2005
Posts: 8
Default NVIDIA driver not working in Gentoo with MM kernel

I've been trying all weekend to get the NVIDIA driver to work in my Linux box. It worked before but I decided to dable with Reiser4, therefore the mm-kernel. I'm gettin' this.

Code:
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.
I'm attaching the NVIDIA log.

Any help would be awsome.
Attached Files
File Type: txt nvidia.txt (45.2 KB, 138 views)
beettlle is offline   Reply With Quote
Old 09-18-05, 08:26 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA driver not working in Gentoo with MM kernel

If this problem reproduces with the 1.0-7676 driver, please post an updated bug report. 1.0-6629 is no longer supported.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-19-05, 12:19 AM   #3
beettlle
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: NVIDIA driver not working in Gentoo with MM kernel

Thanks for the reply. Same difference with the new driver. Any ideas?

Quote:
Update: Ok, I played with it some more, re-emerge-ed the nvidia-glx and now it works. Thanks a bunch!
Attached Files
File Type: txt nvidia-bug-report.txt (41.1 KB, 139 views)
beettlle is offline   Reply With Quote
Old 09-19-05, 11:21 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA driver not working in Gentoo with MM kernel

Its not clear from your last comment whether you're still having problems, or if you got this to work.
netllama is offline   Reply With Quote
Old 09-19-05, 11:26 PM   #5
beettlle
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: NVIDIA driver not working in Gentoo with MM kernel

Sorry, the problem was solved. I can get X running now, but, again, the locking problem's back. If I let X run for a while, or run something that's very OpenGL intensive (Enlightenment 17) X locks up. I know this is a known problem from the old drivers and thought it was fixed. Again, I'm attaching the debug information. Thank you very much for all the help.
Attached Files
File Type: txt nvidia-bug-report.txt (67.6 KB, 143 views)
beettlle is offline   Reply With Quote
Old 09-20-05, 12:17 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA driver not working in Gentoo with MM kernel

Do you have a reliable means of triggering the lockups or are they completely random?

Also, what kind of motherboard are you using, and have you ensured that you're running the most recent BIOS?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-22-05, 01:30 AM   #7
beettlle
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: NVIDIA driver not working in Gentoo with MM kernel

The motherboard I'm using is a Tyan Tiger MP K7. I had some problems with the default BIOS setting after flashing it with the latest greatest flash Tyan has on their website. Now that I got it to boot again I'm getting the same behaviour.

There is no "reliable" way of trigering the lockup. It seems that it does it when I'm running something OpenGL intensive. Under Gnome, if I leave glxgears running to long it locks up. But it also happens if I don't run any OpenGL code, but then it usualy takes longer to lock up (hours instead of minutes). I'm playing with Enlightenment 0.17 which is supposed to be all OpenGL and it locks up very fast when I run it (1 or 2 minutes to lock up).

Any other info I can give you that might help?

Thanks for the help,

-Cesar
beettlle is offline   Reply With Quote
Old 09-22-05, 10:51 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA driver not working in Gentoo with MM kernel

Is the system stable if you're not using the mm kernel (and just 2.6.14.1)? Do you have the capacity to setup a serial console to try to capture any kernel messages that correspond with the lockup?

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 09-22-05, 12:51 PM   #9
beettlle
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: NVIDIA driver not working in Gentoo with MM kernel

I don't have any machines with serial, my other machine's an Apple laptop and I don't have a USB-to-serial adapter. I'm going to ask around and see what I can find. Could I catch any of the kernel messages if I increase my syslog level?

I can't run the vanilla 2.6 kernel because I have a couple of partitions, more specificaly /home and where my music and videos are, with ReiserFS4.

Thanks,

-Cesar
beettlle is offline   Reply With Quote
Old 09-22-05, 01:11 PM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA driver not working in Gentoo with MM kernel

The problem is that if the system is locking up, its unlikely that anything is being written to disk at the time of the lockup, and therefore no kernel messages will be captured, regardless of the debug level of syslogd.

-Lonni
netllama is offline   Reply With Quote
Old 09-22-05, 01:25 PM   #11
beettlle
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: NVIDIA driver not working in Gentoo with MM kernel

Just for S&G I decided to try to ssh into the machine. The machines hasn't looked up, it's just X that doesn't let me do anything so I manualy killed X. So I may be a ble to get something out of syslog.

-Cesar
beettlle is offline   Reply With Quote
Old 09-22-05, 01:33 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NVIDIA driver not working in Gentoo with MM kernel

If you can ssh in while X is hung, please generate a new bug report while its in that hung state.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 05:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 12:04 PM
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 09:30 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 07:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.