Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-07-05, 05:12 PM   #1
tonicwasser
Registered User
 
Join Date: Oct 2005
Posts: 10
Default Linux on NForce 430 + GeForce 6150

Does anyone have any experience or advice with regard to running Linux on new NForce 430 / GeForce 6150 based motherboards?

How well is the support for SATA Harddisk? Is the SATA AHCI compatible? Can I boot from a SATA harddisk? How well is the support for audio? What about graphics and gigabit Ethernet?

Do I need the Nforce binary driver or is the in kernel support OK for the various devices? Is the NVIDIA graphics driver ready for GeForce 6150?

I am thinking about buying an Asus A8N-VM CSM Socket 939 Micro-ATX motherboard and run Ubuntu 5.10 (kernel 2.6.12) on it. Is it possible or a futile exercise? Should I buy the Asus A8V-MX with VIA K8M800 chipset instead?

Regards, TW
tonicwasser is offline   Reply With Quote
Old 10-08-05, 11:25 AM   #2
sobitthen
Need 6150/430 advice.
 
Join Date: Oct 2005
Location: Superior, WI
Posts: 6
Send a message via MSN to sobitthen Send a message via Yahoo to sobitthen
Default Re: Linux on NForce 430 + GeForce 6150

Same question basically, awaiting arrival of Foxconn 6150/430 based motherboard and a RedHat FC4-64 install. Setting up a media based pc in bedroom and apps for new ATI Theater550 for windows drove me to linux solution. Setting up FC3-64 on a Asus K8V was a breeze, hoping for same luck. So... BUMP
sobitthen is offline   Reply With Quote
Old 10-10-05, 11:39 PM   #3
sobitthen
Need 6150/430 advice.
 
Join Date: Oct 2005
Location: Superior, WI
Posts: 6
Send a message via MSN to sobitthen Send a message via Yahoo to sobitthen
Question Re: Linux on NForce 430 + GeForce 6150

Ended up getting the BIOSTAR NF4 TForce6100-939 motherboard due to backorder of the FoxConn. Anyone have any sucess running this series board under Linux yet?

Thanks..
sobitthen is offline   Reply With Quote
Old 10-11-05, 12:26 PM   #4
cmfans
Registered User
 
Join Date: Oct 2005
Posts: 1
Default Re: Linux on NForce 430 + GeForce 6150

I use ASRock K8NF4G-SATA2 Nforce 410 + Geforce 6100 with an WD SATA 80G hard disk ,I can install Suse 10 and I can use Nforce audio to enable the Nforce 410 ac97 sound card ,but the Nvidia graphic driver version 7676 can not enable my Geforce 6100 graphic card , I feel so sad now .
cmfans is offline   Reply With Quote
Old 10-11-05, 08:08 PM   #5
sobitthen
Need 6150/430 advice.
 
Join Date: Oct 2005
Location: Superior, WI
Posts: 6
Send a message via MSN to sobitthen Send a message via Yahoo to sobitthen
Default Re: Linux on NForce 430 + GeForce 6150

so you were not able to use the onboard video? did you install with a separate video card? According to nvidia.. laugh.. they said only drivers that would be needed are for LAN and audio.
sobitthen is offline   Reply With Quote
Old 10-12-05, 09:22 PM   #6
pdrongowski
Registered User
 
Join Date: Aug 2005
Posts: 7
Smile Re: Linux on NForce 430 + GeForce 6150

Hi --

I bought the Tforce 6100-939, too. I plan to add a discrete graphics
board eventually, so didn't wait for the 6150.

The CPU is an Athlon64 X2 4400+. I've been able to boot Fedora Core 4,
but not the Fedora SMP kernel. I didn't have any luck at all with SuSE 9.3.
Not relevant to Linux users, but I also managed to install Windows XP
Pro 64-bit.

I wish I had more to report (like trying Nvidia drivers), but I've been
on the road!

I agree that a 6150-based HTPC looks sweet. Albatron has a board in
the works that has DVI output instead of VGA.

-- pj
pdrongowski is offline   Reply With Quote
Old 10-14-05, 09:55 AM   #7
cifs
Registered User
 
Join Date: Jul 2005
Posts: 17
Default Re: Linux on NForce 430 + GeForce 6150

Just bought the K8NF4G-SATA2 and desprately need the Nvidia graphics drivers to work ... Had to recomple kernel to use only BIOS access to PCI, recompile the 7676 video driver ... Just crashes my machine. ANY help would be apprecitated as I need to get this going for product release.... HELP HELP... The system just crashes to the point of not writing any additional log information in the X log. The kernel driver loads, but when activated, crashes.
cifs is offline   Reply With Quote
Old 10-14-05, 09:33 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Linux on NForce 430 + GeForce 6150

The GeForce 61xx GPU will be supported in the next Linux driver release (1.0-8xxx).

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 10-18-05, 12:06 PM   #9
tabanus
Registered User
 
Join Date: Oct 2005
Posts: 37
Default Re: Linux on NForce 430 + GeForce 6150

Having realised the video is not going to work with this board (the ASRock K8NF4G-SATA2), at least until the next driver release, I moved onto the audio. Oh joy! ALSA doesn't work either

Has anyone managed to get ALSA working using the intel i8x0 driver provided in-kernel with this board? The documentation says its an AC97 chip so it should, but it doesn't.

Rapidly regretting buying this POS.
tabanus is offline   Reply With Quote
Old 10-18-05, 12:16 PM   #10
kozaki
Registered User
 
Join Date: Oct 2005
Posts: 1
Default Re: Linux on NForce 430 + GeForce 6150

Thank you netllama & tabanus !
As i'm looking for a decent integrated Video mainboard for my Linux box, & now know I'll better take an old s3 (or wait quite a bit before taking nVidia GeForce 61x0)
__________________
Open Source <=> it's still time to try guys
kozaki is offline   Reply With Quote
Old 10-20-05, 04:44 AM   #11
tonicwasser
Registered User
 
Join Date: Oct 2005
Posts: 10
Default Re: Linux on NForce 430 + GeForce 6150

Hi guys, thank you for your feedback!

Status so far:
- Suse 10 (kernel 2.6.13) installs and boots on SATA drive.
- Suse 9.3 (kernel 2.6.11) does not work (install? boot? SATA/IDE?).
- Fedora Core 4 (kernel 2.6.11) boots (SATA/IDE?).
- NVidia current graphics driver does not work, but will work from 1.0-8xxx. (ETA not known).
- Nforce driver (version?) supports audio in Suse 10.

Please correct any errors and add additional information if possible. Can you help with the following:
- Does ethernet work with the in-kernel forcedeth driver?
- Does the X.org nv video driver work? (I assume VESA works?)
- Does in-kernel audio work?
- Does USB work out of the box?
- Does firewire work out of the box?
- Can someone provide a 'lspci' printout?
- Does anyone have experience with Ubuntu 5.10 (or kernel 2.6.12)?
- Please remember to write motherboard, distribution (or kernel version) and other relevant information (SATA/IDE drive, x.org version, driver version etc.).

-- Regards,
tonicwasser is offline   Reply With Quote
Old 10-20-05, 06:14 AM   #12
tabanus
Registered User
 
Join Date: Oct 2005
Posts: 37
Default Re: Linux on NForce 430 + GeForce 6150

Quote:
Originally Posted by tonicwasser
Hi guys, thank you for your feedback!

- Does ethernet work with the in-kernel forcedeth driver?
- Does the X.org nv video driver work? (I assume VESA works?)
- Does in-kernel audio work?
- Does USB work out of the box?
- Does firewire work out of the box?
- Can someone provide a 'lspci' printout?
- Does anyone have experience with Ubuntu 5.10 (or kernel 2.6.12)?
- Please remember to write motherboard, distribution (or kernel version) and other relevant information (SATA/IDE drive, x.org version, driver version etc.).

-- Regards,
On my 6100 board, I have:
Ethernet: works perfectly with kernel drivers
xorg: nv and nvidia don't work. Vesa works to get a usable desktop, but otherwise awful, poor refresh rate. I don't know about opengl or any other 3D stuff, not got that far. When you use a PC for word processing, spreadsheets and the like, it's just unacceptable for me to have a vertical refresh rate <75Hz
Audio: In-kernel nvidia AC97 module doesn't work. Alsa-driver doesn't work. Not tried nVidia's own OSS sound implementation. After all, the nVidia video driver doesn't work, why would the sound? [edit: I see that cmfans managed to get sound working]
USB: Not got that far yet (spent past week trying to get video & sound to work).
Firefwire: No idea, never used it.
I'll run lspci when I get home & edit this post.

Mine is a brand new board, and I'm prepared to cut nvidia some slack and give them time to release working drivers, but there's an awful lot of people getting black screens with supposedly working drivers.

[EDIT]
Output of lspci:

0000:00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
0000:00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
0000:00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
0000:00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
0000:00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
0000:00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
0000:00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
0000:00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
0000:00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
0000:00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
0000:00:05.0 VGA compatible controller: nVidia Corporation C51 PCI Express Bridge (rev a2)
0000:00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
0000:00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a2)
0000:00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a2)
0000:00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
0000:00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a2)
0000:00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
0000:00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
0000:00:10.2 Multimedia audio controller: nVidia Corporation MCP51 AC97 Audio Controller (rev a2)
0000:00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

This board is supposed to have on-board AC97 modem, but I disabled that in BIOS because, well, nvidia don't support it in Linux (and I don't need it).
tabanus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-16-12 04:12 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-13-12 02:38 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released artem NVIDIA Linux 0 06-11-12 11:25 AM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
Nforce audio & linux nichos NVIDIA Linux 1 10-05-02 04:16 AM

All times are GMT -5. The time now is 12:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.