Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-07-05, 10:28 AM   #97
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Linux on NForce 430 + GeForce 6150

syntho,
The ConnectedMonitor option cannot be used like that. Its sole purpose is to inform the driver about a display device that it cannot detect under normal conditions. ConnectedMonitor cannot be used to instruct the driver which display device to use when more than one is detected.

Victor,
You're not calling the glx X module (although that should not be fatal).

Please try using the IgnoreDisplayDevices option, to instruct the driver to ignore the phantom TV.

If that doesn't help, please start X with the following command:
startx -- -logverbose 5
and generate and post an updated bug report.

Also, your bug report doesn't have an xorg.conf. Does /etc/X11/xorg.conf exist on your system? I'm wondering if your real problem is that you have no xorg.conf, so the driver is falling back to what it considers to be safe defaults.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-07-05, 10:32 AM   #98
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Linux on NForce 430 + GeForce 6150

The IgnoreDisplayDevices option (see http://download.nvidia.com/XFree86/L...ppendix-d.html) might also help, you can use it to prevent the fals TV display device detection.
zander is offline   Reply With Quote
Old 12-07-05, 01:48 PM   #99
vedragan
Registered User
 
Join Date: Nov 2005
Posts: 12
Talking Re: Linux on NForce 430 + GeForce 6150

Quote:
Originally Posted by zander
The IgnoreDisplayDevices option (see http://download.nvidia.com/XFree86/L...ppendix-d.html) might also help, you can use it to prevent the fals TV display device detection.
Hello zander, Lonni,
Hallo Robert, Hi syntho,

Wow! It works!!! Really-really! I write you from 1600x1200 (I have to makes the fonts bigger ;-)).



Well it did work indeed:
Option "IgnoreDisplayDevices" "TV-0"
I put in the same time also a
Option "ConnectedMonitor" "DFP-0"
for a better team work!

got from glxgear 1777.000 FPS



@ROBERT hier sind die Anleitungen:

And now the procedure for SUSE:
As you know the sax2 (to read: sucks 2 times) is the proposed tool to do X configuration on SUSE (by NVidia itself). sax2 -m 0=nvidia should do the job. Usually... Or a black blank screen by me... Until a not correct run of sax2 there is NO xorg.conf (would be possible eventually to grab one form Sax.log but hmmm better forget it). Therefore:
1. run sax2 -m 0=vesa
2. Configure correctly your monitor!!!
3. Give in the desired capabilities (resolution,color)!!! VESA will stay in 1024x800 but you must do the job!
4. Look quicklly to your VESA screen and get out before you feel the pain...
5. Text mode feels good... Isn't it?
6. run the nvidia-xconfig
7. fire up an editor (pico. nano, vi) and edit xorg.conf
8. search for "nvidia" (should be in the section device) and add the folowing two Options like this:
---
Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "Framebuffer Graphics"
Option "ConnectedMonitor" "DFP-0"
Option "IgnoreDisplayDevices" "TV-0"

EndSection

---
9. You should be able to enjoy your SUSE + +ASUS CSM+ 6150 + 430

@ROBERT I really hope that you use the DVI. If you use the CRT (VGA) please
change the "DFP-0" to "CRT-0".

I attached my xorg.conf to protocol.

Thanks to everybody!!!

Viel Glück Robert!

Disclaimer: If you burn down your monitor, computer and your house I am not responssible.
Attached Files
File Type: zip xorg.conf.zip (1.8 KB, 371 views)
vedragan is offline   Reply With Quote
Old 12-07-05, 08:22 PM   #100
rsrtfm
Suse user
 
Join Date: Nov 2005
Location: Boston,MA
Posts: 37
Thumbs up Re: Linux on NForce 430 + GeForce 6150

Hallo vedragan,
erst mal danke, werde es mal am freitag versuch, zur zeit auf Geschaefts reise,.
waere ja gut wenns, functionieren wuerde,...sieht ja einfach aus,...

so , if it is so easy,.... ignore,...tv.... maybe nvidia , can put it in the documentation,...
I'am sure a lots of 6100 and 6150 motherboard users are waiting for it,...
I'll try it on friday,.... will report back,... meanwhile,...throw some more snowballs,...
-------------------------------------- (NVIDIA)
cheers, Robert Schultz

Quote:
Originally Posted by vedragan
Hello zander, Lonni,
Hallo Robert, Hi syntho,

Wow! It works!!! Really-really! I write you from 1600x1200 (I have to makes the fonts bigger ;-)).



Well it did work indeed:
Option "IgnoreDisplayDevices" "TV-0"
I put in the same time also a
Option "ConnectedMonitor" "DFP-0"
for a better team work!

got from glxgear 1777.000 FPS



@ROBERT hier sind die Anleitungen:

And now the procedure for SUSE:
As you know the sax2 (to read: sucks 2 times) is the proposed tool to do X configuration on SUSE (by NVidia itself). sax2 -m 0=nvidia should do the job. Usually... Or a black blank screen by me... Until a not correct run of sax2 there is NO xorg.conf (would be possible eventually to grab one form Sax.log but hmmm better forget it). Therefore:
1. run sax2 -m 0=vesa
2. Configure correctly your monitor!!!
3. Give in the desired capabilities (resolution,color)!!! VESA will stay in 1024x800 but you must do the job!
4. Look quicklly to your VESA screen and get out before you feel the pain...
5. Text mode feels good... Isn't it?
6. run the nvidia-xconfig
7. fire up an editor (pico. nano, vi) and edit xorg.conf
8. search for "nvidia" (should be in the section device) and add the folowing two Options like this:
---
Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "Framebuffer Graphics"
Option "ConnectedMonitor" "DFP-0"
Option "IgnoreDisplayDevices" "TV-0"

EndSection

---
9. You should be able to enjoy your SUSE + +ASUS CSM+ 6150 + 430

@ROBERT I really hope that you use the DVI. If you use the CRT (VGA) please
change the "DFP-0" to "CRT-0".

I attached my xorg.conf to protocol.

Thanks to everybody!!!

Viel Glück Robert!

Disclaimer: If you burn down your monitor, computer and your house I am not responssible.
__________________
grew up on Sun Os, now got forced on windoz, at home trying to survive on SuSe linux,....
rsrtfm is offline   Reply With Quote
Old 12-09-05, 08:08 AM   #101
sandre48
Registered User
 
Join Date: Dec 2005
Posts: 1
Default Re: Linux on NForce 430 + GeForce 6150

Hello, It is the first time I post a message. I am interested in the Asus A8N-VM CSM motherboard for a LINUX use ; that why I follow with great interest everything you are doing in order to solve the related problems.
I am not a LINUX spécialist and I would want to be sure someone has tried the new NVIDIA driver (Linux-x86-1.0-8174-pkg1.run) downloadable from NVIDIA site from the 6th of december and what are the results ?
sandre48 is offline   Reply With Quote
Old 12-09-05, 10:57 AM   #102
nclaude
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Re: Linux on NForce 430 + GeForce 6150

asus a8n-vm csm amd3200+
bios 0506
kernel 2.6.15-rc5 custom
distribution debian etch x86
lcd monitior VP191b (1280*1024*24)
windowmanager windomaker


I have problems with the new driver.

Sometime it works and glxgears gives 1748 fp/s
but there are strange messages in dmesg/syslog


Sometine it doesn't work. There is a green screen with grey boarder. I think the green is a part of may root window

I generated a bug report file.

thanks for help

claude
Attached Files
File Type: txt reppe-nv-work-dmesg.txt (1.7 KB, 293 views)
File Type: zip reppe-nvidia-bug-report.log.zip (20.8 KB, 265 views)
nclaude is offline   Reply With Quote
Old 12-09-05, 01:18 PM   #103
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Linux on NForce 430 + GeForce 6150

Claude,
Please apply the patches from this thread and it should resolve those messages:
http://www.nvnews.net/vbulletin/showthread.php?t=61052

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-09-05, 01:42 PM   #104
rsrtfm
Suse user
 
Join Date: Nov 2005
Location: Boston,MA
Posts: 37
Angry Re: Linux on NForce 430 + GeForce 6150

update,.....
- 10.1 alpha 3,.... did ignore TV-0,... CRT-0,...
at least seams, it does not lockup,... no 3D, glxgears not running,...argh,...
8174 driver,...

need help:
- opensuse, super
the RC slick, did not install, errors,
- so the super version installed,... great, running on nv,... glxgears 477,....
- tried 8174 to install,... "apears to be running X server",....
&%$#%$#^%#$,...banging head on the wall,.....
help, how can I get around this,....? please,!!!!!!!!!!!!!!!!!!!111
ok, boot in single,..... init 3,... ps -edalf, no f&^% x server running,...
what am I supose to do? any hints please....
----------------------
- online update,... nvidia.sh,....
oh, great, now it locks up again,....,
why, like to get off the alpha release,... on my laptop, the opensuse super , runs great,...
tried the suse 64,... could not get it up stable,...
cheers, Robert Schultz -------------------------------- (NVIDIA)
__________________
grew up on Sun Os, now got forced on windoz, at home trying to survive on SuSe linux,....
rsrtfm is offline   Reply With Quote

Old 12-09-05, 03:13 PM   #105
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Linux on NForce 430 + GeForce 6150

Runlevel 3 does not normally have X running. You need runlevel 5 for X on SuSE.

-Lonni
netllama is offline   Reply With Quote
Old 12-09-05, 09:08 PM   #106
rsrtfm
Suse user
 
Join Date: Nov 2005
Location: Boston,MA
Posts: 37
Thumbs down Re: Linux on NForce 430 + GeForce 6150

yeah, that's why it pisses me off,.... boot single user, init 3, multi, init 3,... no go,....ps -edalf | grep X,kde,gdm,x, what ? it's f*^ not running,
and can't get the damn installer to work,.... why not have a force , ignore switch,.... PLEASE!!!
well, changed, xorg.conf to vesa,... removed 7676 driver,...
for some reason, was able to install new driver,... glxgears from 470 to 3500,... this new stuff is buggy,....

what needs to be fixed, is the online update in suse, overwrites the existing ,
nv driver, what , at least has glx, 3d support, glxgears, 470,.. but works,
after update, because no patches are applied, on standard 2.6.13 screen,
will suffere the lockups and black screen,.... and suse users will do online-update,.. because it's recommended,... needs to be fixed,....
yeah, no,.... it's not nvidias responsibility,.... well in that case, ignorance is bliss,....
so far, I'am not done,... ctl-alt backspace, is the fastest, to switch, since it takes up to an minute,... otherwise,...and did lockup the box,...
sound,... ad1986a, is not working,.... here we go again,... not nvidia,....
well, the motherboard is advertised as an 6150, with 430, integrated, video, and sound, and lan,... how would one know it's not,... read the fineprint,....
roll it into the driver,... since there are only a few 6150, 430 motherboards,....
and you do want to beat intel,... work with asus, gigabyte, foxconn,...
have it working,... same for the nic,... and some basic linux irq's, apics,...
just got an foot of snow,.. so I have plenty of amunition,....
-------------------------------- (NVIDIA)
cheers, Robert Schultz merry N-MAS (xmas,) or should be merry, N-mess
Quote:
Originally Posted by netllama
Runlevel 3 does not normally have X running. You need runlevel 5 for X on SuSE.

-Lonni
__________________
grew up on Sun Os, now got forced on windoz, at home trying to survive on SuSe linux,....
rsrtfm is offline   Reply With Quote
Old 12-10-05, 02:01 PM   #107
KenWoodland
Registered User
 
Join Date: Dec 2005
Posts: 17
Default Re: Linux on NForce 430 + GeForce 6150

My update on the ASUS A8N-VM CSM:

Environment: Knoppmyth A22 (Linux 2.6.13.2-chw-3)

Network: Working with forcedeth, used patches to bring it up to revision 0.47.

IDE, SATA: Working.

USB (Zapstream remote / USB pen drive): Working.

ACPI: Working with patch. (Waiting for ASUS to fix it's BIOS like everyone else.) But for now I patched utmisc.c in utilities to allow one invalid character in the namespace before reporting and error.

Audio: Working. I found a note by someone on the net who had a different motherboard with the AD1986A chip on it that had the same sound problems we are all having on the ASUS. He gave a temp patch that removes sourround sound channel support in order to make the regular stereo support work. This is a ALSA bug. (Downloaded ALSA 1.0.10, modified hda_codec.c).

Video (On board 6150): X working, glxgears working, XvMC is not working!
Using the latest 8174 drivers I can not seem to get XvMC working, has anyone had any sucess with this? I have checked /etc/X11/XvMCConfig and made sure it points to the right place. Both Mythtv and mplayer do not seem to be able to use XvMC. (They try but fail).

How do I verify that XvMC works with the 8174 drivers on this motherboard?
KenWoodland is offline   Reply With Quote
Old 12-11-05, 05:59 AM   #108
nclaude
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Re: Linux on NForce 430 + GeForce 6150

Quote:
Originally Posted by netllama
Claude,
Please apply the patches from this thread and it should resolve those messages:
http://www.nvnews.net/vbulletin/showthread.php?t=61052

Thanks,
Lonni
The patches relove the messages.
With the option "irqpoll" the driver always works.

Thanks lonni.

claude
nclaude is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-16-12 04:12 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-13-12 02:38 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released artem NVIDIA Linux 0 06-11-12 11:25 AM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM
Nforce audio & linux nichos NVIDIA Linux 1 10-05-02 04:16 AM

All times are GMT -5. The time now is 11:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.