Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-14-05, 03:09 PM   #1
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default GeForce 6200 freezes and no video

I am having problems with intermittant freezing of video while playing Quake 3 Arena and no updates to the display.

If I run Quake 3 in fullscreen I get a blank screen from the start and I can hear the game sound. Its as if the screen is not drawing.

I edit the game configuration manually to disable fullscreen and then restart the game. The window shows a blank screen when the game starts but when I pull another window over the top of the game window it starts working. I can then play for 15 minutes or so and the game suddenly freezes for about 30 seconds and then starts again but the window no longer updates. I can here the game sounds as it continues to play but the video in the frame does not update. If I then pull another window over the frame its starts to draw again and plays fine for another 15 minutes.

It is an Asus N6200/TD/128 GeForce 6200 128MB AGP 4x/8x video card in a Shuttle MK40VN motherboard with Fedora Core 4 and the 7676 version Nvidia driver.

I've tried installing Fedora Core 3 and downgrading to older versions of the Nvidia driver but I get the same problem. I installed an older GeForce 5900FX from another box and the problem goes away. So it is specific to the GeForce 6200 card.

I'll post a bug log tonight after work. I was going to ssh in and create the bug log but I forgot to enable the ethernet card so I cannot get to the box at the moment.
burnin1965 is offline   Reply With Quote
Old 10-14-05, 09:13 PM   #2
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

Okay, as promised I've attached the nvidia-bug-report log file.

As a side note, the shell script saves the file with the extension .log but the upload scripts for the forum will not accept .log so I changed it to .txt.

burnin
Attached Files
File Type: txt nvidia-bug-report.txt (57.3 KB, 422 views)
burnin1965 is offline   Reply With Quote
Old 10-14-05, 09:29 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 6200 freezes and no video

In addition to the bug log, also post the output from running 'glxinfo'.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-14-05, 10:16 PM   #4
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

Here it is Lonni.

BTW, I was looking at the bug log and noticed I was still running the older 7667 driver. I reinstalled the 7676 driver before running glxinfo. If I need to rerun the bug log let me know.

And thanks for taking a look.

burnin
Attached Files
File Type: txt glxinfo.txt (7.2 KB, 167 views)
burnin1965 is offline   Reply With Quote
Old 10-14-05, 10:45 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 6200 freezes and no video

I have a few questions:
0) Does this problem happen with any other OpenGL applications, such as glxgears?
1) When Quake stops rendering, if you start glxgears, does it render?
2) Is there a reason why you're running X with a color depth of 16 instead of 24? Have you tested whether this problem also occurs with 24bpp?
3) Can you test while setting NvAGP=1 ?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-14-05, 11:12 PM   #6
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

0) So far the problem only happens with Quake 3. I have Neverwinter Nights and Unreal Tournament 2004, but I have not installed them yet because of the problem in Quake 3.

glxgears seems to run fine, no blank screen on start, but I haven't watched it long enough to see if it eventually freezes. I'll try firing up glxgears and pipe the frame rate output to a file to see if it eventually freezes as well.


1) I actually started glxgears and let it run along side Quake 3 in a window because I wasn't sure if all rendering stopped. The result was that glxgears continues to render with no problems while Quake 3 is frozen or not updating.


2) I had not tried 24bpp. So I just tried it and I get the same blank screen on start up. I'll have to play for awhile to see if the freezing is still there, I'll repost with results in awhile.


3) I changed my xorg.conf settings to NvAGP=1 and after reloading the nvidia module I get the following in /var/log/messages

Oct 14 21:50:10 blackbox kernel: NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7676 Fri Jul 29 12:58:54 PDT 2005
Oct 14 21:50:11 blackbox kernel: NVRM: not using NVAGP, an AGPGART backend is loaded!
Oct 14 21:50:11 blackbox kernel: NVRM: not using NVAGP, an AGPGART backend is loaded!

I don't see agpart from lsmod, could it be compiled into the Fedora Core 4 kernel?
burnin1965 is offline   Reply With Quote
Old 10-14-05, 11:20 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: GeForce 6200 freezes and no video

Yes, I believe that the FC4 kernel does have agpgart compiled in.

I'd appreciate it if you could test NVN or UT, just to see if this behavior happens there as well.

I'll see if I can track down your motherboard in an attempt to reproduce this problem.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-14-05, 11:25 PM   #8
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

Quote:
2) I had not tried 24bpp. So I just tried it and I get the same blank screen on start up. I'll have to play for awhile to see if the freezing is still there, I'll repost with results in awhile.

No luck, at 24bpp Quake 3 still freezes intermittantly, and after 15 seconds or so the game starts going again but the screen does not draw until I drag another window over the top of the game window.

When all this takes place everything else on the desktop is rendering no problem.

burnin
burnin1965 is offline   Reply With Quote

Old 10-14-05, 11:26 PM   #9
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

I can setup the box to recompile the kernel with agpart as a module if its possible. If that would be a better test than running the other games.

burnin
burnin1965 is offline   Reply With Quote
Old 10-15-05, 01:14 AM   #10
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

Okay, I copied Neverwinter Nights from another machine that is working and did not experience any freezes like Quake 3. However, I can get the screen to stop drawing by bringing up the menu and saving the current game. After the game is saved the window no longer updates, I have the game running in a window and not in fullscreen. If I grab another window on the desktop and drag it on top of the Neverwinter Nights window it starts drawing again.

burnin
burnin1965 is offline   Reply With Quote
Old 10-16-05, 11:36 AM   #11
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

Okay, I recompiled the kernel with /dev/agpart as a module and the freezes are gone, however, when Quake 3 starts the screen is blank until I drag another window over the display.

Also of note, the freezes may be gone because I did something wrong during my compile and installation so most of the driver modules were missing. Only three modules were loaded, nvidia, ext3, and jbd.

So there was no sound, no network, etc. And considering that Quake 3 started with a blank screen I suspect the problem is still there and if I get everything loaded up again the freezes will likely return.

Since the older FX5900 card works and the 6200 card has problems and nothing I change software wise helps I'm thinking its the 6200 card. If there is something I can do to assist in determining what the problem is so the folks at Nvidia can fix it I'll be glad to help. But at this point I need to start looking at other cards as I've been goofing with this card for about a week and I need to get these systems constructed and delivered. I'd like to go with the FX5900 cards but their too expensive for the application.

burnin
burnin1965 is offline   Reply With Quote
Old 11-12-05, 03:30 PM   #12
burnin1965
Registered User
 
Join Date: Oct 2005
Posts: 11
Default Re: GeForce 6200 freezes and no video

I haven't posted on this thread lately because I gave up on the GeForce 6200 and picked up a couple of refurbished FX5900 cards, they worked great. Now I'm building one more box with the same hardware but I could not get ahold of another refurbed FX5900 so I decided to try a GeForce 6600GT. It has the same problem as the 6200. I was surprised as I have a 6600GT PCI express running with no problems in another box.

There appears to be an issue with the 6xxx series cards + AGP. Should I start looking for another card or is this a known issue that can be resolved?

burnin
burnin1965 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.