Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-17-05, 03:52 PM   #1
Impi
Registered User
 
Join Date: Oct 2005
Posts: 13
Default BenQ PE5120 and 854x480

Hi all!

I want to use the native resolution (854x480) of my BenQ PE5120 beamer.
I generated this modeline
Code:
ModeLine "854x480" 45.86 854 896 1096 1176 480 482 494 520 #75Hz
which seems to work in Xorg's nv-driver, but then I don't have 3d-acceleration and somehow the beamer never registers a change in the resolution (it always reports it at 1024x768).
When I use the nvidia-driver (1.0.7676 and 1.0.6629) I get this message in my /var/log/Xorg.1.log:
Code:
(WW) NVIDIA(0): Not using mode "854x480":
(WW) NVIDIA(0):   horizontal resolution (854) not a multiple of 8
(WW) NVIDIA(0):   horizontal blanking width ((max(1176,1096) - min(854,896) =
(WW) NVIDIA(0):      322) not a multiple of 8
is it possible to disable this multiple of 8 check or does anyone know of another way of using this resolution?
Impi is offline   Reply With Quote
Old 10-19-05, 01:43 PM   #2
Impi
Registered User
 
Join Date: Oct 2005
Posts: 13
Default Re: BenQ PE5120 and 854x480

Really impossible to use WSVGA with nvidia-drivers?
Does anyone know if this is possible in Windows?
Impi is offline   Reply With Quote
Old 10-19-05, 01:55 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: BenQ PE5120 and 854x480

How or where did you obtain that modeline?

Please start X with the following command:
startx -- -logverbose 5
and then generate and post a bug report for review.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-22-05, 01:35 PM   #4
Impi
Registered User
 
Join Date: Oct 2005
Posts: 13
Default Re: BenQ PE5120 and 854x480

The modeline was generated with the Colas XFree Modeline Generator.
Attached Files
File Type: txt nvidia-bug-report.txt (78.9 KB, 174 views)
Impi is offline   Reply With Quote
Old 10-22-05, 03:53 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: BenQ PE5120 and 854x480

How or where did you determine that your projector has a native resolution of 854x480?

Neither the EDID in the X log of your bug report, nor the official user's manual mention that resolution as being valid.

The EDID lists:
720x400@88Hz
640x480@60Hz
640x480@72Hz
640x480@75Hz
800x600@60Hz
800x600@72Hz
800x600@75Hz
1024x768@60Hz
1021x768@65Hz
1024x768@70Hz
1024x768@75Hz

And the User's Manual lists:
SXGA, XGA, SVGA, VGA, Macintosh®, HDTV (1080i, 720p, 576p, 576i, 480p, 480i)

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-23-05, 06:41 AM   #6
Impi
Registered User
 
Join Date: Oct 2005
Posts: 13
Default Re: BenQ PE5120 and 854x480

It says so in the information about the DMD chip (in the manual for the PE5120):
0.53" DMD 480P (854x480)
That is the native resolution of the chip, as I understand it.
Currently I'm running it at 1024x576, but shouldn't I get a sharper picture, when I used the native resolution?
Impi is offline   Reply With Quote
Old 10-23-05, 10:19 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: BenQ PE5120 and 854x480

I see what you're referring to now, but it seems a bit odd that they list 480P outside of the resolutions section. Are you certain that 854x480 was working with the nv driver? Did you see that as the accepted resolution in the X log?

-Lonni
netllama is offline   Reply With Quote
Old 10-23-05, 11:46 AM   #8
Impi
Registered User
 
Join Date: Oct 2005
Posts: 13
Default Re: BenQ PE5120 and 854x480

Yes, according to X it is working (I have attached a bug-report, with the nv-driver running).
But the beamer always says that it is running at 1024x768, regardles of what resolution I choose in X.

With the nvidia-driver the beamer mostly recognises to what resolution I have switched. So, when I'm choosing 1024x576 the beamer says it is running at 1024x576, when I choose 800x600 the beamer says it is running at 800x600 and so on...

Anyway thanks for your help so far, but are you sure this has nothing to do with 854 not being a multiple of 8?
From what you wrote it sounds more like it is an issue of the beamer not giving out the correct EDID. Perhaps I should contact BenQ about this.
Attached Files
File Type: txt nvidia-bug-report2.txt (80.2 KB, 170 views)
Impi is offline   Reply With Quote

Old 10-23-05, 02:51 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: BenQ PE5120 and 854x480

The bug report you attached against the 'nv' driver also shows that 854x480 fails to work:
(II) NV(0): Not using mode "854x480/75Hz" (no mode of this name)
(--) NV(0): Virtual size is 1024x576 (pitch 1024)

I'd suggest talking to BenQ at this point, as either their documentation is erroneous, or possibly something is wrong with your projector. Perhaps they can provide you with a modeline for 480P.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-24-05, 10:06 AM   #10
RPlakas
Registered User
 
Join Date: Sep 2004
Posts: 1
Default Re: BenQ PE5120 and 854x480

Lonni,

Can you verify that we can use non-divisible-by-8 resolutions in modelines with the latest Nvidia drivers? I am using an FX5200, but I owuld pickup an 6600GT if it supported this.

I also have a projector with a native res of 854x480 (Infocus 4805)but I have a modeline setup for 848x480 because the driver won't accept 854x480

Thanks,

Rich





Quote:
Originally Posted by netllama
The bug report you attached against the 'nv' driver also shows that 854x480 fails to work:
(II) NV(0): Not using mode "854x480/75Hz" (no mode of this name)
(--) NV(0): Virtual size is 1024x576 (pitch 1024)

I'd suggest talking to BenQ at this point, as either their documentation is erroneous, or possibly something is wrong with your projector. Perhaps they can provide you with a modeline for 480P.

Thanks,
Lonni
RPlakas is offline   Reply With Quote
Old 10-24-05, 12:26 PM   #11
Impi
Registered User
 
Join Date: Oct 2005
Posts: 13
Default Re: BenQ PE5120 and 854x480

Quote:
Originally Posted by netllama
The bug report you attached against the 'nv' driver also shows that 854x480 fails to work:
(II) NV(0): Not using mode "854x480/75Hz" (no mode of this name)
(--) NV(0): Virtual size is 1024x576 (pitch 1024)
That's just because I've set a mode "854x480/75Hz" but called it in the modeline "854x480". If you scroll a little bit further down (line 855) you can see that it is acceptet:
(**) NV(0): Mode "854x480": 45.9 MHz, 39.0 kHz, 75.0 Hz
(II) NV(0): Modeline "854x480" 45.86 854 896 1096 1176 480 482 494 520

Quote:
I'd suggest talking to BenQ at this point, as either their documentation is erroneous, or possibly something is wrong with your projector. Perhaps they can provide you with a modeline for 480P.
I will do that. But something tells me, that they won't support any Linux stuff...
Impi is offline   Reply With Quote
Old 10-24-05, 02:15 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: BenQ PE5120 and 854x480

I've dug into this a bit more, and the strict divide by 8 requirement will be addressed in the next driver release (1.0-8xxx). The best workaround right now is to reduce the resolution to be divisible by 8, which means, please try using 848x480. You will need to create a modeline, such as this:
Modeline "my848x480" 40.96 848 880 968 1088 480 481 484 502

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.