Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-15-05, 12:23 PM   #1
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

hi all first post here (i think)

anyhow heres my system

slackware 10.2 with a 2.6.13.3 kernel
ABIT NF7-S ver2.0 with bios #27

this board has these 2 auido controllers:

00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
Subsystem: ABIT Computer Corp.: Unknown device 1c00
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0 (250ns min, 3000ns max)
Interrupt: pin A routed to IRQ 12
Region 0: Memory at e8000000 (32-bit, non-prefetchable) [size=512K]
Capabilities: [44] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
Subsystem: ABIT Computer Corp.: Unknown device 1c00
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0 (500ns min, 1250ns max)
Interrupt: pin A routed to IRQ 5
Region 0: I/O ports at d000 [size=256]
Region 1: I/O ports at d400 [size=128]
Region 2: Memory at e8081000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

im trying to install the nvidia "Version: 1.0-0306":

when i got install it it freezes during the build section

is there some kernel modules i need to have built into kernel so the driver will install without freezing?

any help getting the soundstorm APU working would be great!

thanks
nunyerb is offline   Reply With Quote
Old 10-15-05, 04:11 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Please post the installation log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-15-05, 04:46 PM   #3
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Quote:
Originally Posted by netllama
Please post the installation log.

Thanks,
Lonni
since the nvidia driver will not install with out freezing i cant give you that info

what i need to know is what kernel options do i need in the /device drivers/sound

under alsa and Open Sound System
nunyerb is offline   Reply With Quote
Old 10-15-05, 04:55 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

If no log is being generated then the problem isn't the driver or the installer, but something in your environment. The installer log is created as soon as the installer finishes extracting the driver from the archive.

I'm afraid I don't understand what you mean by "/device drivers/sound under alsa and Open Sound System", however if you can't get the driver installed that is really not relevant.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-16-05, 05:26 AM   #5
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Quote:
Originally Posted by netllama
If no log is being generated then the problem isn't the driver or the installer, but something in your environment. The installer log is created as soon as the installer finishes extracting the driver from the archive.

I'm afraid I don't understand what you mean by "/device drivers/sound under alsa and Open Sound System", however if you can't get the driver installed that is really not relevant.

Thanks,
Lonni
whats the name of the file you want me to look at?

could you please tell me the modules for kernel 2.6.13 that i need to pick when i build my kernel?
im talking in 'make menuconfig' or 'make xconfig' in the /device drivers/sound/sound card/ either alsa or OSS

thanks
nunyerb is offline   Reply With Quote
Old 10-16-05, 08:18 AM   #6
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Quote:
Originally Posted by netllama
Please post the installation log.

Thanks,
Lonni
heres whats in it currently

nforce-installer log file '/var/log/nvidia-nforce-installer.log'
creation time: Sat Oct 15 16:45:55 2005

option status:
license pre-accepted : false
expert : false
uninstall : false
driver info : false
no precompiled interface : false
no ncurses color : false
no questions : false
silent : false
Installer install prefix : /usr
kernel source path : (not specified)
net kernel install path : (not specified)
audio kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp

Using: nvidia-installer ncurses user interface
-> Found package NVIDIA network driver for Linux-x86
-> Found package NVIDIA audio driver for Linux-x86
-> Please select packages for installation:
Selections:
NVIDIA audio driver for Linux-x86 (1.0-6)
-> Starting install of NVIDIA audio driver for Linux-x86
-> Checking for loaded module nvsound
-> Checking for loaded module nvaudio
-> License accepted.
-> Skipping check for conflicting rpms.
-> There appears to already be an audio driver installed on your system (versio
n: 1.0-6). As part of installing this driver (version: 1.0-6), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> /proc/version is Linux version 2.6.13.3 (root@darkstar) (gcc version 3.3.6)
#22 Sat Oct 15 16:42:55 EDT 2005
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.6.13.3/source'
-> Kernel output path: '/lib/modules/2.6.13.3/build'
-> Performing cc_version_check with CC="cc".
-> running command /usr/bin/grep "^PATCHLEVEL ="
/lib/modules/2.6.13.3/source/Makefile | /usr/bin/cut -d " " -f 3
-> Kernel module filename is nvsound.ko
Cleaning kernel module build directory.
executing: 'cd ./nvsound/main; make clean'...
rm -f *.ko *mod.* *.cmd nv*.o *~ core
-> Building kernel module:
executing: 'cd ./nvsound/main; make module SYSSRC=/lib/modules/2.6.13.3/sour
ce SYSOUT=/lib/modules/2.6.13.3/build'...
make -C /lib/modules/2.6.13.3/build \
KBUILD_SRC=/usr/src/linux-2.6.13.3 KBUILD_VERBOSE=1 \
KBUILD_CHECK= KBUILD_EXTMOD="/tmp/selfgz3358/NFORCE-Linux-x86-1.0-0306-pkg1/
nvsound/main" \
-f /usr/src/linux-2.6.13.3/Makefile modules


heres what happens when i run driver

it extracts it then builds and i think it then tests and thats where it freezes
nunyerb is offline   Reply With Quote
Old 10-16-05, 10:38 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

The output that you've posted shows that its stopping while compiling the module. How long have you waited when its seemed frozen? Have you compiled any other software on your system in the past?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-16-05, 02:26 PM   #8
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Quote:
Originally Posted by netllama
The output that you've posted shows that its stopping while compiling the module. How long have you waited when its seemed frozen? Have you compiled any other software on your system in the past?

Thanks,
Lonni
i have tried so many different things that was just my last output from that file.

what i (NEED) to know is what modules need to be compiled in the kernel (FIRST)

if i dont have the right modules which i dont (cause i dont have anything selected in there) then nothing can build

in "make menuconfig" under "/device drivers/sound/sound card/" there are 2 types i can pick from and that is "alsa" and "open sound system" i have absolutely nothing checked on with "Y" or "M"

what is it that i need then perhaps we can get to install
nunyerb is offline   Reply With Quote

Old 10-16-05, 03:21 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Your kernel needs OSS support, beyond that the kernel configuration shouldn't matter. However, the log file you posted doesn't suggest that your kernel configuration has any relevance to the failure.

How long have you waited when its seemed frozen? Have you compiled any other software on your system in the past?

Thanks,
Lonni

-Lonni
netllama is offline   Reply With Quote
Old 10-16-05, 06:27 PM   #10
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Quote:
Originally Posted by netllama
Your kernel needs OSS support, beyond that the kernel configuration shouldn't matter. However, the log file you posted doesn't suggest that your kernel configuration has any relevance to the failure.

How long have you waited when its seemed frozen? Have you compiled any other software on your system in the past?

Thanks,
Lonni

-Lonni
my log file is so screwed you dont even know

if i only select "/device drivers/sound/sound card/Open Sound System" that should work right?
well i tried it that way and if i just select that 1 kernel module the nvidia driver will not install. it says something about it didnt detect any hardware.

there has to be something else in there or maybe in the also

look at your kernel .config and tell me exactly what you have as "Y" and as "M" in your kernel .config

after i get that far i will do exactly as you specify but it dont do any good trying to install this driver if i dont have the rigth modules selected

btw thank-you for trying to help me
nunyerb is offline   Reply With Quote
Old 10-16-05, 06:33 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

I'm not running Slackware, and I know nothing about your kernel configuration requirements, so I couldn't begin to provide you with a configuration that would work reliably on your system.

I'd suggest booting the kernel that shipped with Slackware. If that works to install the driver, then you can use the same kernel's shipping configuration to build your own kernel.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-16-05, 06:43 PM   #12
nunyerb
Registered User
 
Join Date: Oct 2005
Posts: 28
Default Re: abit NF7-S v2.0 APU & Nvidia sound 1.0-0306

Quote:
Originally Posted by netllama
I'm not running Slackware, and I know nothing about your kernel configuration requirements, so I couldn't begin to provide you with a configuration that would work reliably on your system.

I'd suggest booting the kernel that shipped with Slackware. If that works to install the driver, then you can use the same kernel's shipping configuration to build your own kernel.

Thanks,
Lonni
the kernel that i installed with slack10.2 was test26.s which is 2.6.13 testing

then i upgraded the kernel to 2.6.13.3 now i have my kernel trimmed down quite a bit....this kernel is using modules for my specific mboard, vcard, modem, processor AND trying for sound.

i can not believe nobody here knows exactly the specific modules to make the nforce 2 soundstorm APU work

the nvidia driver install instructions just say make sure OSS is selected in kernel and NO alsa stuff should be selected...

now this is kind of funny cause in the alsa catagory i see OSS stuff and also a module for the nforce audio (AC97) and i checked this and it does work with alsaconf but dont forget that is not the hardware soundcard onboard the mb that is the software codec

i want the APU to work
someone for the love of god help
nunyerb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM

All times are GMT -5. The time now is 08:43 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.