Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-02-03, 06:03 PM   #1
sindar
Registered User
 
Join Date: Jan 2003
Posts: 6
Default RedHat 8.0 Troubles

Please Help, I have read just about everything I can and have done all of the XF86Config stuff.

First of all, I haven't ever been able to STARTX. When I first tried to install RH8 it would freeze at the STARTX point so I reinstalled, text only mode.

I have tried to follow all of the steps to download and install the proper drivers.

I have NVIDIA_kernel and NVIDIA_GLX 4191 RPM's.

When I try to install the NVIDIA_kernel it installs but says that it could not find MODULE NVIDIA and I can't find it either - where is it and how do I get it?

Because it can't find that it never installs nvidia.0, so that doesn't work.

now, when I try to STARTX it says Unable to load NVIDIA, no module found.

I have the NFORCE 420 Chipset w/ integrated GeForce2 MX and 512 Ram. Someone please tell me what to do.

Also, I have an older kernel 2.4.18.14, but I don't know how to upgrade that without a GUI or a setup dialup connection

Thanks,

Sindar
sindar is offline   Reply With Quote
Old 01-02-03, 06:04 PM   #2
volt
 
Join Date: Jul 2002
Location: /dev/null
Posts: 1,556
Default

http://www.nvnews.net/vbulletin/show...&threadid=5785
__________________
[b]Optimization guidelines by Koji Ashida of NVIDIA:[/b][list][*]Use fx12 instructions whenever possible[*]Use lowest pixel shader version[/list][url=http://developer.nvidia.com/docs/IO/10878/ChinaJoy2004_OptimizationAndTools.pdf]source[/url]

[size=1]The politics are invading the technology. We don't really like to mess with politics because that kind of adversarial relationship has nothing to do with pure technical operations and the technical specifications of what we like to play with, the hardware![/size]
volt is offline   Reply With Quote
Old 01-02-03, 06:11 PM   #3
sindar
Registered User
 
Join Date: Jan 2003
Posts: 6
Default

Ok, read that, I am downloading those tar files now. Will that create the NVIDIA module that I am lacking?

I just did the TAR and make/make install and it didn't have any errors, do I need to follow the other instructions for driver install now?

Last edited by sindar; 01-02-03 at 06:30 PM.
sindar is offline   Reply With Quote
Old 01-02-03, 06:35 PM   #4
sindar
Registered User
 
Join Date: Jan 2003
Posts: 6
Default

I have done what the link you sent said VOLT, but it is still the same. when I run STARTX it says

(EE) NVIDIA(0): Failed to initialise the NVdriver kernel module!
(ee) NVIDIA(0): ***Aborting ***
(EE) Screens found, but none hae a usable configuration.

XIO: fatgal IO error 104 on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.
sindar is offline   Reply With Quote
Old 01-02-03, 08:25 PM   #5
volt
 
Join Date: Jul 2002
Location: /dev/null
Posts: 1,556
Default

If you didn't get any errors during compilation that means the modules has been loaded. You just need to configure your XF86Config so it's usable

You will find plenty of examples here...

I hope you did not forget to remove the NVIDIA rpm's?

rpm -e <NVIDIA kernel package>
rpm -e <NVIDIA GLX package>
__________________
[b]Optimization guidelines by Koji Ashida of NVIDIA:[/b][list][*]Use fx12 instructions whenever possible[*]Use lowest pixel shader version[/list][url=http://developer.nvidia.com/docs/IO/10878/ChinaJoy2004_OptimizationAndTools.pdf]source[/url]

[size=1]The politics are invading the technology. We don't really like to mess with politics because that kind of adversarial relationship has nothing to do with pure technical operations and the technical specifications of what we like to play with, the hardware![/size]
volt is offline   Reply With Quote
Old 01-02-03, 09:19 PM   #6
sindar
Registered User
 
Join Date: Jan 2003
Posts: 6
Default

I was wrong, I did get errors. I have just reinstalled RedHat 8.0 and I am going to give it one more try. I'll post my results in a few minutes.
sindar is offline   Reply With Quote
Old 01-02-03, 09:27 PM   #7
sindar
Registered User
 
Join Date: Jan 2003
Posts: 6
Default It Worked

YEAH!!! It worked!! Thank you VOLT!!! I have alot to learn about LINUX and Redhat now, but thanks for the start.
sindar is offline   Reply With Quote
Old 01-02-03, 09:35 PM   #8
volt
 
Join Date: Jul 2002
Location: /dev/null
Posts: 1,556
Default

When you compile drivers for the first time, you cannot use the untared files for the second time if you have changed something in your system, you will get errors. Best thing is to untar the drivers and compile them again.

My advice: stay away from RPM's even if NVchooser script tells you to use them.
__________________
[b]Optimization guidelines by Koji Ashida of NVIDIA:[/b][list][*]Use fx12 instructions whenever possible[*]Use lowest pixel shader version[/list][url=http://developer.nvidia.com/docs/IO/10878/ChinaJoy2004_OptimizationAndTools.pdf]source[/url]

[size=1]The politics are invading the technology. We don't really like to mess with politics because that kind of adversarial relationship has nothing to do with pure technical operations and the technical specifications of what we like to play with, the hardware![/size]
volt is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
nforce on RedHat 8.0 shaun680 NVIDIA Linux 8 10-17-02 12:36 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
Redhat 8.0, no rpm, can't compile. Ironphil NVIDIA Linux 6 10-02-02 03:13 PM
Redhat 7.3 + Nvidia drivers 3123 = troubles e-r-a-n NVIDIA Linux 4 09-17-02 12:26 PM

All times are GMT -5. The time now is 06:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.