Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-03-06, 03:38 PM   #1
rootkit
Registered User
 
Join Date: Dec 2005
Posts: 23
Default XvMC issues

Hi
i can't get XvMC working. i attach some usefull infos
Attached Files
File Type: txt mpeg2play_accel.txt (1.0 KB, 126 views)
File Type: txt mplayer-xvmc.txt (2.9 KB, 151 views)
File Type: log nvidia-bug-report.log (80.0 KB, 129 views)
rootkit is offline   Reply With Quote
Old 01-03-06, 05:11 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMC issues

What is the mplayer command that you're using? Also, can you post a link to the ilt.mpg that you're using?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-03-06, 05:22 PM   #3
rootkit
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: XvMC issues

i give this command:

Code:
mplayer ilt.mpg -vo xvmc -vc ffmpeg12mc

[~]$ ll ilt.mpg
-rw-r--r--  1 amd64 users 2,1G 2005-12-20 18:48 ilt.mpg
It is a ~2GB "I Love Techno 2003" dvdrip, do you really want to download it? :P

Btw, any valid mpeg file gives me the same error
rootkit is offline   Reply With Quote
Old 01-03-06, 05:27 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMC issues

Currently, bug 203277 is open to report a problem where XvMC is not working on some GPUs. Please run the following command and provide the resulting output:

XVMC_DEBUG=1 mplayer ilt.mpg -vo xvmc -vc ffmpeg12mc

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-03-06, 05:38 PM   #5
rootkit
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: XvMC issues

MPlayer dev-CVS-051223-17:56-4.0.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon 64 X2 Manchester,Toledo (Family: 15, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2


Warning unknown option skin at line 50

Playing ilt.mpg.
Cache fill: 0.00% (0 bytes)
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 3) 25.000 fps 9800.0 kbps (1225.0 kbyte/s)
================================================== ========================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 2.0 (stereo) 48000 Hz 192.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
vo_xvmc: X-Video extension 2.2
vo_xvmc: X-Video MotionCompensation Extension version 1.0
================================================== ========================
Forced video codec: ffmpeg12mc
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
vd_ffmpeg: XVMC accelerated codec
Selected video codec: [ffmpeg12mc] vfm: ffmpeg (FFmpeg MPEG-1/2 (XvMC))
================================================== ========================
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
alsa-init: 1 soundcard found, using: default
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
vd_ffmpeg: XVMC accelerated MPEG2
trying pixfmt=0
VDec: vo config request - 720 x 576 (preferred colorspace: MPEG1/2 Motion Compensation and IDCT)
VDec: using MPEG1/2 Motion Compensation and IDCT as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xvmc] 720x576 => 1024x576 MPEG1/2 Motion Compensation and IDCT
vo_xvmc: Port 270 grabed
vo_xvmc: Found matching surface with id=54434449 on 270 port at 0 adapter
NV-XVMC (ERROR): this library supports the following chips only:
NV-XVMC (ERROR): NV17, 18, 25, 28, 30, 31, 34, 35, 36, 40, 41, 43 and 44
vo_xvmc: XvMCCreateContext failed with error 11
FATAL: Cannot initialize video driver.
trying pixfmt=1
VDec: vo config request - 720 x 576 (preferred colorspace: MPEG1/2 Motion Compensation)
VDec: using MPEG1/2 Motion Compensation and IDCT as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xvmc] 720x576 => 1024x576 MPEG1/2 Motion Compensation and IDCT
vo_xvmc: Port 270 grabed
vo_xvmc: Found matching surface with id=54434449 on 270 port at 0 adapter
NV-XVMC (ERROR): this library supports the following chips only:
NV-XVMC (ERROR): NV17, 18, 25, 28, 30, 31, 34, 35, 36, 40, 41, 43 and 44
vo_xvmc: XvMCCreateContext failed with error 11
FATAL: Cannot initialize video driver.
VDec: vo config request - 720 x 576 (preferred colorspace: MPEG1/2 Motion Compensation and IDCT)
VDec: using MPEG1/2 Motion Compensation and IDCT as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xvmc] 720x576 => 1024x576 MPEG1/2 Motion Compensation and IDCT
vo_xvmc: Port 270 grabed
vo_xvmc: Found matching surface with id=54434449 on 270 port at 0 adapter
NV-XVMC (ERROR): this library supports the following chips only:
NV-XVMC (ERROR): NV17, 18, 25, 28, 30, 31, 34, 35, 36, 40, 41, 43 and 44
vo_xvmc: XvMCCreateContext failed with error 11
FATAL: Cannot initialize video driver.
vd_ffmpeg: Unexpected init_vo error
rootkit is offline   Reply With Quote
Old 01-03-06, 05:51 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XvMC issues

Thanks, this is another instance of bug 203277.

-Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
HPCwire: @nvidia Works On #CPU Co-Dependency Issues with Kepler GPU http://t.co/Uqhyt News Archived News Items 0 05-23-12 05:10 AM
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
Overclocking issues... mcortz_2000 CPUs, Motherboards And Memory 5 09-16-02 03:41 PM
Is there a Microsoft patch for the refresh rate issues yet? Zarich NVIDIA GeForce 7, 8, And 9 Series 22 08-24-02 01:02 PM

All times are GMT -5. The time now is 12:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.