Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-02-05, 07:13 AM   #1
dimitri
Registered User
 
Join Date: Sep 2003
Location: France
Posts: 23
Default XIO: fatal IO error 104

Hi,

X doesn't start on our new Dell Precision 670 workstations. The workstation runs Fedora Core 4 with latest updates. This is specific to this hardware, we have lots of other Dell workstations and they don't exhibit this problem.

# startx
[...]
X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.9-22.ELsmp i686 [ELF]
[...]
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 2 13:55:18 2005
(==) Using config file: "/etc/X11/xorg.conf"
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
#

I've seen other threads refering to this 104 error, but none with actual solutions:
http://www.nvnews.net/vbulletin/showthread.php?t=55449

Is this a known issue? Is there a generic solution to this problem, or is it hardware-dependent?
Attached Files
File Type: txt nvidia-bug-report.log.txt (77.9 KB, 194 views)
dimitri is offline   Reply With Quote
Old 11-02-05, 07:29 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: XIO: fatal IO error 104

Did you disable SELinux for the duration of the driver installation and re-enable it afterwards?
zander is offline   Reply With Quote
Old 11-02-05, 07:54 AM   #3
dimitri
Registered User
 
Join Date: Sep 2003
Location: France
Posts: 23
Default Re: XIO: fatal IO error 104

No, SELinux has not been disabled, this is a vanilla fresh Fedora Core 4 install. I wasn't aware of any SELinux issue, but on the other hand we don't have any problem with at least four other Fedora Core 4 workstations, all with (older) Nvidia cards.

I went through README again and I guess you're referring to this FAQ:
Quote:
Q. Why does X crash when starting on Fedora Core 4?

A. There are interaction problems with SELinux (enabled by default on Fedora
Core 4) and the NVIDIA graphics driver. NVIDIA is investigating this, but
it is recommended that you append the kernel boot option "selinux=0" to the
kernel boot line in your grub.conf file. You must reinstall the NVIDIA
driver after adding this option.
I'll try this and let you know. Thank you for your help.

For what it's worth, removing from xorg.conf line:
Load "glx"
fixes the problem - but that's obviously not what we want.
dimitri is offline   Reply With Quote
Old 11-02-05, 08:22 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: XIO: fatal IO error 104

You needn't permanently disable SELinux, it's sufficient to temporarily disable it for the duration of the NVIDIA Linux graphics driver installation (i.e. run `setenforce 0` before and `setenforce 1` after the installation); future NVIDIA Linux graphics driver releases won't require this workaround.
zander is offline   Reply With Quote
Old 11-02-05, 09:02 AM   #5
dimitri
Registered User
 
Join Date: Sep 2003
Location: France
Posts: 23
Default Re: XIO: fatal IO error 104

It works:
* rebooted Fedora Core 4 with selinux=0
* reinstalled Nvidia drivers over existing drivers
* rebooted Fedora Core 4 without selinux=0, some re-labelling took place for a few minutes, then X starts without problems.

I'll try the setenforce trick for our automated post-installation procedure.

Thank you for you help.
dimitri is offline   Reply With Quote
Old 08-29-06, 11:15 PM   #6
aknetskimo
Registered User
 
aknetskimo's Avatar
 
Join Date: Jan 2006
Location: Alaska
Posts: 3
Default Re: XIO: fatal IO error 104

I have a gigabyte board with a amd 3800 2X and a asus 6800 gt pci video card.
I'm running Mandravia 2006 64 bit. (kernel:2.6.12mdk 1-1mdk)
I downloaded the latest Nvidia driver (NVIDIA-Linux-x86_64-1.0-8774-pkg2.run
It also give me the fatal 104 error.
Does this system/software also need the selinux turned off?
Help!
aknetskimo is offline   Reply With Quote
Old 08-30-06, 10:43 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: XIO: fatal IO error 104

aknetskimo,
Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-30-06, 10:56 AM   #8
Bastien59
Registered User
 
Join Date: Aug 2006
Location: Lille
Posts: 15
Default Re: XIO: fatal IO error 104

@aknetskimo> why don't you try instead of asking ? I think it would be more judicious to try and tell us if it works...
Bastien59 is offline   Reply With Quote

Old 09-03-06, 10:00 PM   #9
aknetskimo
Registered User
 
aknetskimo's Avatar
 
Join Date: Jan 2006
Location: Alaska
Posts: 3
Default Re: XIO: fatal IO error 104

I am accessing your site via another box. The box with the IO error is only usable in command line mode. How do I send you the log file from command line or do I need to copy the file to floppy and move it to another box?
aknetskimo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Warcraft 3 fatal error! Kruno Gaming Central 6 09-13-02 07:26 AM

All times are GMT -5. The time now is 10:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.