Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-05, 05:12 AM   #1
imoore
Registered User
 
Join Date: Dec 2004
Posts: 6
Default nvidia driver fails on FreeBSD after port revision

Hi, I've been using the nvidia driver on my FreeBSD system since 5.21-RELEASE with a GeForce4 without any problems.
Currently I'm running 5.4-RELEASE.
A revision of the nvidia-driver port came out a couple of days ago & I rebuilt the port using portupgrade.
Now X refuses to start. On the console, I get the following error on running startx:
NVIDIA: could not open the device file /dev/nvidiactl (Unknown error: 999).
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

The Xorg log file is pretty long, so here are some extracts:
5.4-RELEASE-p8 #0: Sat Oct 22 12:38:08 CST 2005 root@daemon.foo.lan:/usr/obj/usr/src/sys/IAN i386
Build Date: 11 November 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 11 20:29:49 2005
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) | |-->Monitor "DiamondView 1995"
(**) | |-->Device "NVidia GeForce4"

<snip>

(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.7676
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "kbd"
(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.o
(II) Module kbd: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) NVIDIA X Driver 1.0-7676 Fri Jul 29 13:32:37 PDT 2005
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found

<snip>

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "IgnoreEDID" "true"
(**) NVIDIA(0): Option "RenderAccel" "True"
(**) NVIDIA(0): Option "CursorShadow" "true"
(**) NVIDIA(0): Option "CursorShadowAlpha" "75"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "1"
(**) NVIDIA(0): Enabling experimental RENDER acceleration
(**) NVIDIA(0): Enabling cursor shadow
(**) NVIDIA(0): Cursor shadow alpha = 75
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(**) NVIDIA(0): Ignoring EDIDs
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

The nvidia.ko module is loaded:
% kldstat -n nvidia
Id Refs Address Size Name
14 1 0xc2854000 37f000 nvidia.ko

The device files are present in /dev:
daemon:~ % ll /dev/nv*
crw-rw-rw- 1 root wheel 8, 0x48000000 Nov 11 20:27 /dev/nvidia0
crw-rw-rw- 1 root wheel 0, 0x480000ff Nov 11 20:27 /dev/nvidiactl

According to the ports diff pages, the update to the port (from 1.0.7676 to 1.0.7676_1), was the addition of the line:
${REINPLACE_CMD} -E 's/(extension).*/\1/ ; /bin/d' ${WRKSRC}/x11/Makefile

I tried commenting that out in the makefile and rebuilding the port, which should have made it exactly the same as before, but it made no difference.

I can't find any mention of a 999 error or anything that might help me, so hopefully someone can suggest something!

Cheers,
Ian
imoore is offline   Reply With Quote
Old 11-11-05, 06:12 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia driver fails on FreeBSD after port revision

Looking at recent activity, the only change made in the last few days was the removal of `nvidia-settings` from the nvidia-driver port, in favor of a natively built version (in the sense that it's built for whichever happens to be the most current FreeBSD version installed). Are there any interesting messages in the `dmesg` output? Does the problem persist if you install using the official NVIDIA FreeBSD graphics driver package?
zander is offline   Reply With Quote
Old 11-11-05, 06:43 AM   #3
imoore
Registered User
 
Join Date: Dec 2004
Posts: 6
Default Re: nvidia driver fails on FreeBSD after port revision

Quote:
Originally Posted by zander
Looking at recent activity, the only change made in the last few days was the removal of `nvidia-settings` from the nvidia-driver port, in favor of a natively built version (in the sense that it's built for whichever happens to be the most current FreeBSD version installed). Are there any interesting messages in the `dmesg` output?
No, nothing except the nvidia kernel module being loaded.

Quote:
Originally Posted by zander
Does the problem persist if you install using the official NVIDIA FreeBSD graphics driver package?
It won't build - complains about me running FreeBSD 6!
% sudo make install
===> src
@ -> /usr/src/sys
machine -> /usr/src/sys/i386/include
awk -f @/tools/makeobjops.awk @/kern/device_if.m -h
awk -f @/tools/makeobjops.awk @/kern/bus_if.m -h
awk -f @/tools/makeobjops.awk @/dev/pci/pci_if.m -h
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -p
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -q
awk -f @/tools/vnode_if.awk @/kern/vnode_if.src -h
cc -O -pipe -march=athlon-xp -I/src -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=7676 -D__KERNEL__ -UDEBUG -U_DEBUG -DNDEBUG -O -fno-common -fno-unit-at-a-time -minline-all-stringops -Werror -D_KERNEL -DKLD_MODULE -nostdinc -I- -I/src -I. -I@ -I@/contrib/altq -I@/../include -I/usr/include -finline-limit=8000 -fno-common -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -ffreestanding -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -fformat-extensions -std=c99 -c nvidia_ctl.c
In file included from nvidia_ctl.c:14:
./nv-freebsd.h:25:2: #error This driver does not support FreeBSD 6.x/-CURRENT!
*** Error code 1

Stop in /usr/home/imoore/NVIDIA-FreeBSD-x86-1.0-7676/NVIDIA-FreeBSD-x86-1.0-7676/src.
*** Error code 1

Stop in /usr/home/imoore/NVIDIA-FreeBSD-x86-1.0-7676/NVIDIA-FreeBSD-x86-1.0-7676


No - I'm not running 6.x!
%uname -a:
FreeBSD daemon.foo.lan 5.4-RELEASE-p8 FreeBSD 5.4-RELEASE-p8 #0: Sat Oct 22 12:38:08 CST 2005 root@daemon.foo.lan:/usr/obj/usr/src/sys/IAN i386

Cheers,
Ian
imoore is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Current NVIDIA FreeBSD graphics driver releases zander NVIDIA FreeBSD 0 01-27-09 05:22 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 08:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.