Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-05, 01:11 PM   #1
tux_gt
Registered User
 
Join Date: Nov 2004
Posts: 16
Default Blender and 1.0-7676

I have just updated from 1.0-6629 (patched) to 1.0-7676 and everything went fine. RenderAccel is still working fine. No problems with UT2004, Darwinia and Quake 4.

But I have a problem with Blender 2.37a (also with 2.40-alpha-test2): If I use the fullscreen mode (default mode) I get sometimes a black screen (sometimes complete, sometime partly), when I move the mouse or click the mouse. This also happens, when I switch back to Blender from another program. I did not have this problem with 1.0-6629.
If I use the windows mode (switch -w) this does not happen. Any hint what I should look for?

Thank you.

Part from xorg.conf:
Section "Device"
BoardName "GeForce 6800 GT"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "RenderAccel" "true"
Option "Coolbits" "1"
Option "NoLogo" "true"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection
tux_gt is offline   Reply With Quote
Old 11-11-05, 02:41 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Blender and 1.0-7676

If this reproduces without RenderAccel and Coolbits options, please generate and provide a bug report along with specific instructions required to reproduce this.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-12-05, 12:10 AM   #3
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: Blender and 1.0-7676

I have this same problem since a few driver versions ago. And both with my old Geforce3 Ti 200 and my new Geforce 6600. RenderAccel is not the issue. Windowed mode or fullscreen.

I noticed I get this blender-black-screen problem ONLY if I turn on antialiasing for 3d (either via nvidia-settings or environment variable).

I can reproduce the problem by:

- antialiasing for 3d on (say, 2x)

- start blender, by default, it gives you a cube, which is selected.

- hit "tab" to edit the cube

- hit "space bar" to bring up the menu

- the 3d area goes black!

Screenshot attached.
Attached Thumbnails
Click image for larger version

Name:	blender-aa.png
Views:	183
Size:	33.3 KB
ID:	14307  
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Old 11-12-05, 08:17 AM   #4
tux_gt
Registered User
 
Join Date: Nov 2004
Posts: 16
Default Re: Blender and 1.0-7676

I have the same effect with RenderAccel and Coolbits disabled.
I have tried it with antialiasing disabled (the default I use) and enabled: partly or complete black screen in Blender fullscreen (not in window mode). It looks like the screenshot from pigeon. I have attached (I hope) the log file from nvidia-bug-report.

I can reproduce the partly/complete black screen so:
Start Blender in fullscreen mode (default mode for Blender)
Press ALT-Tab to switch to another pogram
Press ALT-TAB to switch back to Blender: partly/complete black screen

Or
Start Blender in fullscreen mode
Press F12 to render the default view (a simple 3D box), a window with rendering result pop up
Press ESC to close the window with rendering result: complete black screen

I have tried it with the official builds from blender.org and my own builds (which I used default).

Thank you very much. The Nvidia support for Linux was the main reason, to buy the 6800GT for our new PCs. OK, and the speed
Attached Files
File Type: zip nvidia-bug-report.log.zip (26.9 KB, 178 views)
tux_gt is offline   Reply With Quote
Old 11-12-05, 09:50 AM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Blender and 1.0-7676

Thanks, I've reproduced this. I'll do so more testing next week and open a bug if this isn't resolved in the upcoming driver release.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-14-05, 12:05 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Blender and 1.0-7676

I've confirmed that this bug does not exist in the upcoming 1.0-8xxx driver.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-15-05, 07:28 AM   #7
tux_gt
Registered User
 
Join Date: Nov 2004
Posts: 16
Default Re: Blender and 1.0-7676

Great news! Thank you for your quick response.
Greetings, Carsten.
tux_gt is offline   Reply With Quote
Old 12-05-05, 02:30 PM   #8
tux_gt
Registered User
 
Join Date: Nov 2004
Posts: 16
Default Re: Blender and 1.0-7676

Blender is working fullscreen without getting black with 1.0-8174.
Thank you.
tux_gt is offline   Reply With Quote

Old 12-09-05, 06:06 AM   #9
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: Blender and 1.0-7676

Interesting.
I just upgraded to 8174.
I can still reproduce the same black 3d window area bug with blender...
(i.e. with antialiasing turned on only)
But, seriously, not that i'll turn on those antialiasing when i'm using blender, but i just though if a 3d program is doing exactly what blender is doing, then it might have the same trouble. So I guess i'll report this again.
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote
Old 12-09-05, 10:41 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Blender and 1.0-7676

The way that I can reproduce this problem with 1.0-8174 is if I have both the Composite extension and RenderAccel turned on, which is a separate and unrelated bug.

If you're still seeing this problem with 1.0-8174 (without RenderAccel & the Composite extension), please generate and provide a bug report.

Also, which version of blender are you using?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-09-05, 12:59 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Blender and 1.0-7676

Actually, after some additional testing, this isn't even reproducing with Composite +RenderAccel. When I was able to reproduce it with 1.0-8174, it was due to exhaustion of vmalloc space, which is a kernel issue. I was able to resolve that problem by booting with the vmalloc=128m parameter.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nouveau X.Org Driver Finally Releases Version 1.0 News Archived News Items 0 06-18-12 06:30 PM
Eurocom Monster 1.0: Clevo's Little Monster News Archived News Items 0 05-18-12 07:20 AM
nvidia drivers in a motherboard with AGP 1.0 (motherboard MVP3+) knocker NVIDIA Linux 1 08-19-02 01:57 AM

All times are GMT -5. The time now is 02:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.