Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-28-10, 12:15 AM   #97
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default Re: Nvidia support for Xen

These are my latest notes on how to use the NVIDIA binary driver (latest version recently released has not been tested) with a Xenlinux (non-pvops) kernel. It is merely a work-around for a "NVIDIA: unknown symbol init_mm" error which occurs as soon as the module tries to load. Ssee NOTE [1] for my specific kernel build details.

Note: This hack is experimental and I have been using it for just over 1 week now. Hopefully you will provide feedback on your own results or perhaps you know of a better solution.

Parts of these instructions are borrowed from the many guides that have come before mine. I have chosen to detail some of the areas where I ran into trouble. Please note, I do not run a desktop manager like [k|g]dm and I suggest that you disable it for the time being

Boot a non-xen kernel and install the NVIDIA driver. Ensure xorg is working properly. This step is to get common userland libraries populated that would be used regardless of the kernel version.

Boot the xen kernel and assuming /lib/modules/$(uname -r)/source does indeed point to your xen kernels sources:

$ sh NVIDIA-Linux-x86_64-195.36.15-pkg2.run --extract-only
Creating directory NVIDIA-Linux-x86_64-195.36.15-pkg2
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 195.36.15......................................... .................................................. .................................................. .......................

$ cd NVIDIA-Linux-x86_64-195.36.15-pkg2/usr/src/nv/
$ patch -p0 < ~/nv-hack.txt
patching file nv-linux.h

$ export IGNORE_XEN_PRESENCE=1
$ export SYSSRC=/lib/modules/$(uname -r)/source
$ export SYSOUT=/lib/modules/$(uname -r)/build
$ make clean module
<a lot of noise here>
NVIDIA: left KBUILD

$ sudo cp nvidia.ko /lib/modules/$(uname -r)/kernel/drivers/video/
$ sudo depmod -a
$ sudo modprobe nvidia

nv-hack.txt contents:
Code:
--- nv-linux.h.orig	2010-04-27 19:52:12.000000000 -0400
+++ nv-linux.h	2010-04-27 19:52:21.000000000 -0400
@@ -1013,7 +1013,7 @@
         if (!kernel)                                    \
             __pgd = pgd_offset(__mm, address);          \
         else                                            \
-            __pgd = pgd_offset_k(address);              \
+            __pgd = NULL;                               \
         __pgd;                                          \
     })
Results: I have tested mythfrontend for several hours which has ran fine while connected to a pv domU mythbackend on the same box. I have also ran games known to work in wine. I load the uvesafb module ahead of doing a startx as this works around loss of video when switching to virtual terminal or after exiting Xorg. Something that can happen regardless if xen is involved. As far as the kernel, there are a few udev burps in dmesg that I need to investigate but it has been plenty stable.



NOTE [1]
I am using 2.6.31.12 kernel sources + xen patches (http://gentoo-xen-kernel.googlecode.....31-14.tar.bz2)

$ cd && wget http://www.kernel.org/pub/linux/kern...6.31.12.tar.gz
$ wget http://gentoo-xen-kernel.googlecode.....31-14.tar.bz2
$ mkdir xen-patches && cd xen-patches && tar xjf ~/xen-patches-2.6.31-14.tar.bz2
$ cd /usr/src && tar xzf linux-2.6.31.12.tar.gz

Example patch method (this is borrowed from a guy named Boris aka dbaxps):
Code:
#! /bin/bash

cd /usr/src/linux-2.6.31.12 || exit

for P in `ls ~/xen-patches/*.patch1 | sort`
do
patch -p1 -s -i $P
if [ $? = 0 ]; then
echo $P applied
else
echo "Error processing "$P
exit 1
fi
done
Note: I couldn't get debian's make-kpkg to build this one properly so use the old school solution for now. UPDATE see NOTE [2]

$ cd /usr/src/linux-2.6.31.12
$ cp /boot/config-<some old version> ./
$ make oldconfig
$ make menuconfig #<insert link to guide for options to enable for xen here>
$ make -j4
$ sudo make modules_install install
$ sudo update-initramfs -c -k 2.6.31.12

I'm running grub2 which at this point I'll update /etc/grub/40_custom to add in this kernel to boot under xen
Code:
menuentry "Xen 4.0 / Ubuntu 10.4 kernel 2.6.31.12 sxen" {
insmod ext2
set root='(hd0,2)'
search --no-floppy --fs-uuid --set 321dedfa-be48-4b4d-bff0-0e5ecce240fd
multiboot /boot/xen-4.0.gz dummy=dummy iommu=pv dom0_mem=1024M
module /boot/vmlinuz-2.6.31.12 dummy=dummy root=/dev/sdc2 ro
module /boot/initrd.img-2.6.31.12
}
$ sudo update-grub



NOTE [2]
Problem: debian Kernel package build of xenified kernel fails when attempting to create bzImage (it will try to create bzImage regardless of passing --zimage to make-kpkg)

hack for arch/x86/Makefile (2.6.31.12 + andrew lyon's rebased suse patches already applied as described previously)

contents of makefilehack.txt
Code:
--- arch/x86/Makefile.orig	2010-05-02 12:24:38.000000000 -0400
+++ arch/x86/Makefile	2010-05-02 12:27:01.000000000 -0400
@@ -155,18 +155,19 @@
 LDFLAGS_vmlinux := -e startup_64
 endif
 
-# Default kernel to build
-all: vmlinuz
+endif
+## Default kernel to build
+#all: vmlinuz
 
-# KBUILD_IMAGE specifies the target image being built
-KBUILD_IMAGE := $(boot)/vmlinuz
+## KBUILD_IMAGE specifies the target image being built
+#KBUILD_IMAGE := $(boot)/vmlinuz
 
-vmlinuz: vmlinux
-	$(Q)$(MAKE) $(build)=$(boot) $(KBUILD_IMAGE)
-	$(Q)mkdir -p $(objtree)/arch/$(UTS_MACHINE)/boot
-	$(Q)ln -fsn ../../x86/boot/$@ $(objtree)/arch/$(UTS_MACHINE)/boot/$@
-else
-# Default kernel to build
+#vmlinuz: vmlinux
+#	$(Q)$(MAKE) $(build)=$(boot) $(KBUILD_IMAGE)
+#	$(Q)mkdir -p $(objtree)/arch/$(UTS_MACHINE)/boot
+#	$(Q)ln -fsn ../../x86/boot/$@ $(objtree)/arch/$(UTS_MACHINE)/boot/$@
+#else
+## Default kernel to build
 all: bzImage
 
 # KBUILD_IMAGE specify target image being built
@@ -176,7 +177,7 @@
 	$(Q)$(MAKE) $(build)=$(boot) $(KBUILD_IMAGE)
 	$(Q)mkdir -p $(objtree)/arch/$(UTS_MACHINE)/boot
 	$(Q)ln -fsn ../../x86/boot/bzImage $(objtree)/arch/$(UTS_MACHINE)/boot/$@
-endif
+#endif
 
 $(BOOT_TARGETS): vmlinux
 	$(Q)$(MAKE) $(build)=$(boot) $@
I changed config option CONFIG_XEN_COMPAT_030200_AND_LATER=y (bitmonk on #xen tells me that bzImage boot may only
work on xen 3.3 or something later ). This gets by the build failure for now.

The failure that occurs when CONFIG_XEN_COMPAT_030002_AND_LATER is set (its including linux/string.h):
arch/x86/boot/compressed/misc.c:135: error: conflicting types for ‘memcpy’
/usr/src/linux-2.6.31.12/arch/x86/include/mach-xen/asm/hypercall.h:289: note: previous implicit declaration of ‘memcpy’ was here
make[2]: *** [arch/x86/boot/compressed/misc.o] Error 1
make[1]: *** [arch/x86/boot/compressed/vmlinux] Error 2
make: *** [bzImage] Error 2


the build process would be something like:

$ cd /usr/src/linux-2.6.31.12
$ patch -p0 < ~/makefilehack.txt
$ cp /boot/config-<some old version> ./ #<need good default config>
$ make oldconfig
$ make menuconfig # enable xen options and set compat option higher
$ fakeroot make-kpkg clean
$ export CONCURRENY_LEVEL=4
$ fakeroot make-kpkg --append-to-version=-sxen1 kernel_image
$ cd ../
$ sudo dpkg -i linux-image-2.6.31.12-sxen1_2.6.31.12-sxen1-10.00.Custom_amd64.deb
$ sudo update-initramfs -c -k 2.6.31.12-sxen1

<update /etc/grub.d/40_custom as noted before>
$ sudo update-grub

Last edited by Armedblade; 05-06-10 at 09:23 PM.
Armedblade is offline   Reply With Quote
Old 10-15-10, 08:52 PM   #98
kumar1234
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: Nvidia support for Xen

Hello,

I am are trying to install the nvidia module as mentioned in the above post.
I am using Ubuntu 10.04.

The module is loading properly and there are no errors while loading.
But when I try to start X by giving "service gdm start" there is an error
in X saying that nvidia module not found.

Please let me know how to proceed!

Thanks,
Kumar.

Here is the Xorg.0.log

cat /var/log/Xorg.0.log

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
Current Operating System: Linux cuda2 2.6.31.12 #2 SMP Fri Oct 15 17:14:31 EDT 2010 x86_64
Kernel command line: root=UUID=8000fce4-6301-49ee-aaf2-b5e601903ef2 ro
Build Date: 21 July 2010 01:03:39PM
xorg-server 2:1.7.6-2ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Oct 15 21:44:09 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Device0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
(**) ModulePath set to "/usr/lib64/xorg/modules/,/usr/lib/xorg/modules/extensions"
(II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x7ca300
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 6.0
X.Org XInput driver : 7.0
X.Org Server Extension : 2.0
(--) using VT number 8

(--) PCI: (0:3:0:0) 10de:0604:10de:0504 nVidia Corporation G92 [GeForce 9800 GX2] rev 162, Mem @ 0xf9000000/16777216, 0xc0000000/268435456, 0xf6000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/131072
(--) PCI:*(0:4:0:0) 10de:0604:10de:0504 nVidia Corporation G92 [GeForce 9800 GX2] rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 195.36.15 Fri Mar 12 01:17:05 PST 2010
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log
kumar1234 is offline   Reply With Quote
Old 10-15-10, 09:30 PM   #99
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default Re: Nvidia support for Xen

I don't think the errors always show up on console. Did you check dmesg after loading it? show output for:

$ sudo modprobe nvidia && dmesg | grep -i nvidia
Armedblade is offline   Reply With Quote
Old 10-16-10, 09:51 AM   #100
kumar1234
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: Nvidia support for Xen

Yeah, I have checked with dmesg. There are no errors. Here is the output:


alex@cuda2:~$ sudo modprobe nvidia && dmesg | grep -i nvidia
[ 82.676334] nvidia: module license 'NVIDIA' taints kernel.
[ 82.934770] nvidia 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 82.934782] nvidia 0000:03:00.0: setting latency timer to 64
[ 82.934967] nvidia 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 82.934975] nvidia 0000:04:00.0: setting latency timer to 64
[ 82.935788] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
[ 1246.807565] nvidia 0000:03:00.0: setting latency timer to 64
[ 1246.807736] nvidia 0000:04:00.0: setting latency timer to 64
[ 1246.807893] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
[ 3672.545268] nvidia 0000:03:00.0: setting latency timer to 64
[ 3672.545491] nvidia 0000:04:00.0: setting latency timer to 64
[ 3672.545653] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
[ 3906.465666] nvidia 0000:03:00.0: setting latency timer to 64
[ 3906.465825] nvidia 0000:04:00.0: setting latency timer to 64
[ 3906.465970] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
[52053.578653] nvidia 0000:03:00.0: setting latency timer to 64
[52053.578824] nvidia 0000:04:00.0: setting latency timer to 64
[52053.579342] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
[52067.184111] nvidia 0000:03:00.0: setting latency timer to 64
[52067.184258] nvidia 0000:04:00.0: setting latency timer to 64
[52067.184699] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
kumar1234 is offline   Reply With Quote
Old 10-16-10, 09:59 AM   #101
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default Re: Nvidia support for Xen

I haven't had any issues getting it to work. You ran the binary while booted in a generic kernel sometime before/after compiling the driver on the Xenified kernel correct? Additionally your xorg.conf was provided by nvidia-settings?

EDIT: What Xenified kernel are you using? I see Linux cuda2 2.6.31.12, i suppose you built that based on the build instructions above.
Armedblade is offline   Reply With Quote
Old 10-16-10, 10:09 AM   #102
kumar1234
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: Nvidia support for Xen

hmmm. I ran the binary on the Xen kernel itself. Here is my xorg.conf. I am using Xen 4.0 and linux 2.6.31.12 as mentioned in the post.

alex@cuda2:~$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Mar 12 02:12:40 PST 2010


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/"
ModulePath "/usr/lib/xorg/modules/extensions"
EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
kumar1234 is offline   Reply With Quote
Old 10-16-10, 10:35 AM   #103
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default Re: Nvidia support for Xen

You say you followed the guide but it doesn't tell you to boot the Xenified kernel to install the drivers.

My guess is the xorg.log complaining about missing module is not the nvidia binary driver module but the xorg module nvidia_drv.so perhaps. Perhaps the userland files for the driver are not in the state you expect to them to be. If you haven't already, you need to install the driver while booted on generic kernel including the 32 bit compatibility libraries.
Armedblade is offline   Reply With Quote
Old 10-16-10, 10:39 AM   #104
kumar1234
Registered User
 
Join Date: Oct 2010
Posts: 4
Default Re: Nvidia support for Xen

From the above guide:

>Boot a non-xen kernel and install the NVIDIA driver. Ensure xorg is working properly. This step is to get common userland libraries populated that would be used regardless of the kernel version.

>Boot the xen kernel and assuming /lib/modules/$(uname -r)/source does indeed point to your xen kernels sources:

This is what I did. I installed NVIDIA drivers on a generic kernel. That is working fine and is able to locate the driver.

Then I boot into the xen kernel and proceed with installation which goes fine.
kumar1234 is offline   Reply With Quote

Old 10-16-10, 10:48 AM   #105
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default Re: Nvidia support for Xen

I'd use startx as opposed starting gdm while troubleshooting.

Will xorg start using the "nv" driver on the Xenified kernel?

Another option may be to:
$ sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.orig
$ sudo X -configure
check generated file to see if it is using Driver "nv" or "nvidia" and update it to use "nvidia"
$ sudo mv <file that was generated> /etc/X11/xorg.conf
$ startx
Armedblade is offline   Reply With Quote
Old 11-05-10, 12:12 AM   #106
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default Re: Nvidia support for Xen

UPDATE: newest series drivers do not need a hack and work under Xen if you use the manual approach described previously.

I was able to get the latest nvidia-current pkg to install/compile/etc, even under Xen [It uses dkms]. The resulting nvidia-current.ko module, which loads, will not let me start Xorg (errors regarding /dev/nvidia0) so I've squashed that idea for now.

Last edited by Armedblade; 11-07-10 at 11:15 AM.
Armedblade is offline   Reply With Quote
Old 01-28-11, 07:00 PM   #107
uOpt
FreeBSD cheering section
 
uOpt's Avatar
 
Join Date: Nov 2004
Location: Boston, MA, USA
Posts: 609
Default Re: Nvidia support for Xen

Are you guys running the X11 server with NVidia drivers in the Dom0 or a DomU?

Sorry, it's a bit lost in the long thread.
__________________

My Unix benchmark results
uOpt is offline   Reply With Quote
Old 05-02-11, 09:11 AM   #108
moenchmeyer
Registered User
 
Join Date: Oct 2007
Posts: 30
Default Re: Nvidia support for Xen

I tried to use the NVIDIA driver 270.41.06 together with Opensuse 11.4 and XEN.
My graphics card is a 9800 GTX+.

I followed this procedure

init 3
cd Directory_With_Nvidia_Driver
export IGNORE_XEN_PRESENCE=1 SYSSRC=/usr/src/linux-2.6.37.6-0.5 SYSOUT=/usr/src/linux-2.6.37.6-0.5-obj/x86_64/xen

sh ./NVIDIA-Linux-x86_64-270.41.06.run

The compilation etc. worked quite well and after "init 5" I got a perfectly working graphical X11/KDE 4.6 environment - as for the standard kernel.

However, for the XEN kernel there is an annoying side effect:

The text consoles tty1 to tty6 and tty10 do not work any more after init 5 . Meaning that by using CTRL ALT Fx I only get a black screen for the ttyx. But with CTRL ALT F7 I can return to the graphical environment.

Any ideas what I could do or try to get the switch to the ttys working?
moenchmeyer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remastered Doom 3 BFG Edition Game Coming with Stereo 3D Support News Archived News Items 0 06-01-12 05:30 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Official Detonator 40.xx Feedback Thread pelly NVIDIA Windows Graphics Drivers 299 09-22-02 06:54 AM

All times are GMT -5. The time now is 07:16 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.