Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-18-05, 04:59 PM   #1
djfuzz
Registered User
 
Join Date: May 2004
Posts: 18
Default Black & White tv?!

Hi all,

I've did an complete re-install of my myth media center beacause i wanted support for my DVB card so i installed my system with the 2.6.13 kernel.
I was using an very old NVIDIA driver which functioned very well, but since my re-install i only get an Black&White version of mythtv!
I did set the Option "TVStandard" to "PAL-B" (live in the netherlands) but it doesn't seem to respond to that option. I only get an color version of mythtv on another tv which has an AV-S option (S fot SECAM?).
My config:

Linux Core edition (Not fedora!) @ kernel 2.6.13 with NVIDIA driver version: 7676.
NVIDIA Ge-force fx5200 with S-VIDEO output.
And an old SONY TV which i want it to be connected to.

Any suggestions? Thanks in advance!
__________________
Linux rig (JukeboXz): 800Mhz pIII/Core dist V.2.6.13/SB Live 5.1/Geforce fx5200/256MB mem/Pinnacle SAT CI DVB card
ME = NOT RUNNING FEDORA CORE IM RUNNING: Core Dist!
djfuzz is offline   Reply With Quote
Old 11-18-05, 05:19 PM   #2
poca
Registered User
 
Join Date: Apr 2005
Posts: 25
Default Re: Black & White tv?!

I have a similar problem if the s-video cable is non connected and if the TV is not on the correct channel before I start my x server with TV-out enable.

But if all is correctly connected and set, it works fine.
poca is offline   Reply With Quote
Old 11-19-05, 04:36 AM   #3
djfuzz
Registered User
 
Join Date: May 2004
Posts: 18
Default Re: Black & White tv?!

mmm thanks i'l try, how do u connect your svideo to your tv: using a svideo to scart converter?
That's the way i connect it to my TV.
It seems that the 7XXX series of the driver have the same problem, i've tried all of them with no luck!
__________________
Linux rig (JukeboXz): 800Mhz pIII/Core dist V.2.6.13/SB Live 5.1/Geforce fx5200/256MB mem/Pinnacle SAT CI DVB card
ME = NOT RUNNING FEDORA CORE IM RUNNING: Core Dist!
djfuzz is offline   Reply With Quote
Old 11-19-05, 05:57 AM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: Black & White tv?!

Note that when you connect use a svideo -> scart converter it is normal that you have this problem. In short in case of composite the 'gray + color' (luminance and chrominance) are send using the same wire. In case of svideo both have their own wire. When using a svideo -> scart converter most televisions think that you are using composite. They only use one of the wires which causes black&white. You can try to choose composite in your X config file or else the other way is to solder a capacitor of 470pF in the scart converter between the luminance and chrominance wire. Using this way this way you combine luminance and chrominance and then the TV works fine.
Thunderbird is offline   Reply With Quote
Old 11-23-05, 04:27 PM   #5
djfuzz
Registered User
 
Join Date: May 2004
Posts: 18
Default Re: Black & White tv?!

Wow thank you Thunderbird!
That is possible because with the old drivers i've had to set the configuration file to composite and my tv had colours again!
But with the new drivers i can't use composite anymore because i get an black screen when i do so!

So i'l think i use the capacitor trick !

But still isn't it strange it did work in the beginning and when i installed a new driver everything was black and white?

Thanks!
__________________
Linux rig (JukeboXz): 800Mhz pIII/Core dist V.2.6.13/SB Live 5.1/Geforce fx5200/256MB mem/Pinnacle SAT CI DVB card
ME = NOT RUNNING FEDORA CORE IM RUNNING: Core Dist!
djfuzz is offline   Reply With Quote
Old 12-21-05, 07:27 PM   #6
jeisom
Registered User
 
Join Date: Dec 2005
Location: My own little world
Posts: 117
Default Re: Black & White tv?!

Has anybody a proper solution to this. I'm using 8174 on a pny 6600. the tv displays color up until x starts. here is my relevant xorg.conf info:


Section "Screen"

#Visual "DirectColor"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
Option "Accel" # [<bool>]
Option "AGPSize" "64" # <i>
Option "AGPMode" "8"
Option "AGPFastWrite" "True"
Option "HWCursor" "True"
Option "NvAGP" "0"
Option "NoLogo" "0"
Option "TwinView" "True"
Option "TwinViewOrientation" "Below"
Option "UseEdidFreqs" "True"
Option "MetaModes" "1600x1200, 1024x768"
SubSection "Display"
Depth 24
Modes "1600x1200"
Option "NvAGP" "0"
Option "NoLogo" "1"
Option "ConnectedMonitor" "crt,tv"
Option "TVStandard" "NTSC-M"
Option "TVFormat" "SVIDEO"
#Option "TVFormat" "Composite"
EndSubSection
EndSection


both TVFormats do black and with
jeisom is offline   Reply With Quote
Old 12-21-05, 07:50 PM   #7
jeisom
Registered User
 
Join Date: Dec 2005
Location: My own little world
Posts: 117
Default Re: Black & White tv?!

never mind. found that Option "TVOutFormat" "SVIDEO"
fixed the problem.
jeisom is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
$144.99 - ASUS ML248H Black / White 24" 2ms HDMI LED Backlight Widescreen LCD Monit News 24-Inch 0 06-22-12 04:00 PM
AMD FX-8120 Black Edition CPU Review (with Asus M5A99X EVO) News Archived News Items 0 06-21-12 08:30 AM
GeForce4 TV-out only displays black and white dlapo NVIDIA GeForce 7, 8, And 9 Series 6 12-25-05 04:16 AM
Black and White 2 creature pictures JohnsonLKD Gaming Central 1 08-22-02 01:51 PM

All times are GMT -5. The time now is 09:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.