Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-06, 09:53 AM   #1
tbyte
Registered User
 
tbyte's Avatar
 
Join Date: Apr 2003
Location: Europe, Bulgaria
Posts: 28
Unhappy problems with 1.0-8762, GF6200 and GF6800GT

I got GF6200 (AGP agp.ko is loaded) at office and GF6800GT (PCI-E) at home and everything worked fine with driver 1.0-8178. But when I upgraded to 1.0-8762 the computer with GF6200 instantly reboots after closing any aplication that uses OpenGL (e.g screensavers or glxgears) and the computer with GF6800GT would not allow me to set 1280x1024 at 100Hz refresh rate (it worked with 8178).

Last edited by tbyte; 06-01-06 at 10:08 AM.
tbyte is offline   Reply With Quote
Old 06-01-06, 11:32 AM   #2
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: problems with 1.0-8762, GF6200 and GF6800GT

Post your xorg.conf and the changes you made to loader.conf and device.hints. I had a similar problem, but I forgot what change I made to fix it. Also, make sure not to load the acpi_video driver. It grabs the video card before the nvidia driver can.
Harvey Pooka is offline   Reply With Quote
Old 06-01-06, 03:49 PM   #3
tbyte
Registered User
 
tbyte's Avatar
 
Join Date: Apr 2003
Location: Europe, Bulgaria
Posts: 28
Default Re: problems with 1.0-8762, GF6200 and GF6800GT

Here are xorg.confs and kldstats from the two machines.
Attached Files
File Type: txt GF6800GT-kldstat.txt (767 Bytes, 178 views)
File Type: txt xorg.conf.GF6800GT.txt (2.7 KB, 190 views)
File Type: txt xorg.conf.GF6200.txt (5.5 KB, 218 views)
File Type: txt GF6200-kldstat.txt (1.3 KB, 210 views)
tbyte is offline   Reply With Quote
Old 06-01-06, 05:30 PM   #4
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: problems with 1.0-8762, GF6200 and GF6800GT

6200: Did you compile the nvidia-driver port with support for FreeBSD AGP? Also, is that LoadKernelModule option needed for your system?

6800GT: Check what xorg.log has in it for EDID. The nvidia driver may be picking its own refresh and sync values. I used to have the IgnoreEDID option in my xorg.conf, but it is now ignored. Search the README file for UseEdidFreqs to see if that helps.
Harvey Pooka is offline   Reply With Quote
Old 06-04-06, 07:39 AM   #5
tbyte
Registered User
 
tbyte's Avatar
 
Join Date: Apr 2003
Location: Europe, Bulgaria
Posts: 28
Default Re: problems with 1.0-8762, GF6200 and GF6800GT

GF6200: Yes it is with support for FreeBSD AGP and the driver is loaded from loader.conf (and agp.ko as dependancie)

GF6800GT:

Xorg.0.logWW) NVIDIA(0): Unable to get display device CRT-1's EDID; cannot compute DPI
Xorg.0.logWW) NVIDIA(0): from EDID.
Xorg.0.log-(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default

I wander how does this worked with old driver ... monitor is DELL Trinitron P1130 (21").
tbyte is offline   Reply With Quote
Old 06-05-06, 11:22 AM   #6
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: problems with 1.0-8762, GF6200 and GF6800GT

GF6200: I think that may have been my problem. I had tried using the FreeBSD AGP driver for both my laptop and desktop. While the desktop handled it better, I think I had stability problems with both. The desktop would eventually lock up while the laptop would panic right after glxinfo finished. Try using the Nvidia AGP driver.

GF6800GT: I think Nvidia changed the way the EDID code (and other stuff around DPMS) worked. For me, DPMS no longer works on my desktop. The screen blanks but the backlight of my LCD is still on. I have to turn the monitor off, move the mouse or hit a key and turn the monitor on before I can see anything again; it gets locked into that state.

I read (and hopefully interpreted correctly) that the acpi_video driver in FreeBSD should be better behaved in 7 (http://groups.google.com/group/fa.fr...1ddd0f1103d8dc) since it will no longer be an all or nothing lock on the device as it is now. Currently, only acpi_video or Nvidia may grab the device.
Harvey Pooka is offline   Reply With Quote
Old 06-22-06, 06:15 PM   #7
tbyte
Registered User
 
tbyte's Avatar
 
Join Date: Apr 2003
Location: Europe, Bulgaria
Posts: 28
Default Re: problems with 1.0-8762, GF6200 and GF6800GT

Thanks for Your help but I got pissed by 8762 and went back to 8178 and everythink is fine now ... I hope nVidia test thist crap next time they make a release. I can swalow the crash in low end 6200 but having problems with 6800GT ...
Thanks again for your help - I learned some neat things from you
tbyte is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:27 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.