Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-01-05, 08:54 PM   #1
sams0n
Registered User
 
Join Date: Dec 2005
Posts: 24
Default TVout+X = lockup on exiting, switching to console (bug reports)

Gentoo kernel 2.6.13 (had this issue on other versions too)
GF4 ti 4200 + tvout
NV driver 7676
Xorg 6.8.2

Description:
When I use X with one monitor configured (without tv-out) everything works fine. I can switch to console and back, exit X and start it again without any problems. If I change xorg.conf file to enable the tv-out by uncommenting this line Screen 1 "TV" rightof "Monitor", I cannot exit X or switch to console as the damn thing locks up completely. It works great with Tv-out though. The only problem - I cannot use consoles and exit X, as it punishes me with complete lockup.

Here is the log attached with X running in tvout mode. Thanks for your help.

PS: if any happy nvidia user has the same problem, would you mind posting your logs to help nvidia fix it. It is easy to do
Attached Files
File Type: zip nvidia-bug-report.log.zip (25.3 KB, 131 views)
sams0n is offline   Reply With Quote
Old 12-06-05, 01:22 AM   #2
sams0n
Registered User
 
Join Date: Dec 2005
Posts: 24
Default Re: TVout+X = lockup on exiting, switching to console (bug reports)

I have tested the new drivers 8174. The same setup, I have only changed the nvidia drivers.

The lockup is gone (thankyou^1000). Now I am able to switch back and forth with my Tv-out setup. But some other problems emerged.

1) Tv-out signal is out of sync. The signal goes to TV, but it is completely screwed (white horizontal lines on black background that change their patterns when I open some app on DISPLAY=:0.1). It is something wrong with clock pixel timings, I guess, according to the previous X log vs current.

2) When I switch to console, the console font reserts to default(?) font (and I am using ter-c14f). So I need to "setfont ter-c14f" every time I visit the console. Any chance to change that?

Thank you very much for any reply.

Pls find attached the 8174 log.
Attached Files
File Type: zip nvidia-bug-report.log.8174.zip (26.1 KB, 118 views)
sams0n is offline   Reply With Quote
Old 12-06-05, 01:24 PM   #3
nvneus
Registered User
 
Join Date: Jul 2004
Posts: 5
Default Re: TVout+X = lockup on exiting, switching to console (bug reports)

I've got the same problem (corrupted tvout) as the prevoius poster. I went from 6111 to 8174 (2.6.14). I used to have a working dual head setup. If you find a solution please post about it. I will do the same.

Good Luck,
Arco
Attached Files
File Type: zip nvidia-bug-report.log.zip (22.3 KB, 103 views)
nvneus is offline   Reply With Quote
Old 12-06-05, 07:14 PM   #4
mimetux
Registered User
 
Join Date: Dec 2005
Posts: 2
Default Re: TVout+X = lockup on exiting, switching to console (bug reports)

Mandriva 2006
2.6.12.12 Kernel
Xorg 6.8.99.900
Video card : Gforce4 Ti 4200 whit AGP 8x

hello,i've the same problem,so look at this

My Xorg.0.log on the Encoder section whit 7676 Nvidia driver

(--) NVIDIA(0): Detected TV Encoder: Philips

and now,after installing 8174 Nvidia driver

(--) NVIDIA(0): Detected TV Encoder: Brooktree 873 << Oups !!

i see Brooktree 873 encoder ,the problem is here

thank you for any reply
mimetux is offline   Reply With Quote
Old 12-07-05, 03:22 AM   #5
nvneus
Registered User
 
Join Date: Jul 2004
Posts: 5
Default Re: TVout+X = lockup on exiting, switching to console (bug reports)

Nice call. Same here. Your on to something. For the record on my MSI G4Ti 4200-VTD8X there is a Philips SAA7114H.
nvneus is offline   Reply With Quote
Old 12-23-05, 04:20 AM   #6
sams0n
Registered User
 
Join Date: Dec 2005
Posts: 24
Default Re: TVout+X = lockup on exiting, switching to console (bug reports)

Gentoo kernel 2.6.13 (had this issue on other versions too)
GF4 ti 4200 + tvout
NV driver --->> 8178 <<----
Xorg 6.8.2

That finally happened!
Now I can switch to console and back. Use TV-Out, exit Xorg and start it back. Everything works! Nice support, NVIDIA!

There is one minor problem left - console fonts are reset to default(?) everytime I switch to console from Xorg. That can be fixed with "setfont ter-c14f" command. In which case I have problems switching back to Xorg, pressing Alt-F7 gives me tildas (~) in console. But I can live with it.

Thanks again
sams0n is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
BUG 302.17 - can not access TTY console legluondunet NVIDIA Linux 9 06-24-12 06:16 PM
TwinView & Console bug topman NVIDIA Linux 3 08-16-02 10:32 AM

All times are GMT -5. The time now is 07:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.