Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-05-05, 10:20 PM   #1
kraney
Registered User
 
Join Date: Apr 2005
Posts: 41
Default 8174 doesn't like 1080i

With the 8174 driver in place, 1080i and 720p are not recognized as standard TV resolutions. My xorg.conf works fine at 1080i with driver 7676, drops to 640x480 with 8175. This is with a GeForce 6200 connected via composite out.
Attached Files
File Type: log nvidia-bug-report.log (95.8 KB, 110 views)
kraney is offline   Reply With Quote
Old 12-06-05, 01:56 AM   #2
Sewage_Calamari
Registered User
 
Join Date: Nov 2005
Posts: 2
Default Re: 8174 doesn't like 1080i

I have the same problem. Using Component output, 1920x1080i isn't recognized as a valid TV output mode, whereas it was before with the 7676 drivers. In fact I can't get any resolutions to work. I'm using the same configuration as before too. Any help would be appreciated.

Thanks.

Attached Files
File Type: txt 8174bugreport.txt (92.5 KB, 120 views)
Sewage_Calamari is offline   Reply With Quote
Old 12-07-05, 02:04 PM   #3
korpenkraxar
Registered User
 
Join Date: Dec 2005
Posts: 7
Thumbs down Re: 8174 doesn't like 1080i

Same thing here. MSI 6200 with HD1080i. Worked with 7676, not with 8174. Here we go again...
korpenkraxar is offline   Reply With Quote
Old 12-07-05, 03:06 PM   #4
rufusosx
Registered User
 
Join Date: Dec 2005
Posts: 2
Default Re: 8174 doesn't like 1080i

Same, all modes are rejected as not being valid TV modes. 720p was working fine with 7676 on the composite outs of my 6200.
rufusosx is offline   Reply With Quote
Old 12-07-05, 03:34 PM   #5
JoshPrismon
Registered User
 
Join Date: Nov 2005
Posts: 24
Default Re: 8174 doesn't like 1080i

Has anyone been able to configure this to work? I have a Mythbox I have been setting up, and the last thing I need to get working before taking the monitor off is 1080i or 480p.

Random seperate question, you are you directly specifying what you want the resolution to be? I get that you need to set the TVStandard to HD720p, HD1080i or HD480p. Since there is no TVOutFormat Component, I assume you have to ignore that line completly or use TVOutFormat SVIDEO. Are you still limited to 30-50 Second Monitory Syncs when using HDTV?

Does all of this require adding new modelines, or are the drivers smart enough to pick modes bassed on the TVOutFormat
JoshPrismon is offline   Reply With Quote
Old 12-07-05, 10:20 PM   #6
kraney
Registered User
 
Join Date: Apr 2005
Posts: 41
Default Re: 8174 doesn't like 1080i

Actually, there is a TVOutFormat COMPONENT, which is what I use. I also had to add a modeline for 1080i. I use this one:

ModeLine "1080i" 74.5 1920 1952 2016 2208 1080 1084 1096 1126 -hsync -vsync interlace

Of course, don't bother trying it with the new driver, use 7676.
kraney is offline   Reply With Quote
Old 12-09-05, 02:52 AM   #7
JoshPrismon
Registered User
 
Join Date: Nov 2005
Posts: 24
Default Re: 8174 doesn't like 1080i

Try this. Modify /etc/inittab to boot up to init level 3 instead of 5. Login as root, or use sudo to start X manually (startx). Does it work for you? This error went away when I tried that, but for some reason my screen is mono chrome when it starts up (seems to be sending SVIDEO or Composite via the Component so everything has a blueish tinge?)
JoshPrismon is offline   Reply With Quote
Old 12-10-05, 04:07 PM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 8174 doesn't like 1080i

Please generate and attach an nvidia-bug-report.log file if you experience this problem.
zander is offline   Reply With Quote

Old 12-10-05, 07:49 PM   #9
JoshPrismon
Registered User
 
Join Date: Nov 2005
Posts: 24
Default Re: 8174 doesn't like 1080i

See attached for this not working in the standard GDM boot up.
Attached Files
File Type: zip nvidia-bug-report.zip (25.1 KB, 103 views)
JoshPrismon is offline   Reply With Quote
Old 12-10-05, 08:07 PM   #10
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 8174 doesn't like 1080i

@JoshPrismon: so in your case, at least, the problem goes away if you start X manually with `startx`? Can you attach the X server log files created (preferably in verbose mode) in each case?
zander is offline   Reply With Quote
Old 12-10-05, 11:55 PM   #11
JoshPrismon
Registered User
 
Join Date: Nov 2005
Posts: 24
Default Re: 8174 doesn't like 1080i

Quote:
Originally Posted by zander
@JoshPrismon: so in your case, at least, the problem goes away if you start X manually with `startx`? Can you attach the X server log files created (preferably in verbose mode) in each case?
I am not sure how to force GDM to start up X with verbose on. I turned debug on above, but that doesn't seem to have helped it.

Even stranger:
  • Starting X via GDM doesn't work
  • Running startx as root doesn't work.
  • Starting start x using "sudo startx --logverbose 5" does work!?

Here is the difference in the X.org log from running it as root -> startx and running it as sudo:

< (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 10 22:47:26 2005
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 10 22:42:03 2005
296a297
> (II) Found 1 PCI NVIDIA devices
378a380,381
> (==) NVIDIA(0): Using HW cursor
> (==) NVIDIA(0): Video key set to default value of 0x101fe
380a384,386
> (--) NVIDIA(0): Found 2 CRTCs on board
> (II) NVIDIA(0): Supported display device(s): CRT-0, CRT-1, DFP-0, TV-0
> (II) NVIDIA(0): Boot display device(s): TV-0
381a388,390
> (II) NVIDIA(0): Chip Architecture: 0x40
> (II) NVIDIA(0): Chip Implementation: 0x43
> (II) NVIDIA(0): Chip Revision: 0xa4
383a393
> (II) NVIDIA(0): Bus detected as PCI Express
386a397
> (II) NVIDIA(0): Enabled display device(s): TV-0
387a399,448
> (II) NVIDIA(0): Supported TV modes:
> (II) NVIDIA(0): TV Standard: NTSC-M: 320x200
> (II) NVIDIA(0): TV Standard: NTSC-M: 320x240
> (II) NVIDIA(0): TV Standard: NTSC-M: 400x300
> (II) NVIDIA(0): TV Standard: NTSC-M: 640x400
> (II) NVIDIA(0): TV Standard: NTSC-M: 640x480
> (II) NVIDIA(0): TV Standard: NTSC-M: 720x480
> (II) NVIDIA(0): TV Standard: NTSC-M: 800x600
> (II) NVIDIA(0): TV Standard: NTSC-M: 1024x768
> (II) NVIDIA(0): TV Standard: NTSC-J: 320x200
> (II) NVIDIA(0): TV Standard: NTSC-J: 320x240
> (II) NVIDIA(0): TV Standard: NTSC-J: 400x300
> (II) NVIDIA(0): TV Standard: NTSC-J: 640x400
> (II) NVIDIA(0): TV Standard: NTSC-J: 640x480
> (II) NVIDIA(0): TV Standard: NTSC-J: 720x480
> (II) NVIDIA(0): TV Standard: NTSC-J: 800x600
> (II) NVIDIA(0): TV Standard: NTSC-J: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-M: 320x200
> (II) NVIDIA(0): TV Standard: PAL-M: 320x240
> (II) NVIDIA(0): TV Standard: PAL-M: 400x300
> (II) NVIDIA(0): TV Standard: PAL-M: 640x400
> (II) NVIDIA(0): TV Standard: PAL-M: 640x480
> (II) NVIDIA(0): TV Standard: PAL-M: 720x480
> (II) NVIDIA(0): TV Standard: PAL-M: 800x600
> (II) NVIDIA(0): TV Standard: PAL-M: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 320x200
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 320x240
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 400x300
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 640x400
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 640x480
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 720x576
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 800x600
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-N: 320x200
> (II) NVIDIA(0): TV Standard: PAL-N: 320x240
> (II) NVIDIA(0): TV Standard: PAL-N: 400x300
> (II) NVIDIA(0): TV Standard: PAL-N: 640x400
> (II) NVIDIA(0): TV Standard: PAL-N: 640x480
> (II) NVIDIA(0): TV Standard: PAL-N: 720x576
> (II) NVIDIA(0): TV Standard: PAL-N: 800x600
> (II) NVIDIA(0): TV Standard: PAL-N: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-NC: 320x200
> (II) NVIDIA(0): TV Standard: PAL-NC: 320x240
> (II) NVIDIA(0): TV Standard: PAL-NC: 400x300
> (II) NVIDIA(0): TV Standard: PAL-NC: 640x400
> (II) NVIDIA(0): TV Standard: PAL-NC: 640x480
> (II) NVIDIA(0): TV Standard: PAL-NC: 720x576
> (II) NVIDIA(0): TV Standard: PAL-NC: 800x600
> (II) NVIDIA(0): TV Standard: PAL-NC: 1024x768
> (II) NVIDIA(0): Mapping display device 0 (TV-0) to CRTC 0
388a450
> (II) NVIDIA(0): TVs do not provide EDIDs; skipping EDID probe on TV-0
402a465,475
> (II) NVIDIA(0): Saved console TV mode: 3
> (II) NVIDIA(0): Processing requested modes for display device TV-0:
> (II) NVIDIA(0): "1400x1050"
> (II) NVIDIA(0): "1280x960"
> (II) NVIDIA(0): "1280x800"
> (II) NVIDIA(0): "1280x1024"
> (II) NVIDIA(0): "1152x864"
> (II) NVIDIA(0): "1152x768"
> (II) NVIDIA(0): "1024x768"
> (II) NVIDIA(0): "800x600"
> (II) NVIDIA(0): "640x480"
620a694,697
> (II) NVIDIA(0): kernel module enabled successfully
> (II) NVIDIA(0): Memory mapped
> (II) NVIDIA(0): Interrupts enabled
> (II) NVIDIA(0): No MetaMode found for mode "1024x768"
621a699
> (II) NVIDIA(0): First mode initialized
623a702,705
> (II) NVIDIA(0): Visuals set up
> (II) NVIDIA(0): Pixmap depths set up
> (II) NVIDIA(0): GLX visuals set up
> (II) NVIDIA(0): Framebuffer set up
626a709,710
> (II) NVIDIA(0): Default colormap initialized.
> (II) NVIDIA(0): Palette loaded
629a714
> (II) NVIDIA(0): Screen initialization complete
673a759
> (**) Option "Device" "/dev/input/mice"
675a762
> (II) NVIDIA(0): Restored console TV mode: 3
[josh@localhost ~]$ sudo diff /var/log/Xorg.0.log*
17c17
< (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 10 22:47:26 2005
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 10 22:42:03 2005
296a297
> (II) Found 1 PCI NVIDIA devices
378a380,381
> (==) NVIDIA(0): Using HW cursor
> (==) NVIDIA(0): Video key set to default value of 0x101fe
380a384,386
> (--) NVIDIA(0): Found 2 CRTCs on board
> (II) NVIDIA(0): Supported display device(s): CRT-0, CRT-1, DFP-0, TV-0
> (II) NVIDIA(0): Boot display device(s): TV-0
381a388,390
> (II) NVIDIA(0): Chip Architecture: 0x40
> (II) NVIDIA(0): Chip Implementation: 0x43
> (II) NVIDIA(0): Chip Revision: 0xa4
383a393
> (II) NVIDIA(0): Bus detected as PCI Express
386a397
> (II) NVIDIA(0): Enabled display device(s): TV-0
387a399,448
> (II) NVIDIA(0): Supported TV modes:
> (II) NVIDIA(0): TV Standard: NTSC-M: 320x200
> (II) NVIDIA(0): TV Standard: NTSC-M: 320x240
> (II) NVIDIA(0): TV Standard: NTSC-M: 400x300
> (II) NVIDIA(0): TV Standard: NTSC-M: 640x400
> (II) NVIDIA(0): TV Standard: NTSC-M: 640x480
> (II) NVIDIA(0): TV Standard: NTSC-M: 720x480
> (II) NVIDIA(0): TV Standard: NTSC-M: 800x600
> (II) NVIDIA(0): TV Standard: NTSC-M: 1024x768
> (II) NVIDIA(0): TV Standard: NTSC-J: 320x200
> (II) NVIDIA(0): TV Standard: NTSC-J: 320x240
> (II) NVIDIA(0): TV Standard: NTSC-J: 400x300
> (II) NVIDIA(0): TV Standard: NTSC-J: 640x400
> (II) NVIDIA(0): TV Standard: NTSC-J: 640x480
> (II) NVIDIA(0): TV Standard: NTSC-J: 720x480
> (II) NVIDIA(0): TV Standard: NTSC-J: 800x600
> (II) NVIDIA(0): TV Standard: NTSC-J: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-M: 320x200
> (II) NVIDIA(0): TV Standard: PAL-M: 320x240
> (II) NVIDIA(0): TV Standard: PAL-M: 400x300
> (II) NVIDIA(0): TV Standard: PAL-M: 640x400
> (II) NVIDIA(0): TV Standard: PAL-M: 640x480
> (II) NVIDIA(0): TV Standard: PAL-M: 720x480
> (II) NVIDIA(0): TV Standard: PAL-M: 800x600
> (II) NVIDIA(0): TV Standard: PAL-M: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 320x200
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 320x240
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 400x300
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 640x400
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 640x480
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 720x576
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 800x600
> (II) NVIDIA(0): TV Standard: PAL-BDGHI: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-N: 320x200
> (II) NVIDIA(0): TV Standard: PAL-N: 320x240
> (II) NVIDIA(0): TV Standard: PAL-N: 400x300
> (II) NVIDIA(0): TV Standard: PAL-N: 640x400
> (II) NVIDIA(0): TV Standard: PAL-N: 640x480
> (II) NVIDIA(0): TV Standard: PAL-N: 720x576
> (II) NVIDIA(0): TV Standard: PAL-N: 800x600
> (II) NVIDIA(0): TV Standard: PAL-N: 1024x768
> (II) NVIDIA(0): TV Standard: PAL-NC: 320x200
> (II) NVIDIA(0): TV Standard: PAL-NC: 320x240
> (II) NVIDIA(0): TV Standard: PAL-NC: 400x300
> (II) NVIDIA(0): TV Standard: PAL-NC: 640x400
> (II) NVIDIA(0): TV Standard: PAL-NC: 640x480
> (II) NVIDIA(0): TV Standard: PAL-NC: 720x576
> (II) NVIDIA(0): TV Standard: PAL-NC: 800x600
> (II) NVIDIA(0): TV Standard: PAL-NC: 1024x768
> (II) NVIDIA(0): Mapping display device 0 (TV-0) to CRTC 0
388a450
> (II) NVIDIA(0): TVs do not provide EDIDs; skipping EDID probe on TV-0
402a465,475
> (II) NVIDIA(0): Saved console TV mode: 3
> (II) NVIDIA(0): Processing requested modes for display device TV-0:
> (II) NVIDIA(0): "1400x1050"
> (II) NVIDIA(0): "1280x960"
> (II) NVIDIA(0): "1280x800"
> (II) NVIDIA(0): "1280x1024"
> (II) NVIDIA(0): "1152x864"
> (II) NVIDIA(0): "1152x768"
> (II) NVIDIA(0): "1024x768"
> (II) NVIDIA(0): "800x600"
> (II) NVIDIA(0): "640x480"
620a694,697
> (II) NVIDIA(0): kernel module enabled successfully
> (II) NVIDIA(0): Memory mapped
> (II) NVIDIA(0): Interrupts enabled
> (II) NVIDIA(0): No MetaMode found for mode "1024x768"
621a699
> (II) NVIDIA(0): First mode initialized
623a702,705
> (II) NVIDIA(0): Visuals set up
> (II) NVIDIA(0): Pixmap depths set up
> (II) NVIDIA(0): GLX visuals set up
> (II) NVIDIA(0): Framebuffer set up
626a709,710
> (II) NVIDIA(0): Default colormap initialized.
> (II) NVIDIA(0): Palette loaded
629a714
> (II) NVIDIA(0): Screen initialization complete
673a759
> (**) Option "Device" "/dev/input/mice"
675a762
> (II) NVIDIA(0): Restored console TV mode: 3

All of this being said, the screen comes up, but it is completly shaded blue. I plugged in the SVIDEO connector and the SVIDEO signal is fine even with a HD1080i specified as the output format. That occurs if I leave out the TVOutFormat.

I will attach three different logs as soon as I figure out how to get GDM to log verbosely.
JoshPrismon is offline   Reply With Quote
Old 12-11-05, 06:47 AM   #12
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: 8174 doesn't like 1080i

Quote:
Originally Posted by kraney
With the 8174 driver in place, 1080i and 720p are not recognized as standard TV resolutions. My xorg.conf works fine at 1080i with driver 7676, drops to 640x480 with 8175. This is with a GeForce 6200 connected via composite out.
A little bit OT, but can your TV native or by the scaler and the 6200 really HDTV 1920x1080 interlaced? In the 6200 specs is some about 1900x1200 (DVI) written.
I have experienced a better HDTV image on my LCD-TV in 1280x720 (720p) (native 1366x768) in progessive mode via an DVI-HDMI-cable to my HD-850 DVD-Player or my notebooks 6800 Go via DVI connected. The picture is awesome.

Marcus
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why You Should Watch and Record Video in 720p Instead of 1080i [Video] News Archived News Items 0 05-10-12 07:00 AM

All times are GMT -5. The time now is 11:16 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.