Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-07-05, 02:57 AM   #1
sdiverdi
Registered User
 
Join Date: Jun 2005
Posts: 12
Default dell precision m50 + quadro4 550 gogl + nvidia drivers = funky display!

i'm having some trouble with the nvidia drivers on my laptop that i can't seem to figure out. i've successfully used the drivers on many machines before, but to no avail this time. the laptop is a dell precision m50 with a new, updated fedora core 3. it has a Quadro4 550 GoGL card in it and a 1600x1200 dfp display.

previously, i was able to use this machine with hardware acceleration, with redhat 7.3 (XFree86 4.3 i think) and a 4xxx series driver, but i needed to upgrade for better firewire / usb support.

now, with fedora core 3, the nv driver works fine. i specify

HorizSync 29 - 80
VertRefresh 0 - 70

and from Xorg.log see that the dot clock's range is 12 - 350. it selects a modeline for 1600x1200 with a dot clock of 162MHz, a horizsync of 75KHz and a vertrefresh of 60Hz. this works perfectly.

when i switch to the nvidia driver making only the minimal changes to the xorg.conf file ('nv' -> 'nvidia' and disabling dri), the display is funky, with a 1024x768 desktop contained in a 1024x768 subrectangle of the display - outside this rectangle are randomly colored vertical lines. looking at Xorg.log, the 1600x1200 line was invalid, because the EDID values set the horizsync to 29 - 65 and the vertrefresh to 0 - 60, and the 1600x1200's horizsync is out of range.

i thought setting IgnoreEDID would fix the problem, since the old modeline works on this display. and in fact, the driver does successfully select the same 1600x1200 modeline, but the display is again funky - this time, the entire 1600x1200 desktop is squashed vertically in half and presented twice, once on the top half of the screen and again on the bottom. really, it looks like an interlaced signal is being displayed on the screen, but interlacing is not set in the modeline, and i didn't think DFP's needed / supported interlaced signals.

i've tried these same settings with driver versions 7174, 7664, 7667, 7676 and 8174, all with the same results. i don't think this is the same as the error in http://www.nvnews.net/vbulletin/showthread.php?t=61077 since mine doesn't work with 7676.

attached is an nvidia bug report (i had to gzip it because it was just over 100kb, but rename it to .log so the forum would accept it) from a test with the nvidia driver 8174 and IgnoreEDID set, showing it select the 1600x1200 modeline, but the display is definitely not correct with these settings.

any ideas? any help is appreciated.
Attached Files
File Type: log nvidia-bug-report.log (23.8 KB, 192 views)
sdiverdi is offline   Reply With Quote
Old 12-07-05, 06:27 AM   #2
fettouhi
Registered User
 
Join Date: Dec 2005
Posts: 15
Default Re: dell precision m50 + quadro4 550 gogl + nvidia drivers = funky display!

I'm having the sae problem with my DELL laptop and I had it on all version you mentioned above of the nvidia driver but I solved it by adding the option

options NVreg_Mobile=0

modules.conf or modprobe.conf but in latest version that doesn't work .
fettouhi is offline   Reply With Quote
Old 12-07-05, 08:39 PM   #3
sdiverdi
Registered User
 
Join Date: Jun 2005
Posts: 12
Default Re: dell precision m50 + quadro4 550 gogl + nvidia drivers = funky display!

hey, fantastic, that does work! i thought i'd tried that before, but i guess i didn't do it right. just for the record, i added the line

options nvidia NVreg_Mobile=0

to the end of /etc/modprobe.conf and then did an 'rmmod nvidia && modprobe nvidia' and was able to start up just fine! btw, this also works for me with driver 8174, but i had to set IgnoreEDID - have you tried that?

thanks a lot!
sdiverdi is offline   Reply With Quote
Old 12-08-05, 12:42 AM   #4
fettouhi
Registered User
 
Join Date: Dec 2005
Posts: 15
Default Re: dell precision m50 + quadro4 550 gogl + nvidia drivers = funky display!

Quote:
Originally Posted by sdiverdi
hey, fantastic, that does work! i thought i'd tried that before, but i guess i didn't do it right. just for the record, i added the line

options nvidia NVreg_Mobile=0

to the end of /etc/modprobe.conf and then did an 'rmmod nvidia && modprobe nvidia' and was able to start up just fine! btw, this also works for me with driver 8174, but i had to set IgnoreEDID - have you tried that?

thanks a lot!
It does work? Where do you set this IgnoreEDID, i.e. do you put it?

Regards

André
fettouhi is offline   Reply With Quote
Old 12-08-05, 12:44 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: dell precision m50 + quadro4 550 gogl + nvidia drivers = funky display!

IgnoreEdid is an X configuration (XF86Config/xorg.conf) option. Please see the NVIDIA driver README for more details on its usage.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-09-05, 02:04 AM   #6
fettouhi
Registered User
 
Join Date: Dec 2005
Posts: 15
Default Re: dell precision m50 + quadro4 550 gogl + nvidia drivers = funky display!

Quote:
Originally Posted by netllama
IgnoreEdid is an X configuration (XF86Config/xorg.conf) option. Please see the NVIDIA driver README for more details on its usage.

Thanks,
Lonni
Added it to my xorg.conf, now everything works !

Regards

André
fettouhi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Precision 690 with a nVidia Quadro 3450 Cr0t NVIDIA Linux 9 08-16-12 02:53 PM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
Corrupted display - 295.53 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 9 06-12-12 03:34 PM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVidia Display Drivers screw up KDE Webgraph NVIDIA Linux 11 10-08-02 08:57 PM

All times are GMT -5. The time now is 05:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.