Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-07-05, 10:22 AM   #1
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default 1.0.8174 DPI computation incorrect

Geforce 6200 AGP 256MB ram
Linux 2.6.14
Enlightenment WM
1600x1200 resolution

Using 1.0.7676 DPI was compiuted at 112x112 which was fine and expected based on EDID:

xdpyinfo:
dimensions: 1600x1200 pixels (363x272 millimeters)
resolution: 112x112 dots per inch

Using 1.0.8174, and no changes to xorg.conf:

xdpyinfo:
dimensions: 1600x1200 pixels (452x318 millimeters)
resolution: 90x96 dots per inch

which resulted in poor font resolution and screen usability.

Only by adding Option "UseEdidDpi" "False" to xorg.conf would the proper screen dimensions be picked up and proper DPI computed.

According to my monitor's specs: Viewsonic P95F+ 19"
353 mm (H) x 265 mm (V) (typical)
360 mm (H) x 270 mm (V) (depends on signal timing)

The results in 1.0.7676 are very close. If I use the UseEdidDpi=false option, I get good results.

The rest of the options from xorg.conf in case you need it.
Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GeForce 6200"
Screen 0
EndSection

Section "Screen"
Identifier "Viewsonic"
Device "Card0"
Monitor "Viewsonic"
DefaultDepth 24
Option "DPMS"
Option "NvAGP" "1"
Option "NoLogo" "1"
Option "UseEDIDDpi" "FALSE"
...

Hope this information is helpful.
pete4nv is offline   Reply With Quote
Old 12-07-05, 10:47 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: 1.0.8174 DPI computation incorrect

Please start X with -logverbose 6 and generate/attach an nvidia-bug-report.log file.
zander is offline   Reply With Quote
Old 12-07-05, 11:33 AM   #3
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: 1.0.8174 DPI computation incorrect

OK. They are attached. One more thing I should mention is Monitor section:

Section "Monitor"
Identifier "Viewsonic"
VendorName "Viewsonic"
ModelName "P95F+"
DisplaySize 360 270
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Note, I force the size to this value and use this in combination with UseEdidDpi false

As you see, the driver comes very close, which is acceptable.

Using ediddpi, the following is incorrect in the file:
(II) NVIDIA(0): Computing DPI from CRT-0's EDID
(II) NVIDIA(0): width : 1280 pixels 360 mm (DPI: 90)
(II) NVIDIA(0): height : 1024 pixels 270 mm (DPI: 96)
(--) NVIDIA(0): DPI set to (90, 96); computed from "UseEdidDpi" X config option

Note, even though I use 1600x1200, this section shows it based on 1280x1024! When using the Dimensions and no ediddpi, this section shows proper information.

(II) NVIDIA(0): Virtual screen size determined to be 1600 x 1200
(**) NVIDIA(0): DPI set to (112, 112); computed from "DisplaySize" Monitor section option

HTH
Attached Files
File Type: txt logediddpi.txt (28.8 KB, 181 views)
File Type: txt lognoediddpi.txt (28.7 KB, 153 views)
pete4nv is offline   Reply With Quote
Old 12-07-05, 12:38 PM   #4
sasha
Registered User
 
Join Date: Apr 2004
Posts: 13
Default Re: 1.0.8174 DPI computation incorrect

Option "UseEdidDpi" "False"

That helped here
sasha is offline   Reply With Quote
Old 12-07-05, 02:05 PM   #5
JTY
Registered User
 
Join Date: Sep 2005
Posts: 12
Default Re: 1.0.8174 DPI computation incorrect

I'm seeing the same issue.

Code:
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): DPI set to (108, 113); computed from "UseEdidDpi" X config option
However, when I set Option "UseEdidDpi" "False" it goes to 96x96, which is what it was with 7676.
JTY is offline   Reply With Quote
Old 12-07-05, 03:33 PM   #6
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: 1.0.8174 DPI computation incorrect

I know about the UseEdidDpi. That's why I wrote the bug report. It was not necessary before. Now, as the output I provided shows, Unless it is FALSE, it will incorrectly determine the screen resolution. And, if you DO use UseEdidDpi, it's necessary to explicitly set the screen dimensions in the Monitor section.

I just reported this because my 1.0.7676 settings caused the failure I described. Surely not a showstopper.
pete4nv is offline   Reply With Quote
Old 12-07-05, 03:44 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0.8174 DPI computation incorrect

The handling of DPI detecting was changed from 1.0-7676 to 1.0-8174 such that "UseEdidDpi" is on by default. This was actually to fix a bug where the DPI calculation was incorrect in the majority of cases.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-07-05, 03:52 PM   #8
cozmic
Registered User
 
Join Date: Jul 2003
Location: Germany
Posts: 3
Default Re: 1.0.8174 DPI computation incorrect

Looks like the EDID size calculation needs some rework.

Code:
(II) NVIDIA(0): Virtual screen size determined to be 1600 x 1200
(WW) NVIDIA(0): No size information available in CRT-0's EDID; cannot compute
(WW) NVIDIA(0):      DPI from EDID.
Well it could be computed before without problems. EDID information claims to be version 1.03, size is specified as 41x30cm, resulting in about 100 dpi at 1600x1200.

The EDID information is attached. (EDID can be read out with the nvidia-settings tool)
Attached Files
File Type: zip edid.bin.zip (256 Bytes, 160 views)
cozmic is offline   Reply With Quote

Old 12-07-05, 03:57 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0.8174 DPI computation incorrect

You attached the binary EDID. Please provide the non-binary EDID, either via the tool you used to obtain the binary EDID, or by starting X with this command:
startx -- -logverbose 5
and attaching your X log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-07-05, 04:45 PM   #10
Lethe
Registered User
 
Join Date: Nov 2005
Posts: 178
Default Re: 1.0.8174 DPI computation incorrect

Bloody hell - I was just going to post about this - 1.0-8174 buggered up my fonts.

After reading up, I found a solution, but first, from xorg.log:

Code:
(WW) NVIDIA(0): No size information available in CRT-0's EDID; cannot compute
(WW) NVIDIA(0):      DPI from EDID.
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
The quick fix is to start X with, like,:

> startx -- -dpi 90

Although I don't know how to calculate the correct dpi for my system?

Nick
Lethe is offline   Reply With Quote
Old 12-07-05, 05:07 PM   #11
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: 1.0.8174 DPI computation incorrect

Try using DISPLAYSIZE in the Monitor section. You need your monitor specs for the maximum display image size in milimeters. Then, if you turn off UseEdidDpi, X should compute the proper DPI for you. Then you can avoid using --dpi. To confirm, just type xdpyinfo | grep dimensions -A 2

dimensions: 1600x1200 pixels (363x272 millimeters)
resolution: 112x112 dots per inch

You'll get a display like this. which will show you. It's quirky that the display is measured in metric and DPI is in inches.
pete4nv is offline   Reply With Quote
Old 12-07-05, 05:39 PM   #12
Lethe
Registered User
 
Join Date: Nov 2005
Posts: 178
Default Re: 1.0.8174 DPI computation incorrect

Well, DPI == dots per inch, so it's expected to be imperial ;-)

Thanks for your help.... it looks like the new driver 1.0-8174 actually gets it right on my system 75dpi. I had to reset all fonts a little bigger in KDE, but when I visit this site:

http://boards.footymad.net/mboard/fmb.php?tno=424

The fonts in the message board are real crap. I messed at first with KDE fonts settings, but nothing worked. Setting `startx -- -dpi 85' fixes it, but then desktop fonts seem a bit blurry. 75DPI is good, though - clear as a bell. It must be that web site - but I am not convinced yet.

Again, thanks for help.

Nick
Lethe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Refresh Rates, DPI, and Other Display Tweaking Phyre NVIDIA Linux 3 08-02-02 04:32 AM

All times are GMT -5. The time now is 08:39 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.