Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-07-05, 05:16 PM   #1
philcostin
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 52
Default Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

When playing any Valve Source games using cedega, if the NVidia drivers version is greater than 1.0-6xxx then the following texture problem occurs:



If you look at the railings around the walkways, they are supposed to have textured walls. These walls and many other semi-transparent textures sometimes become fully invisible (depending on the angle you view them).

On the transgaming forum (transgaming.org/forum) there is a thread about this issue. Transgaming think it could be a problem or an incompatibility with the way the newer nVidia drivers work. (7xxx, 8xxx)

Thread with more screenshots: http://transgaming.org/forum/viewtopic.php?t=4452


Thanks in advance for help resolving this, even if it involves communication with Transgaming to work out a resolution.

Cheers!

Phil.
philcostin is offline   Reply With Quote
Old 12-07-05, 05:25 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

Please generate and post a bug report from a system where this problem is present with 1.0-8174.

Also, to confirm you are seeing this in Half Life 2? Is it present throughout the game, or only under specific circumstances?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-08-05, 03:44 AM   #3
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

I also have this problem, had it for a while now. Its annoying that the whole railing and catwalk fences just vanish. Those annoying things with the long tongues in HL2 cling on to a floor grating in one scene, and its suppose to be a transparent textured floor their hanging on, instead all you see is them hanging on nothing. :P
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 12-08-05, 06:08 AM   #4
philcostin
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 52
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

Quote:
Originally Posted by netllama
Please generate and post a bug report from a system where this problem is present with 1.0-8174.

Also, to confirm you are seeing this in Half Life 2? Is it present throughout the game, or only under specific circumstances?

Thanks,
Lonni
Lonni,

The missing textures usually only occur when viewing a texture that has areas of full alpha (such as a metal grid floor, a railing, a window etc). If your line of vision is perpendicular to the texture, or above about 80 degrees from the normal, you can see the texture. If however, you are looking at the texture from an angle outside this range (such as 45 degrees), the texture is missing.

As I said, I can't reproduce the problem with 1.0-6xxx. Here is a bug report for 8174 (X version 6.8.2) 7676 does the same thing.



Thanks!

Phil.
Attached Files
File Type: zip nvidia-bug-report.log.zip (20.2 KB, 171 views)

Last edited by philcostin; 12-08-05 at 07:11 AM. Reason: Post new bug report, this time with the correct xorg.conf content
philcostin is offline   Reply With Quote
Old 12-08-05, 07:03 AM   #5
philcostin
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 52
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

EDIT: re-made bug report before it was downloaded with correct xorg.conf file content rather than XF86Config file content
philcostin is offline   Reply With Quote
Old 12-09-05, 01:10 PM   #6
philcostin
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 52
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

sorry in advance for this: "BUMP" but the bug report might go unnoticed.

cheers!
phil.
philcostin is offline   Reply With Quote
Old 12-09-05, 02:20 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

I'm working on reproducing this, however at the moment, I'm having problems getting steam installed with cedega, and am talking to Transgaming about it.

Thanks for your patience,
Lonni
netllama is offline   Reply With Quote
Old 12-09-05, 02:26 PM   #8
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

Yes, getting steam installed and running can be a biatch at times. Steaming pile! :P
I have to add that I thought this was transgaming's bug so I never ever bothered asking NVIDIA about it.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote

Old 12-09-05, 03:16 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

Perhaps someone here can help me to help you. When I try to install steam with Cedega, it consistantly fails with the following error:
Could not execute the external program C:\Program Files\Steam\steam.exe

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-09-05, 04:15 PM   #10
Spyke
Foxie
 
Spyke's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 618
Send a message via AIM to Spyke Send a message via MSN to Spyke Send a message via Yahoo to Spyke
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

After you get that error message, go into c_drive/Program\ Files/Valve and then run cedega Steam.exe

The installer is done installing steam at that point and was trying to run it for the first time.
Meaning you just have to run it yourself.

Hope this helps.
__________________
Gaming:
Intel i7 980X @ 4GHz | ASUS Rampage III Extreme | GTX 480 3Way SLI @ 900Mhz | Koolance VID-NX480 | Corsair Obsidian 700D
Corsair H70 CPU Cooler | EK-FB RE3 | Corsair AX1200 | Black Ice SR1 360 | 240GB OCZ Revodrive X2 SSD | Windows 7 Ultimate
12GB Corsair Dominator GT @ 8-8-8-24-1T DDR3-1600 | Onkyo TX SR-707 | 70" Sharp Aquos LCD | KEF Audio 5.1 C3/C6LCR/C7
Workstation:
Intel i7 920 D0 @ 4GHz | ASUS Rampage II Extreme | GTX 480 @ 800Mhz | Koolance VID-NX480 | Lian-Li V1200B | Corsair HX1000
EK NB ASUS HP | Watercool HeatKiller 3.0 | Feser Extreme X-360 | 2x160GB Intel X25-M SSD RAID0 | 4x2TB WD20EARS RAID10
12GB Corsair Dominator @ 8-8-8-24-1T DDR3-1600 | Creative X-Fi Titanium | Pioneer DVR-212D | Gentoo Linux
Dell 3008WFP | JohnBlue JB3 | CityPulse DA2.03e II DAC | KingRex T20U w/ Modded Auricaps & PSU | Glow Audio Sub One
Server:
Quad Socket Opteron 8356 (16 cores) @ 2.3GHz | Supermicro H8QMi-2 | Supermicro 2U Chassis | Redundant 1200W PSU
32GB 2GBx16 DDR2-667 ECC | 4x 300GB Cheetah SAS RAID10 | Adaptec 5805 512MB w/BBU | Colocated | Gentoo Linux
Spyke is offline   Reply With Quote
Old 12-10-05, 03:17 PM   #11
philcostin
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 52
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

If you are using cedega 5, run "cedega", click "File -> Install" and enter the path name of the steam installer executable..
philcostin is offline   Reply With Quote
Old 12-10-05, 03:47 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Missing Texture problem - 7xxx and 8xxx series drivers, Cedega

Thanks, that worked. I'll continue to work on reproducing the HL2 problem now.

-Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.