Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-05, 01:18 AM   #1
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default 8174 hangs my laptop on starting X

Hangs during X startup. Screen goes black, but nothing comes up. Can ping, but ssh session / console do not respond.

log attached is from before starting X (obviously) on a fresh boot, but after modprobing nvidia.

The stderr on the ssh console with high verbosity get just a little further, there are these 2 additional lines at the end:


(--) NVIDIA(0): Linear framebuffer at 0xDC000000
(--) NVIDIA(0): MMIO registers at 0xFD000000

that is always the last thing I get.

7676 worked fine on this same machine.
Attached Files
File Type: log nvidia-bug-report.log (96.7 KB, 125 views)
Imperito is offline   Reply With Quote
Old 12-08-05, 02:29 AM   #2
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: 8174 hangs my laptop on starting X

and works again on reverting to 7676. Had to trick the userspace parts to get it to work
Imperito is offline   Reply With Quote
Old 12-08-05, 03:21 AM   #3
joffe
Registered User
 
joffe's Avatar
 
Join Date: Nov 2004
Posts: 171
Default Re: 8174 hangs my laptop on starting X

It's good to have this issue brought up. I and many more GeForce4 420 Go users are having the same problem with the new drivers. Keep on posting those bug reports!
__________________
GA-MA790GP-DS4H, ATI Radeon HD3300, AMD Phenom X4 9850, 4GB PC8500 [Ubuntu 8.10]
Toshiba 2450-201, GeForce4 420 Go 32MB, Pentium4 2.4GHz, 512 MB PC2700 [Ubuntu 8.10]
joffe is offline   Reply With Quote
Old 12-08-05, 04:03 AM   #4
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: 8174 hangs my laptop on starting X

Oh, you get the same thing? It wouldn't be the first time nVidia has broken on my card, I only just recently got my 1600x1200 back, I'd been running at 1588x1200 for a while.
Imperito is offline   Reply With Quote
Old 12-08-05, 04:05 AM   #5
joffe
Registered User
 
joffe's Avatar
 
Join Date: Nov 2004
Posts: 171
Default Re: 8174 hangs my laptop on starting X

1600x1200? On what card/output? the GeForce4 420?
__________________
GA-MA790GP-DS4H, ATI Radeon HD3300, AMD Phenom X4 9850, 4GB PC8500 [Ubuntu 8.10]
Toshiba 2450-201, GeForce4 420 Go 32MB, Pentium4 2.4GHz, 512 MB PC2700 [Ubuntu 8.10]
joffe is offline   Reply With Quote
Old 12-08-05, 04:06 AM   #6
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: 8174 hangs my laptop on starting X

Quote:
Originally Posted by Imperito
Hangs during X startup. Screen goes black, but nothing comes up. Can ping, but ssh session / console do not respond.
Hello,

you should really read and correct the warnings in your logs mentioned.
From an false speedstep driver, ACPI video driver (for integrated in the ICH eg)?... and in your xorg.log more...

AGP is disabled?

Code:
speedstep-smi: you're trying to use this cpufreq driver on
 a Pentium 4-based CPU. Most likely it will not work.
You need the speedstep-ich driver for your P4-M!

Code:
ACPI: Fan [FAN] (off)
ACPI: Video Device [VGA] (multi-head: yes  rom: yes  post: no)
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Thermal Zone [THRM] (82 C)
Really not to hot with the fan off and an hot P4-M?

This is a little hand oven for the night fight, right? ;-)

Marcus
pzgren is offline   Reply With Quote
Old 12-08-05, 04:31 AM   #7
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: 8174 hangs my laptop on starting X

Its a toshiba, so the ACPI reading for the fan is wrong, they do it "differently":

Code:
[imperito@mobile:~]$ cat /proc/acpi/toshiba/fan
running:                 1
force_on:                0
And iirc I just grabbed all the cpufreq drivers there were, at least one of them took, because it works for me:

Code:
[imperito@mobile:~]$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
speedstep-ich
AGP works, here I'm booted with 7676 but:

Code:
[imperito@mobile:~]$ cat /proc/driver/nvidia/agp/status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        4x
Fast Writes:     Disabled
SBA:             Disabled
Anyway, none of that (except the AGP, which I don't know where you get was disabled, but keep in mind those bug reports were generated outside of X, since X == hang) has to do with the problem at hand...
Imperito is offline   Reply With Quote
Old 12-08-05, 04:33 AM   #8
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: 8174 hangs my laptop on starting X

And yeah, 1600x1200 on the laptop's LCD display (native resolution). Its a toshiba satellite pro 6100.
Imperito is offline   Reply With Quote

Old 12-09-05, 10:30 PM   #9
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: 8174 hangs my laptop on starting X

Update... a mixed bag...

set NVreg_mobile in the module loading options and it doesn't hang.

It gives me greatly reduced resolution, and my second screen doesn't work at all.

Code:
(EE) NVIDIA(1): The requested configuration of display devices is not
(EE) NVIDIA(1):      supported in the hardware.
???

It was supported last version...
Imperito is offline   Reply With Quote
Old 12-11-05, 07:05 AM   #10
120
Registered User
 
Join Date: Dec 2005
Posts: 14
Default Re: 8174 hangs my laptop on starting X

same problem here, and I also have a toshiba laptop (satellite 5100-503) which can reach 1600x1200. Had also the 1588x1200 issue before.
I provide my nvidia-bug-report just in case.
Attached Files
File Type: log nvidia-bug-report.log (60.9 KB, 119 views)
120 is offline   Reply With Quote
Old 12-11-05, 10:43 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 8174 hangs my laptop on starting X

120:
The only problem that I see in your bug report is that the nvidia driver is not correctly installed. You have the 1.0-8174 kernel module loaded, yet you're using the 1.0-7676 X driver:

II) LoadModule: "glx"
(II) Loading /usr/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.7676
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX

NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-8174 Tue Nov 22 17:48:37 PST 2005
NVRM: RM/client version mismatch!!
NVRM: aborting to avoid catastrophe!

Once you get 1.0-8174 correctly installed, if you continue to experience problems, please see:
http://www.nvnews.net/vbulletin/show...1&postcount=98

Also does this problem reproduce if you're not using ndiswrapper?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-11-05, 11:27 AM   #12
wschutzer
Registered User
 
wschutzer's Avatar
 
Join Date: Dec 2005
Location: Sao Carlos, Brazil
Posts: 55
Default Re: 8174 hangs my laptop on starting X

Quote:
Originally Posted by Imperito
Hangs during X startup. Screen goes black, but nothing comes up. Can ping, but ssh session / console do not respond.
I have the same problem here with my Toshiba Satellite 1415-S173 laptop with NV17 [GeForce4 420 Go], driver 1.0-8174. Black screen, backlight on, can ping, can't ssh, can't reboot through keyboard. The 1.0-7676 works fine, except for corrupted consoles on suspend to ram and a black screen with dpms.

Waldeck
Attached Files
File Type: log nvidia-bug-report.log (91.7 KB, 109 views)
wschutzer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 16, GTX 550Ti, random X hangs, "Attempted to yield the CPU..." MquwIBUO NVIDIA Linux 7 06-12-12 03:39 PM
302.11 driver only allows native resolution settings of laptop DFP darinmiller NVIDIA Linux 2 05-30-12 03:45 PM
Graphic errors and hangs after standby reini122 NVIDIA Linux 4 05-07-12 03:37 AM

All times are GMT -5. The time now is 06:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.