Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-08-05, 12:57 PM   #1
Nexyon
Registered User
 
Join Date: Dec 2005
Posts: 3
Unhappy After reboot X server does not start

Hi,

I've installed the new nVidia driver and it workes well with 3D acceleration, but after every reboot the X server does not start, I need to reinstall the driver with the console and after that the X server starts and everything works perfect again.

The nVidia devices exist...

Quote:
/var/log/Xorg.0.log

X Window System Version 6.8.2 (Ubuntu 6.8.2-77 20051010174523 root@vernadsky.buildd)
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.10 i686 [ELF]
Current Operating System: Linux nexyon 2.6.12-10-386 #1 Fri Nov 18 11:51:02 UTC 2005 i686
Build Date: 10 October 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.12-10-386 (buildd@terranova) (gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8)) #1 Fri Nov 18 11:51:02 UTC 2005 T
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 8 18:22:52 2005
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Standardbildschirm"
(**) | |-->Device "NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/X11/fonts/CID" does not exist.
Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID".
Entry deleted from font path.
(Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID").
(**) FontPath set to "/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.7
X.Org XInput driver : 0.4
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.7
(--) using VT number 7

REMOVED SOME UNNECESARY OUTPUT (I BELIEVE SO)


(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.1.0
ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8174
Module class: XFree86 Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.o
(II) Module kbd: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) NVIDIA X Driver 1.0-8174 Tue Nov 22 17:51:03 PST 2005
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xf0400000 - 0xf040ffff (0x10000) MX[b]
[6] -1 0 0xf0500600 - 0xf05006ff (0x100) MX[b]
[7] -1 0 0xf0500400 - 0xf05005ff (0x200) MX[b]
[8] -1 0 0x40000000 - 0x400003ff (0x400) MX[b]
[9] -1 0 0xf0500000 - 0xf05003ff (0x400) MX[b]
[10] -1 0 0xd8000000 - 0xd7ffffff (0x0) MX[b]O
[11] -1 0 0xf2000000 - 0xf2ffffff (0x1000000) MX[b](B)
[12] -1 0 0xe0000000 - 0xefffffff (0x10000000) MX[b](B)
[13] -1 0 0xf1000000 - 0xf1ffffff (0x1000000) MX[b](B)
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0 0x00001400 - 0x0000143f (0x40) IX[b]
[17] -1 0 0x00001000 - 0x000010ff (0x100) IX[b]
[18] -1 0 0x0000fc00 - 0x0000fc1f (0x20) IX[b]
[19] -1 0 0x000014d0 - 0x000014df (0x10) IX[b]
[20] -1 0 0x0000180c - 0x0000180f (0x4) IX[b]
[21] -1 0 0x000014f8 - 0x000014ff (0x8) IX[b]
[22] -1 0 0x00001808 - 0x0000180b (0x4) IX[b]
[23] -1 0 0x000014f0 - 0x000014f7 (0x8) IX[b]
[24] -1 0 0x000014c0 - 0x000014cf (0x10) IX[b]
[25] -1 0 0x00001804 - 0x00001804 (0x1) IX[b]
[26] -1 0 0x000014e8 - 0x000014e8 (0x1) IX[b]
[27] -1 0 0x00001800 - 0x00001800 (0x1) IX[b]
[28] -1 0 0x000014e0 - 0x000014e0 (0x1) IX[b]
[29] -1 0 0x00001480 - 0x0000149f (0x20) IX[b]
[30] -1 0 0x00001460 - 0x0000147f (0x20) IX[b]
[31] -1 0 0x00001440 - 0x0000145f (0x20) IX[b]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xf0400000 - 0xf040ffff (0x10000) MX[b]
[6] -1 0 0xf0500600 - 0xf05006ff (0x100) MX[b]
[7] -1 0 0xf0500400 - 0xf05005ff (0x200) MX[b]
[8] -1 0 0x40000000 - 0x400003ff (0x400) MX[b]
[9] -1 0 0xf0500000 - 0xf05003ff (0x400) MX[b]
[10] -1 0 0xd8000000 - 0xd7ffffff (0x0) MX[b]O
[11] -1 0 0xf2000000 - 0xf2ffffff (0x1000000) MX[b](B)
[12] -1 0 0xe0000000 - 0xefffffff (0x10000000) MX[b](B)
[13] -1 0 0xf1000000 - 0xf1ffffff (0x1000000) MX[b](B)
[14] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[15] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[16] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[17] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[18] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[19] -1 0 0x00001400 - 0x0000143f (0x40) IX[b]
[20] -1 0 0x00001000 - 0x000010ff (0x100) IX[b]
[21] -1 0 0x0000fc00 - 0x0000fc1f (0x20) IX[b]
[22] -1 0 0x000014d0 - 0x000014df (0x10) IX[b]
[23] -1 0 0x0000180c - 0x0000180f (0x4) IX[b]
[24] -1 0 0x000014f8 - 0x000014ff (0x8) IX[b]
[25] -1 0 0x00001808 - 0x0000180b (0x4) IX[b]
[26] -1 0 0x000014f0 - 0x000014f7 (0x8) IX[b]
[27] -1 0 0x000014c0 - 0x000014cf (0x10) IX[b]
[28] -1 0 0x00001804 - 0x00001804 (0x1) IX[b]
[29] -1 0 0x000014e8 - 0x000014e8 (0x1) IX[b]
[30] -1 0 0x00001800 - 0x00001800 (0x1) IX[b]
[31] -1 0 0x000014e0 - 0x000014e0 (0x1) IX[b]
[32] -1 0 0x00001480 - 0x0000149f (0x20) IX[b]
[33] -1 0 0x00001460 - 0x0000147f (0x20) IX[b]
[34] -1 0 0x00001440 - 0x0000145f (0x20) IX[b]
[35] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[36] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


____________________________________________

/etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Tue Nov 22 18:04:42 PST 2005

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# paths to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "deadkeys"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Standardbildschirm"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]"
Driver "nvidia"
Option "NoLogo" "true"
Option "NvAGP" "1"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 Ultra]"
Monitor "Standardbildschirm"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
(I add the install log as a second post)

Any ideas what the problem is?

Xenon
Nexyon is offline   Reply With Quote
Old 12-08-05, 12:58 PM   #2
Nexyon
Registered User
 
Join Date: Dec 2005
Posts: 3
Default Re: After reboot X server does not start

/var/log/nvidia-installer.log:

Quote:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Dec 8 18:16:12 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : /usr/src/linux-source-2.6.12
kernel output path : (not specified)
kernel install path : /lib/modules/2.6.12-10-386/volatile/
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
8174). As part of installing this driver (version: 1.0-8174), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Performing CC test with CC="/usr/bin/gcc-3.4".
-> Using the kernel source path '/usr/src/linux-source-2.6.12' as specified by
the '--kernel-source-path' commandline option.
-> Kernel source path: '/usr/src/linux-source-2.6.12'
-> Kernel output path: '/usr/src/linux-source-2.6.12'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -f stprof stprof.o symtab.h
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/usr/src/linux-source-2.6.12
SYSOUT=/usr/src/linux-source-2.6.12'...

NVIDIA: calling KBUILD...
make CC=/usr/bin/gcc-3.4 KBUILD_VERBOSE=1 -C /usr/src/linux-source-2.6.12 S
UBDIRS=/tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv modules
mkdir -p /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/.tmp_vers
ions

WARNING: Symbol version dump /usr/src/linux-source-2.6.12/Module.symvers
is missing; modules will have no dependencies and modversions.

make -f scripts/Makefile.build obj=/tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174
-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`/usr/bin/gcc-3.4 -v 2>&1 | tail -n 1`\" > /tmp/
selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nv_compiler.h
/usr/bin/gcc-3.4 -Wp,-MD,/tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/us
r/src/nv/.nv.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/3.4.5/inclu
de -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs -fno-str
ict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer -pipe -
msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=i386 -I
include/asm-i386/mach-default -Wdeclaration-after-statement -I/tmp/selfgz81
14/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type
-Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-mult
ichar -Werror -O -fno-common -MD -Wsign-compare -Wno-cast-qual -Wno-error
-D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNTRM -DNVRM -DDYNAMIC_SLI -D
NV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=8174 -UDEBUG -U_DEB
UG -DNDEBUG -DNV_SIGNAL_STRUCT_RLIM -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DN
V_PCI_GET_CLASS_PRESENT -DNV_SYSCTL_MAX_MAP_COUNT_PRESENT -DNV_REMAP_PFN_RAN
GE_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBU
ILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o /tmp/selfgz8114/NVIDIA-Linux-x
86-1.0-8174-pkg1/usr/src/nv/.tmp_nv.o /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8
174-pkg1/usr/src/nv/nv.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src
/nv/nv-linux.h:47,
from /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src

REMOVED A LOT OF WARNING (ERROR?) MESSAGES

/usr/bin/gcc-3.4 -Wp,-MD,/tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/us
r/src/nv/.nvidia.mod.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/3.4
.5/include -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes -Wno-trigraphs
-fno-strict-aliasing -fno-common -ffreestanding -Os -fomit-frame-pointer
-pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=i
386 -Iinclude/asm-i386/mach-default -Wdeclaration-after-statement -DKBUI
LD_BASENAME=nvidia -DKBUILD_MODNAME=nvidia -DMODULE -c -o /tmp/selfgz8114/NV
IDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nvidia.mod.o /tmp/selfgz8114/NVIDIA-
Linux-x86-1.0-8174-pkg1/usr/src/nv/nvidia.mod.c
ld -m elf_i386 -r -o /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/sr
c/nv/nvidia.ko /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nvi
dia.o /tmp/selfgz8114/NVIDIA-Linux-x86-1.0-8174-pkg1/usr/src/nv/nvidia.mod.o
NVIDIA: left KBUILD.
-> done.
-> Kernel module compilation complete.
-> Kernel messages:
[4294707.442000] IPv6 over IPv4 tunneling driver
[4294709.184000] ACPI: Power Button (FF) [PWRF]
[4294709.184000] ACPI: Power Button (CM) [PBTN]
[4294709.278000] ibm_acpi: ec object not found
[4294714.528000] NVRM: RM/client version mismatch!!
[4294714.528000] NVRM: aborting to avoid catastrophe!
[4294715.737000] apm: BIOS not found.
[4294716.414000] Bluetooth: Core ver 2.7
[4294716.414000] NET: Registered protocol family 31
[4294716.414000] Bluetooth: HCI device and connection manager initialized
[4294716.414000] Bluetooth: HCI socket layer initialized
[4294716.426000] Bluetooth: L2CAP ver 2.7
[4294716.426000] Bluetooth: L2CAP socket layer initialized
[4294716.443000] Bluetooth: RFCOMM ver 1.5
[4294716.443000] Bluetooth: RFCOMM socket layer initialized
[4294716.443000] Bluetooth: RFCOMM TTY layer initialized
[4294717.548000] eth0: no IPv6 routers present
[4294718.743000] NVRM: RM/client version mismatch!!
[4294718.743000] NVRM: aborting to avoid catastrophe!
[4294722.920000] NVRM: RM/client version mismatch!!
[4294722.920000] NVRM: aborting to avoid catastrophe!
[4294763.554000] ACPI: PCI interrupt for device 0000:01:00.0 disabled
[4294779.994000] nvidia: no version for "struct_module" found: kernel
tainted.
[4294780.010000] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 18 (level, low)
-> IRQ 18
[4294780.010000] NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module
1.0-8174 Tue Nov 22 17:48:37 PST 2005
-> Installing both new and classic TLS OpenGL libraries.
-> Parsing log file:
-> done.
-> Validating previous installation:
-> The previously installed file
'/lib/modules/2.6.12-10-386/volatile//nvidia.ko' has a different checksum
(3914510829) than when it was installed (1377564396).
/lib/modules/2.6.12-10-386/volatile//nvidia.ko will not be uninstalled.
-> done.
WARNING: Your driver installation has been altered since it was initially
installed; this may happen, for example, if you have since installed
the NVIDIA driver through a mechanism other than the nvidia-installer
(such as rpm or with the NVIDIA tarballs). The nvidia-installer will
attempt to uninstall as best it can. Please see the file
'/var/log/nvidia-installer.log' for details.
-> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86 (1.0-8174):
-> done.
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for
Linux-x86 (1.0-8174) is complete.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-8174):
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
-> done.
-> Runtime sanity check passed.
-> Would you like to run the nvidia-xconfig utility to automatically update you
r X configuration file so that the NVIDIA X driver will be used when you res
tart X? Any pre-existing X configuration file will be backed up. (Answer: N
o)
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-8174) is now complete. Please update your XF86Config or
xorg.conf file as appropriate; see the file
/usr/share/doc/NVIDIA_GLX-1.0/README.txt for details.
Nexyon is offline   Reply With Quote
Old 12-08-05, 01:06 PM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: After reboot X server does not start

Please generate and attach an nvidia-bug-report.log file; please also make sure you don't have the linux-restricted-modules package installed.
zander is offline   Reply With Quote
Old 12-08-05, 01:22 PM   #4
mo_x
Registered User
 
Join Date: Jul 2005
Posts: 77
Default Re: After reboot X server does not start

Try this:
dpkg --purge nvidia-glx
mo_x is offline   Reply With Quote
Old 12-08-05, 01:26 PM   #5
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: After reboot X server does not start

@mo_x: I don't think this problem is related to /etc/init.d/nvidia-glx, the X server doesn't crash, it aborts because it can't communicate with the NVIDIA kernel module.
zander is offline   Reply With Quote
Old 12-08-05, 03:46 PM   #6
Nexyon
Registered User
 
Join Date: Dec 2005
Posts: 3
Default Re: After reboot X server does not start

Quote:
Originally Posted by zander
Please generate and attach an nvidia-bug-report.log file; please also make sure you don't have the linux-restricted-modules package installed.
Thank you very much! Uninstalling this package and reinstalling the driver after a reboot did it!!

Thank you, thank you, thank you :-D

I'm so glad



Bye
Nexyon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 10:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 01:23 PM
Fujitsu Marries GPUs and Xeon in High-Density HPC Server News Archived News Items 0 06-13-12 07:30 PM
X Server 1.11.3(Ubuntu 12.04) crashes just after start on Geforce 9400(driver 295.40) peat NVIDIA Linux 1 05-10-12 07:00 AM
X won't start properly, RH7.3 and SiS 645 DX potash NVIDIA Linux 23 08-02-02 04:33 PM

All times are GMT -5. The time now is 06:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.