Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-13-05, 03:49 AM   #1
Drache
Registered User
 
Join Date: Nov 2005
Posts: 5
Default How to disable a framebuffer

I have the latest nvidia drivers installed on Slackware 10.2. I have configured and got it working but when I change to a virtual terminal or shutdown out of x the screen goes blank with green rectangle.

Another thread said that this corruption is usual when a framebuffer is in use.

The guy answers "disabled frambuffer and all works fine".

My question is. How and where do I go to disable the frambuffer.

Thanks

Drache
Drache is offline   Reply With Quote
Old 12-13-05, 04:01 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: How to disable a framebuffer

Assuming you're using vesafb, passing video=vesa:off vga=normal to the kernel via the kernel command line (i.e. via GRUB/LILO) should disable it.
zander is offline   Reply With Quote
Old 12-13-05, 05:31 AM   #3
Lethe
Registered User
 
Join Date: Nov 2005
Posts: 178
Default Re: How to disable a framebuffer

I am on Slack and use Framebuffer...

Looking at the screen corruption, I use to get this too when I EXITED X, but console was then all corrupt with greens, blues and reds.

The solution was to add these options to xorg.conf in the 'Section "Device"' part:




# Nick 24/07/2004 - attempt to stop corruption exiting X

Option "ConnectedMonitor" "CRT-0"
Option "IgnoreDisplayDevices" "TV-0"



You will obviously have to specify the Devices according to your set up.

Nick
Lethe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 Video Cards -- Disable Open GL on single? amites NVIDIA Linux 5 05-30-12 03:51 PM
bad cursor after X in framebuffer console wintersky NVIDIA Linux 11 11-07-03 11:59 AM
GF4 - can't get framebuffer working (tried rivafb and vesafb)! roger NVIDIA Linux 2 10-08-02 06:56 PM
Can I use 3-D acceleration in the framebuffer coredumped NVIDIA Linux 3 08-24-02 01:20 PM
Disable Kernel Messages? xniper NVIDIA Linux 2 08-12-02 01:57 PM

All times are GMT -5. The time now is 05:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.