Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-17-05, 12:37 PM   #1
crz
Registered User
 
Join Date: Dec 2005
Posts: 6
Default renderaccel corruption in 8174

Not sure if bugs in RenderAccel (which is clearly marked as experimental) are fair game for bug reports, but here goes.

Attached a screenshot of corruption i'm seeing in an xterm with RenderAccel on. The corruption doesn't happen with RenderAccel off.

Software: 8174 drivers, Xorg 6.8.2, metacity 2.12.1, Keith Packard's hacked xterm to draw with translucent background (found at http://freedesktop.org/~keithp/xterm-trans.tar.gz), running xcompmgr. GLX is disabled. All programs are built 64-bit, from Ubuntu's breezy distro.

Hardware: Athlon64 3700+ (San Diego), Gigabyte GA-K8N51GMF-9 motherboard with onboard GeForce 6100 chip, set to use 64MB for video.

To reproduce the problem: I started up the hacked xterm and typed "asdfasdfasdfasdf" over and over. If I move, resize, or otherwise make the xterm redraw the corrupted parts, they reappear uncorrupted.

The same thing sometimes happens with the stock Xorg xterm too, if I start the xterm and do not move it from its initial position. Once I move the stock xterm, the problem never happens on that window. But on the Keith's xterm it happens all the time.

Again, the problem doesn't appear when RenderAccel is off, but then of course composite + xcompmgr are dog slow. I'm not 100% clear on how Render works, but I'm pretty surprised that the screenshot was able to capture the corruption.

This used to work fine on roughly the same software way back when I was running an AGP Geforce3 Ti on an Athlon 2500+ with the 7676 drivers. I don't have any other hardware to test this with, unfortunately.

Thanks in advance, and I hope this helps the driver writers. This is my one missing piece of eye candy.
Attached Thumbnails
Click image for larger version

Name:	renderaccel-corruption.png
Views:	272
Size:	53.1 KB
ID:	15114  
crz is offline   Reply With Quote
Old 12-17-05, 01:58 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: renderaccel corruption in 8174

There are currently known issues with RenderAccel. We hope to address most, if not all of the known issues in the first driver release of 2006.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Larry Lessig: The corruption of the American political system News Archived News Items 0 06-13-12 11:20 AM
Low-Cost Indian Tablet Project Falls To Corruption News Archived News Items 0 05-06-12 12:00 PM
Graphics corruption in GTA3 with 30.82 drivers Dazz NVIDIA Windows Graphics Drivers 8 08-13-02 04:14 PM

All times are GMT -5. The time now is 07:39 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.