Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-24-03, 10:03 AM   #13
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default

Demian -- this is *very* interesting and helpful.

I have tried a couple of your suggestions and have found the following:

1. Running another small video first (I just use a small avi) does work as long as I start the video I want while the other dummy one is still running.

The clear screen persists even after the original video finishes and even if I continue to shuttle back and forth between normal and full-screen.

1. Setting: Option "NvAgp" "0" (or "1")
doesn't seem to make a difference for me.

I added the above line to my XF86Config, restarted the X-server (with ctl-alt-backspace) and tried again. I looked in the XF86 log and confirmed that AGP was indeed disabled.

3. I am not sure which specific kernel modules you are referring to by AgpArt.

My kernel configuration (adapted from the RH8.0 one and recompiled for 2.4.20) contains the following AGP references:
CONFIG_AGP=m
CONFIG_AGP_INTEL=y
CONFIG_AGP_I810=y
CONFIG_AGP_VIA=y
CONFIG_AGP_AMD=y
# CONFIG_AGP_AMD_8151 is not set
CONFIG_AGP_SIS=y
CONFIG_AGP_ALI=y
CONFIG_AGP_SWORKS=y

AGP support does seem to be compiled as a module though.
Do you mean something different by AgpArt??
---

Great work though!!!!
To me it is still not clear whether the problem is in XF86, the AgpArt kernel driver, or the nVidea driver
Hopefully we can continue to narrow down the problem and get it fixed the right way!
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 01-24-03, 10:20 AM   #14
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default

OK this is really weird.
I tried changing cycling through the X11 screen resolution as I ran a movie at full screen.

(Note the picture size itself remains 1280x1024, just the screen resolution changes meaning that more of the image goes off screen)

Here are the results:
1280x1024: jaggies
1280x960: no jaggies
1152x864: no jaggies
1024x768: jaggies
800x600: jaggies
640x480: jaggies

I am using the following stanza in my XF86 config:

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x48\
0"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x48\
0"
EndSubSection
EndSection


----
It might be interesting to check what happens if you *start* at a resolution other than 1280x1024 or if you change the pixel depth.

I also should repeat my other observation, that when I manually resize the frame it stays ok until I get to about 2/3 of the full 1280x1024 screen size when the jaggies suddenly appear. Seems like a very binary type of thing.

This is all so weird!!!

I am also curious that you and I both have the problem despite having very different machines, graphic cards, and linux distros, while at the same time *nobody* else either on these boards or via googling has reported the problem.

I also wonder whether the reason that playing another video first works is that perhaps the first video uses hardware acceleration whereas the 2nd video uses software emulation. (???)
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 01-24-03, 12:26 PM   #15
Demian
Registered User
 
Join Date: Jan 2003
Posts: 6
Default

Sorry about the confusion on agpart, it was late

The module is CONFIG_AGP under character devices. Check the info about NvAgp in the nvidia drivers readme line 1286, I have mine set to "1" which the readme says uses the NVAGP rather than AGPART. Also try removing your agp module before starting X.
I am running at 1600x1200 24bit, I will check the other resolution after I finish recompiling garnome
Yes it is very weird that no one else has this problem. I firt noticed it back in November and I have searched the web backwards and forwards and haven't found any other posts about it.
One other idea - have you tried downgrading to 3123 and testing Option "NvAgp" "1" under device?
Interesting point about hardware vs. software emulation - I will check if mplayer tells you which it is using - you can force software scaling by using mplayer -vop scale -zoom ----check man mplayer line 1826 or so.
Thats all for now, Im curious as to whether you can get it fix and its weird that changing NvAgp worked for me and not you
Demian is offline   Reply With Quote
Old 01-24-03, 02:07 PM   #16
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default

Interesting.

Still not sure why I am having problems with AGP then since I
CONFIG_AGP=m.

I will also see if removing the module before starting the x-server helps with AGP 0/1.

Any sense on where the ultimate bug lies and hence where we should be looking to submit a bug report?
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 01-25-03, 06:32 PM   #17
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default

I just re-tried using: Option "NvAgp"
This time I exited X, then manually removed the agpgpart module and then restarted X.

Unfortunately, this still did not fix the black line problems.

Interestingly, I got the following output in my log files:
TRIAL 1: NvAgp=1
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
....
(WW) NVIDIA(0): Failed to initialize AGP
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

TRIAL 2: NvAgp=0
(**) NVIDIA(0): Option "NvAGP" "0"
(**) NVIDIA(0): Use of AGP disabled per request

Interestingly, when I leave out the NvAgp option, I still get:
(WW) NVIDIA(0): Failed to initialize AGP

I'm not sure whether that has anything to do with the fact that I remove the agpgart module before, but I still get the same message even when I manually re-install the module.

The net result is that no matter what I do, it seems that AGP is never working (even when I don't set it). I had never realized this and am not sure whether this has anything to do with the " black lines" problem.
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 01-25-03, 07:04 PM   #18
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default

OOOPS... Disregard my previous message. I just re-read the nVidia README and it seems that you need to *reboot* between changing drivers.

So, first of all when I don't include the NvAgp option, I get the standard built-in AGP driver to work properly
(II) NVIDIA(0): AGP 4X successfully initialized

...and when I set Option "NvAgp" "1", I get
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(II) NVIDIA(0): AGP 4X successfully initialized

...and when I set Option "NvAgp" "0", I get
(**) NVIDIA(0): Option "NvAGP" "0"
(**) NVIDIA(0): Use of AGP disabled per request

Unfortunately, though in all 3 cases I still get the same black lines unless I do the kluge of starting another video first...

So, I am still not sure why you are seeing that NvAgp=0 or 1, solves your problems.

Perhaps it is a difference with XFree versions (or it could be due to hardware differences)

I am running the stock RH8.0 updated with a Linux 2.4.20 kernel.
and XFree86 4.2.0.
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 01-25-03, 10:21 PM   #19
Demian
Registered User
 
Join Date: Jan 2003
Posts: 6
Default oops i was wrong - It was VertRefresh all algong

I now know where the problem comes from and how to fix it. Puterguy, I'm guessing you are using an lcd monitor?
I realized that when I changed the NvAgp option I was using a backup XF86Config-4 where I had changed the vertrefresh.
So- I have to have VertRefresh set to 60 or I get lines. I just verified it several times, if i pute a range like 50-70 for vertrefresh I get lines. So far 60 is the only value that doesn't give my lines and I'm sticking with it. So the problem is with the VertRefresh. Test it with 60, or see if other people have posted specs for your particular screen and try those. Let me know!
Demian is offline   Reply With Quote
Old 01-26-03, 09:14 PM   #20
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default Good detective work

You are right about VertRefresh (and about my having an LCD as my profile shows
Setting it to 60 Hz does resolve the black line question.

But... I still have a couple of questions:
1. Can I assume now that different values of NvAgp has nothing to do with the problem or solution and that that was all a red herring?

2. I'm still not sure why starting another video first also "solves" the problem, since this should not effect the refresh rate. What is going on?

3. Won't setting refresh to 60Hz (rather than the 75Hz max of my LCD) adversely affect fast moving action like games?

4. We still don't know what the root cause is of this problem and therefore don't know how to fix it or even whom to submit a bug report to, right???

Any other thoughts on next steps?

Jeff
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote

Old 01-30-03, 10:24 PM   #21
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default

I have submitted the following summary bug report to: linux-bugs@nvidia.com:

I have a GF4 4600 (Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO) running under RedHat 8.0 with kernel 2.4.20. I am using the 4191 Linux driver.

When I play a video (of any format) at full-screen, the scaling
suffers from a pattern of interleaved black lines that ruin the
picture, making it look distorted with jagged edges and blurry.

Specifically, looking closely at the screen, it seems that instead of
properly scaling the picture, 1 pixel thin horizontal black lines are
interleaved between every few original image lines in a regular
pattern. It looks somewhat like this (where even between the
closest-spaced black lines, there are perhap 5 or 6 normal image
lines):

------------------------------------
------------------------------------
------------------------------------
------------------------------------



------------------------------------
------------------------------------
------------------------------------
------------------------------------



------------------------------------
------------------------------------
------------------------------------
------------------------------------

etc.

The effect is worse at full-screen than at double-screen. The result
is that the picture looks very jagged and blurry and thus is almost
impossible to view.

I have initiated a thread on this on the nVidia bulletin board
(http://www.nvnews.net/vbulletin/show...&threadid=6177), which has led to the following interesting observations.

1. The problem is independent of type of video or of video player
(this suggests that it is likely an X-server/driver problem)

2. If you begin with a normal size frame and gradually stretch the
picture, the black line effect suddenly appears when the picture gets to be about 3/4 the size of my 1280x1024 screen

3. The problem only occurs at some resolutions. In fact if you switch the X-server resolutions while the video is running
(ctl-alt-backspace) the "jaggie" effect comes and goes depending on the resolution. Specifically,
1280x1024: jaggies
1280x960: no jaggies
1152x864: no jaggies
1024x768: jaggies
800x600: jaggies
640x480: jaggies

4. INTERESTINGLY, if you start another video first and then start a
second video while the first one is still playing, then you can go to
full-screen without any jaggies. The picture remains good even after the first video completes. (Is it possible that the first video uses haredware scaling while the second uses software scaling???)

5. The problem resolves if I fix the vertical resolution at 60 Hz
(i.e., VertRefresh 60.0), but persists if I use the monitor
specifications of: VertRefresh 50.0 - 75.0 (this suggests maybe a
synchronization problem with the video frame rate???) [Note I have a digital LCD monitor]

6. Using different values for NvAGP has no effect

7. Using x11 vs. xv drivers has no effect

8. I have not had any other problems with the nVidia driver under RH Linux, including with games such as Quake

9. I think (but am not sure) that it worked ok under the 3123
driver. I have however not been able to downgrade to check it again.

So, in summary it seems to be something wrong with scaling that causes the problem that somehow is dependent on the screen resolution, vertical refresh rate, and whether or not another video is already running.

Any suggestions on what might be going on here?
I am stumped and frustrated?

Note that I am not satisfied with keeping the VertRefresh at 60, since I want to get the full 75Hz refresh performance of my monitor

Other details of my configuration include:
RH8.0/Linux 2.4.20
nVidea driver: 1.0-4191
Asus P4PE motherboard
Intel P4 2.53GHz
2 x 512 MB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
Viewsonic VG171 17" Flat Panel
Antec 400W PS

XF86Config file includes the following excerpts
...
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
VideoRam 131072
Option "NvAGP" "1"
Option "DigitalVibrance" "2"
Option "CursorShadow" "1"
Option "RenderAccel" "true"
...
Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 02-17-03, 07:04 PM   #22
fi_chince
Registered User
 
Join Date: Feb 2003
Posts: 2
Default Some additional information

Hello,

I've been experiencing the same problem with my LCD monitor (Samsung 152T). I've tried the suggestion of starting another video first and that seems to work. BUT, the suggestion about changing my VertRefresh to 60 did not work.

I do have some additional information that might be helpful:

1. My monitor has dual input (DVI and analog). This problem only occurs when I use the DVI connector. Using the analog VGA works perfectly fine.

2. puterguy said in his last post that using x11 vs. xv drivers has no effect. For me, though, this is not the case. If I run mplayer with x11 output, eg.

mplayer -vo x11 -zoom -dvd 1

and then switch the fullscreen, I do not get the "jaggies".

My config is almost identical to puterguy's.

Hope this information will be useful to somebody.
fi_chince is offline   Reply With Quote
Old 02-22-03, 05:58 AM   #23
foft
Registered User
 
Join Date: Feb 2003
Location: London
Posts: 1
Post

I have exactly the same problem with my Samsung 191T monitor and Geforce Ti4600 connected via DVI. I only see the problem with a DVI connection. Does everyone with this problem have a Samsung TFT?

As a workaround I tried setting the VertRefresh to 60. This did not improve matters until I also set the HorizSync to 64. Now it looks as it should (albeit at 60Hz... Of course still no flicker though being a TFT!).
foft is offline   Reply With Quote
Old 05-09-03, 03:33 PM   #24
Who_cares
Registered User
 
Join Date: May 2003
Posts: 6
Default

This is wierd as I also have a GeForce 4 Ti 4200 and Samsung 171P (LCD). I wonder whats the cause of this. THanks for the solution though

Ba bye
Who_cares is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: GTC 2012 Full Keynote News Archived News Items 0 05-22-12 07:30 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 05:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 12:53 PM

All times are GMT -5. The time now is 06:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.