Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-20-05, 10:05 AM   #13
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

xorg log
Attached Files
File Type: log Xorg.0.1.log (32.0 KB, 111 views)
LubosD is offline   Reply With Quote
Old 12-20-05, 11:17 AM   #14
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: Dual-head and separated screens (:0.0/:0.1)

Have you tried with 7676 drivers?
Imperito is offline   Reply With Quote
Old 12-20-05, 11:38 AM   #15
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Dual-head and separated screens (:0.0/:0.1)

Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-20-05, 11:46 AM   #16
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

Bug report is generated against the working xorg.conf (one-head setup).
The bunch of Xids is caused by my unsuccessful dual-head.
Attached Files
File Type: log nvidia-bug-report.log (94.8 KB, 114 views)
LubosD is offline   Reply With Quote
Old 12-20-05, 12:02 PM   #17
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Dual-head and separated screens (:0.0/:0.1)

LubosD,
You need to generate a bug report after you've experienced the problem. There's no bug in the one you posted.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-20-05, 12:20 PM   #18
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

Ok, sorry.

This one is from startx -- :0, nvidia used the LCD display but it is saying 'Using ConnectedMonitor string "CRT-0"' - but CRT-0 is screen 1

When I do startx -- :0.1 nothing can connect to the X server.
The Xorg.0.1.log is attached too - it says again something about CRT-0 (yeah, screen 1 should be CRT) but it uses my DVI connected LCD anyway.
Attached Files
File Type: log nvidia-bug-report.log (95.7 KB, 108 views)
File Type: log Xorg.0.1.log (33.0 KB, 112 views)
LubosD is offline   Reply With Quote
Old 12-20-05, 02:18 PM   #19
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Dual-head and separated screens (:0.0/:0.1)

I have a few questions:
0) Why are you using the ConnectedMonitor option? Currently the nvidia driver will always treat a CRT as the primary display device. You cannot change this behavior with the ConnectedMonitor option.
1) What kind of a system/motherboard are you using and which BIOS version?
2) Is there a reason why you are trying to start up each X screen individually? If you just run 'startx' with no other options, what result do you get (once you've removed ConnectedMonitor from your xorg.conf)?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-20-05, 02:52 PM   #20
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

I have to admit that I completely misunderstood how this works... I thought that I can start a separate X session for each display. I'm sorry for this. Now I can see what is this all about

It works

1) In case you're still interested: it's an FIC VI11 motherboard (year 2002), BIOS version is...umm...it's definitely the latest one, chipset is SiS645DX

Just a question: is there any (hackish ) way how to make the driver treat the DFP as a primary device?
LubosD is offline   Reply With Quote

Old 12-20-05, 07:16 PM   #21
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: Dual-head and separated screens (:0.0/:0.1)

It works?
What all did you change? (Just wondering, I get that same error in addition to some other problems, might be related, I don't know).

Are you still using 8174?

I don't have a CRT at all, and I use ConnectedMonitor lines, which work in 7676 but stop working in 8174.
Imperito is offline   Reply With Quote
Old 12-21-05, 07:05 AM   #22
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

Yeah, it works; still using 8174. I have removed ConnectedMonitor lines.

1) But I need my LCD as a main display
2) I'd like to make this work without restarting X. When I connect the second monitor I have to restart X to make the second monitor work. This sux, I think this doesn't require restarts on Windows®
--
First I thought that screens are absolutely separate and I can/have to start separate X server for each screen. But now I can see that X takes both displays and it is a matter of DISPLAY (:0.0 or 0.1) where the program will show up.
LubosD is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.