Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-19-05, 05:23 PM   #1
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Dual-head and separated screens (:0.0/:0.1)

Hello,

I am trying to have a separate X session on each monitor (LCD and CRT).

I have found a lot of example xorg.confs but I can't make it work...mabye I just missed something.
It always gives me "More than one matching Device section found: device2" - both :0.0 and :0.1 start on monitor 0 (LCD).

Can you please tell me what am I doing wrong? My current xorg.conf is attached.

Thanks,
Lubos
Attached Files
File Type: txt xorg.conf.txt (2.8 KB, 111 views)
LubosD is offline   Reply With Quote
Old 12-19-05, 05:30 PM   #2
hermier
Registered User
 
Join Date: Dec 2005
Posts: 26
Default Re: Dual-head and separated screens (:0.0/:0.1)

Try to put the connected monitor to "CRT-0" and "DFP-0".
Seems to be the only *error* I see.
hermier is offline   Reply With Quote
Old 12-19-05, 06:01 PM   #3
mo_x
Registered User
 
Join Date: Jul 2005
Posts: 77
Default Re: Dual-head and separated screens (:0.0/:0.1)

The BusID is missing from the device section, see the nvidia README.
Try also removing the ConnectedMonitor option.
mo_x is offline   Reply With Quote
Old 12-20-05, 01:15 AM   #4
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

Quote:
Originally Posted by mo_x
The BusID is missing from the device section, see the nvidia README.
Try also removing the ConnectedMonitor option.
I think that BusID is not necessary when there is only one card.
LubosD is offline   Reply With Quote
Old 12-20-05, 01:20 AM   #5
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

I have tried DFP-0 and CRT-0 - did not help.
I have removed ConnectedMonitor Options - now it just always starts on the CRT. It still complains about more matching Device sections.

When I add BusID: The requested device configuration is not supported in the hardware.
LubosD is offline   Reply With Quote
Old 12-20-05, 04:53 AM   #6
fm2503
Registered User
 
Join Date: Aug 2005
Posts: 7
Default Re: Dual-head and separated screens (:0.0/:0.1)

Try:
Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1" 0 0
Screen "screen2" RightOf "screen1"
EndSection

(Note the added 0 0)
Also try adding
Section "ServerFlags"
Option "Xinerama" "false"
EndSection
fm2503 is offline   Reply With Quote
Old 12-20-05, 05:42 AM   #7
mo_x
Registered User
 
Join Date: Jul 2005
Posts: 77
Default Re: Dual-head and separated screens (:0.0/:0.1)

Maybe you used the wrong BusID. Can you create a nvidia-bug-report.log (run the nvidia-bug-report.sh script as root) and attach it.
mo_x is offline   Reply With Quote
Old 12-20-05, 09:01 AM   #8
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

BusID should be correct, it complains when I use a different one...

Current errors:
(EE) NVIDIA(1): The requested configuration of display devices is not
(EE) NVIDIA(1): supported in the hardware.
(EE) NVIDIA(1): Failed to unmap registers.
(EE) NVIDIA(1): Failed to unmap registers.
(EE) NVIDIA(1): Failed to free registers.

and it always starts on screen 0 (LCD).

Attaching my current xorg.conf...
Maybe someone from nVidia could help?
Attached Files
File Type: txt xorg.conf.txt (2.9 KB, 104 views)
LubosD is offline   Reply With Quote

Old 12-20-05, 09:13 AM   #9
Imperito
Registered User
 
Join Date: Sep 2002
Posts: 68
Default Re: Dual-head and separated screens (:0.0/:0.1)

I get that same error in 8174, I have to use 7676, where it works.
Imperito is offline   Reply With Quote
Old 12-20-05, 09:24 AM   #10
mo_x
Registered User
 
Join Date: Jul 2005
Posts: 77
Default Re: Dual-head and separated screens (:0.0/:0.1)

I think the CRT will be used as you primary display so try to exchange the CRT-0 and DFP-0 options. The contents of /var/log/Xorg.0.log which is also include in the nvidia log would also be very useful.
mo_x is offline   Reply With Quote
Old 12-20-05, 09:29 AM   #11
LubosD
Registered User
 
Join Date: Jan 2005
Location: Czech Republic
Posts: 451
Send a message via ICQ to LubosD
Default Re: Dual-head and separated screens (:0.0/:0.1)

Quote:
Originally Posted by mo_x
I think the CRT will be used as you primary display so try to exchange the CRT-0 and DFP-0 options.
When I swap CRT-0 and DFP-0 it stops working completely (both monitors are blank).

There are no more errors in the Xorg.0.1.log than "The requested configuration...". There is just some warning:
(WW) NVIDIA(0): Failure reading FlatPanel flags for DFP-0.
LubosD is offline   Reply With Quote
Old 12-20-05, 10:02 AM   #12
mo_x
Registered User
 
Join Date: Jul 2005
Posts: 77
Default Re: Dual-head and separated screens (:0.0/:0.1)

I am not sure, maybe you need a modeline or something else. Without the log files it's hard to tell.
mo_x is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.