Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-26-05, 03:00 AM   #1
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default FC5t1 nv 8178 wrong, why .how to ?

sh 8178............run
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
ERROR: Unable to connect to download.nvidia.com (temporary DNS error (try again
later))
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
ddd999 is offline   Reply With Quote
Old 12-28-05, 03:13 AM   #2
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: FC5t1 nv 8178 wrong, why .how to ?

help me
ddd999 is offline   Reply With Quote
Old 12-28-05, 06:51 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC5t1 nv 8178 wrong, why .how to ?

You need to install the kernel-devel package for whichever kernel you have installed.
zander is offline   Reply With Quote
Old 12-28-05, 10:01 AM   #4
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: FC5t1 nv 8178 wrong, why .how to ?

I have installed kernel-devel-2.6.14-1.1786_FC5.i586.rpm
but problem still
ddd999 is offline   Reply With Quote
Old 12-28-05, 07:09 PM   #5
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: FC5t1 nv 8178 wrong, why .how to ?

installed kernel-source-2.6.14.3-1tr.i586.rpm
but problem still
ddd999 is offline   Reply With Quote
Old 12-28-05, 08:37 PM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC5t1 nv 8178 wrong, why .how to ?

Please attach the /var/log/nvidia-installer.log file generated by the installer after installing the kernel-devel package for the running kernel; also, please do not create more than one thread per problem.
zander is offline   Reply With Quote
Old 12-28-05, 10:15 PM   #7
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: FC5t1 nv 8178 wrong, why .how to ?

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Dec 29 09:02:55 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC test with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured; on Red Hat Linux systems,
for example, be sure you have the 'kernel-source' RPM installed. If you
know the correct kernel source files are installed, you may specify the
kernel source path with the '--kernel-source-path' command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
ddd999 is offline   Reply With Quote
Old 12-29-05, 01:10 AM   #8
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: FC5t1 nv 8178 wrong, why .how to ?

Quote:
Originally Posted by ddd999
installed kernel-source-2.6.14.3-1tr.i586.rpm
but problem still
why i586 which cpu is installed on your system...?
if it is > pentium I then a i686 kernel is running and you need the correct devel package.
Dragoran is offline   Reply With Quote

Old 12-29-05, 05:06 AM   #9
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: FC5t1 nv 8178 wrong, why .how to ?

Quote:
Originally Posted by Dragoran
why i586 which cpu is installed on your system...?
if it is > pentium I then a i686 kernel is running and you need the correct devel package.
[root@localhost ~]# rpm -e kernel-devel-2.6.14-1.1786_FC5
[root@localhost ~]# rpm -ivh kernel-devel-2.6.14-1.1786_FC5.i686.rpm
Preparing... ########################################### [100%]
1:kernel-devel ########################################### [100%]
[root@localhost ~]#
but problem still
nvidia: where can find the **** "precompiled kernel interface " to install
sh .......run
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
ERROR: Unable to connect to download.nvidia.com (temporary DNS error (try again
later))
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel source
files are installed, you may specify the kernel source path with the
'--kernel-source-path' commandline option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
ddd999 is offline   Reply With Quote
Old 12-29-05, 06:09 AM   #10
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC5t1 nv 8178 wrong, why .how to ?

Which kernel do you have installed on your system (see `uname -r` and `rpm -qa | grep kernel`)?
zander is offline   Reply With Quote
Old 12-29-05, 06:56 AM   #11
ddd999
Registered User
 
Join Date: Dec 2005
Posts: 23
Default Re: FC5t1 nv 8178 wrong, why .how to ?

Quote:
Originally Posted by zander
Which kernel do you have installed on your system (see `uname -r` and `rpm -qa | grep kernel`)?
[root@localhost ~]# uname -r
2.6.14-1.1696_FC5
[root@localhost ~]# rpm -qa | grep kernel
kernel-2.6.14-1.1696_FC5
kernel-devel-2.6.14-1.1786_FC5
kernel-source-2.6.14.3-1tr
[root@localhost ~]#
ddd999 is offline   Reply With Quote
Old 12-29-05, 06:57 AM   #12
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: FC5t1 nv 8178 wrong, why .how to ?

You didn't install the correct kernel-devel package, you need to install kernel-devel-2.6.14-1.1696_FC5.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.