Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-29-05, 05:03 AM   #1
askesis
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Debian, x86_64-1.0-8178 glx not working

I am running the official NVidia drivers as downloaded from the NVidia site (NVIDIA-Linux-x86_64-1.0-8178). I am using two monitors with TwinView and all seems OK, except that I cannot run nvidia-settingS or any OpenGl application (e.g. glxgears): whenever I try to load the glx module my XServer refuses to start, without any errors in the XOrg.log.0 (there is 1 warning about skipping the submodule "fb" due to not finding the the symbols)

I have checked that all the files that are on the system are the correct files as per NVidia FAQ.

I there something I can do about this as I really must run some OpenGL aplications?

My nvidia-bug-report.log: http://laudanum.askesis.nl/nv.html
askesis is offline   Reply With Quote
Old 12-29-05, 06:14 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Debian, x86_64-1.0-8178 glx not working

Please generate and attach an nvidia-bug-report.log file after a failed attempt to start X with the GLX module. Does the problem reproduce immediately after the driver installation or only after a reboot? In the latter case, does /etc/init.d/nvidia-glx still exist (part of Debian's nvidia-glx package)?
zander is offline   Reply With Quote
Old 12-29-05, 06:29 AM   #3
askesis
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Re: Debian, x86_64-1.0-8178 glx not working

Quote:
Originally Posted by zander
Please generate and attach an nvidia-bug-report.log file after a failed attempt to start X with the GLX module. Does the problem reproduce immediately after the driver installation or only after a reboot? In the latter case, does /etc/init.d/nvidia-glx still exist (part of Debian's nvidia-glx package)?
It is reproducable both after (re)installation and reboot. I do not have /etc/init.d/nvidia-glx.

Attached the zipped nvidia-bug-report.log

TIA

Joost
Attached Files
File Type: zip nvidia-bug-report.zip (25.5 KB, 109 views)
askesis is offline   Reply With Quote
Old 12-29-05, 06:37 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Debian, x86_64-1.0-8178 glx not working

-> Unable to access previously installed file
'/usr/lib/tls/libnvidia-tls.so.1.0.8178' (No such file or directory).
-> Unable to access previously installed symlink
'/usr/lib/tls/libnvidia-tls.so.1' (No such file or directory).


X crashes because the wrong TLS library is being loaded (/usr/lib/libnvidia-tls.so.1). Does /usr/lib/tls exist?
zander is offline   Reply With Quote
Old 12-29-05, 06:56 AM   #5
askesis
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Re: Debian, x86_64-1.0-8178 glx not working

No, it does not exist in my 64-bit /usr/lib directory. The file and it's symlink however *do* exist in the /usr/lib directory itself. As I look at the timestamps of the files in the /usr/lib directory, they are from the NVidi install (and as I have not installed the Debian deb files I cannot imagine any other program createing and installing *nvidia* files ;-)).

The installation program however, did create (and install) the file and the symlink in the 32-bit emul environment.

TIA

Joost
askesis is offline   Reply With Quote
Old 12-29-05, 06:59 AM   #6
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Debian, x86_64-1.0-8178 glx not working

The files in /usr/lib are not identical to those the installer attempted to install to /usr/lib/tls; does the problem go away if you create /usr/lib/tls and reinstall the driver?
zander is offline   Reply With Quote
Old 12-29-05, 07:10 AM   #7
askesis
Registered User
 
Join Date: Dec 2005
Posts: 4
Default Re: Debian, x86_64-1.0-8178 glx not working

Installation with a manually created /usr/lib/tls does the trick.

Thanks for the assistance

Joost
askesis is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 02:46 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.