Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-29-05, 08:39 AM   #1
taurai
Registered User
 
Join Date: Dec 2005
Posts: 1
Angry GeForce 6600 for Suse 10 IA32 HELP HELP

I have battled, with out success, with my Geforce 6600, trying to install the driver. I have a 17" wide screen on a Toshiba Laptop (Toshiba Qosmio). I start Suse 10 and go to runlevel 3 and try

1)

Using YOU to automatically update the driver. YOU goes through and does the download/update and installation without any problems/complaints. But when it finishes I do not have the "1.0-8178" driver installed. My 3D accelation is still inactive (disabled and can't be changed). Trying to force SAX to have any screen resoulution higher than 1024X768@60Hz will cause startx to fail. Can only get startx to start in a mode equal to 1024X768@60Hz or lower, with no 3D accelaration. FAILS FAILS FAILS

2)

The second approach also FAILS FAILS FAILS as detailed below

I try the manual approach using nvidia-installer (runlevel 3) and the following is my install log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Dec 29 15:24:17 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
7676). As part of installing this driver (version: 1.0-8178), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC test with CC="cc".
-> Kernel source path: '/usr/src/linux'
-> Kernel output path: '/usr/src/linux'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -f stprof stprof.o symtab.h
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/usr/src/linux SYSOUT=/usr/s
rc/linux'...

NVIDIA: calling KBUILD...
make CC=cc KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/tmp/selfgz24204/NVID
IA-Linux-x86-1.0-8178-pkg1/usr/src/nv modules
Makefile:494: .config: No such file or directory
mkdir -p /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/.tmp_ver
sions

WARNING: Symbol version dump /usr/src/linux-2.6.13-15.7/Module.symvers
is missing; modules will have no dependencies and modversions.

make -f scripts/Makefile.build obj=/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-817
8-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz24204/NV
IDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv_compiler.h
cc -Wp,-MD,/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/.nv.
o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.0.2/include -D__KERNE
L__ -Iinclude -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -Werror-impl
icit-function-declaration -fno-strict-aliasing -fno-common -ffreestanding -O
2 -fomit-frame-pointer -pipe -msoft-float -mpreferred-stack-bo
undary=2 -fno-unit-at-a-time -Iinclude/asm-i386/mach-default -Wdeclaration-
after-statement -Wno-pointer-sign -I/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-81
78-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-s
ubscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-com
mon -MD -Wsign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D_
_KERNEL__ -DMODULE -DNTRM -DNVRM -DDYNAMIC_SLI -DNV_MAJOR_VERSION=1 -DNV_M
INOR_VERSION=0 -DNV_PATCHLEVEL=8178 -UDEBUG -U_DEBUG -DNDEBUG -DNV_SIGNAL_S
TRUCT_RLIM -DNV_MULTIPLE_BRIDGE_AGPGART_PRESENT -DNV_PCI_GET_CLASS_PRESENT -
DNV_SYSCTL_MAX_MAP_COUNT_PRESENT -DNV_REMAP_PFN_RANGE_PRESENT -DNV_CHANGE_PA
GE_ATTR_PRESENT -DNV_VMAP_4_PRESENT -DMODULE -DKBUILD_BASENAME=nv -DKBUILD_
MODNAME=nvidia -c -o /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv/nv.o /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.c
In file included from include/linux/bitops.h:77,
from include/linux/kernel.h:15,
from /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv/nv-linux.h:46,
from /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv/nv.c:14:
include/asm/bitops.h: In function ‘find_first_bit’:
include/asm/bitops.h:334: warning: comparison between signed and unsigned
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv/nv-linux.h:47,
from /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv/nv.c:14:
include/linux/prefetch.h: In function ‘prefetch_range’:
include/linux/prefetch.h:62: warning: pointer of type ‘void *’ used in a
rithmetic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:870,
from /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv/nv-linux.h:71,
from /tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv/nv.c:14:
include/asm/io.h: In function ‘check_signature’:
include/asm/io.h:253: warning: wrong type argument to increment
/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.c: In function
‘nvidia_init_module’:
/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.c:1305: warnin
g: ‘pm_register’ is deprecated (declared at include/linux/pm.h:107)
/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.c:1423: warnin
g: ‘pm_unregister’ is deprecated (declared at include/linux/pm.h:112)
/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.c: In function
‘nvidia_exit_module’:
/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.c:1479: warnin
g: ‘pm_unregister’ is deprecated (declared at include/linux/pm.h:112)
/bin/sh: scripts/basic/fixdep: No such file or directory
make[3]: *** [/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv.
o] Error 1
make[2]: *** [_module_/tmp/selfgz24204/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/sr
c/nv] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [mdl] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

__________________________________________________ __
The following is my XF86Config

# /.../
# SaX generated X11 config file
# Created on: 2005-12-29T15:53:27+0200.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/opt/kde3/share/fonts"

<<<<snipped>>>>

InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Microsoft IntelliMouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.1"
Option "BottomEdge" "650"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "InputFashion" "Mouse"
Option "LeftEdge" "120"
Option "MaxSpeed" "1"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "ALPS;Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "Sysp"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 366 229
HorizSync 28-48
Identifier "Monitor[0]"
ModelName "1024X768@60HZ"
Option "DPMS"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "768x576" 33.74 768 792 872 976 576 577 580 596
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce Go 6600 (0x0148)"
BusID "1:0:0"
Driver "nv"
Identifier "Device[0]"
Option "XaaNoOffScreenPixmaps" "on"
Option "XaaNoPixmapCache" "on"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
Attached Files
File Type: log nvidia-installer.log (7.6 KB, 116 views)
taurai is offline   Reply With Quote
Old 01-02-06, 12:24 PM   #2
michiels
Registered User
 
Join Date: Jan 2006
Posts: 1
Default Re: GeForce 6600 for Suse 10 IA32 HELP HELP

Hello,

I have just installed the new vidia driver in my SuSE 10 system.
Inspection of your nvidia install shows that you did not set
the same path as I did. In fact, the default worked for me:
/lib/modules/2.6.13-15-default/build
I guess that this is the same for any SuSE 10.
(In previous attempts I too set the kernel-path to /usr/source
because I got messages about kernel.h not found and that's where
it was. However, using the manual install I had to go back to
the default.)

Once the kernel module was installed and the XF86Config
file had nvidia instead of nv, I could not get the right resolution
to work (for me 1600X1200). Then I discovered by looking at the
/var/log/X.org.0.log that the driver was adding its own modeline
(which it got from the chip I presume).
I commented out all the mode lines in the /etc/X11/XF86Config
file and it worked !

Hope this is of any help for you,

Regards
michiels is offline   Reply With Quote
Old 01-02-06, 12:56 PM   #3
Cimi
Registered User
 
Cimi's Avatar
 
Join Date: Oct 2005
Location: Padua, Italy
Posts: 96
Send a message via ICQ to Cimi Send a message via AIM to Cimi Send a message via MSN to Cimi Send a message via Yahoo to Cimi
Thumbs down Re: GeForce 6600 for Suse 10 IA32 HELP HELP

Quote:
Originally Posted by taurai
I have battled, with out success, with my Geforce 6600, trying to install the driver. I have a 17" wide screen on a Toshiba Laptop (Toshiba Qosmio). I start Suse 10 and go to runlevel 3 and try

1)

Using YOU to automatically update the driver. YOU goes through and does the download/update and installation without any problems/complaints. But when it finishes I do not have the "1.0-8178" driver installed. My 3D accelation is still inactive (disabled and can't be changed). Trying to force SAX to have any screen resoulution higher than 1024X768@60Hz will cause startx to fail. Can only get startx to start in a mode equal to 1024X768@60Hz or lower, with no 3D accelaration. FAILS FAILS FAILS

2)

The second approach also FAILS FAILS FAILS as detailed below
i personally dislike users that behaves in a nervous way. So no help from me
__________________
/\ndr3a
http://www.cimitan.com
ItalianUser
Cimi is offline   Reply With Quote
Old 06-08-07, 01:04 PM   #4
siucdude
Registered User
 
siucdude's Avatar
 
Join Date: Jan 2007
Location: Chicago
Posts: 1
Send a message via ICQ to siucdude
Default Re: GeForce 6600 for Suse 10 IA32 HELP HELP

cimi, I know this is a old threat but I was wondering if you could help me, I have the same computer and I run Ubuntu, I have tried everything, I currently run under nv in xorg.conf because when i switch to nvidia all i get is a black screen, I have posted at ubuntu forums, but i keep getting the anwser to hit ctrl+alt+F*, which does not do anything since the keyboard is almost like locked.

Anyways anyone that could help me out it would be appreciated. I will keep playing my self.

Thanks
Tom
siucdude is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 03:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.