Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-03-06, 02:42 PM   #1
Patator
Registered User
 
Join Date: Jan 2006
Location: Paris
Posts: 6
Default Getting an old RIVA TNT running on Mdk 10.2 (LE2006)

Hello, I am desperately trying to make my old computer working with mandriva 10.2
So far, native X driver will not work
I have tried compiling NV driver 6629 with either patch 02.28.2006 and 1206883 or 02.28.2005+warpxmod and it finally compile but I had error loading modules ddc, etc. So I followed instruction with ld -shared -o ... as mentionned in a post earlier (sorry, few cut and paste, I am using lynx right now and no gpm

The best I got was to have the splash screen but it did not erase to let X, the mouse leave a trace behind (no refresh, it draws but it does not refresh...)

Of course, this is based on another kernel I compiled (but i am kind of rusty at that too, did I forget a parameter??)

any help welcome, this is m X log as far as I can get with the ld command to update nvidia_drv.o
Attached Files
File Type: log Xorg.0.log (29.5 KB, 126 views)
Patator is offline   Reply With Quote
Old 01-03-06, 11:55 PM   #2
fhj52
Registered User
 
Join Date: Jan 2005
Posts: 135
Default Re: Getting an old RIVA TNT running on Mdk 10.2 (LE2006)

According to log, X loaded. You have a 1280x1024 screen with (90,96) DPI fonts, ...
X cannot load any better than it did.

For using nVidia drivers, when splash screen shows, the nVidia drivers are loaded. What happens after that depends on you and Man*

I would look elsewhere for solution to problem.

One thing you can try is to kill X with CTRL-ALT-BKSP and when it drops you to terminal, start X using something like startxfce or startkde, etc... (details omitted) . That will bypass that *(^#*^ stupid login screen Man* has created to control how one does a login. IOW, it could be the Man* default login screen that is hanging. I have not used 2006 yet( got it on disk but ... ). They are probably using the KDE-clone they made for login as the default login screen. MANY have had trouble with it in the past...
Oh, you will need to be root do most any of that so be very careful!

If it helps, I ran TnT2 card on XFree and also with nVidia drivers for a long time(years) with Mandrakelinux from versions 7.x - 9.x. I have not used it in a long time but last time, with Man*9.1, it worked just fine. I think I used the native X drivers... (not nvidia). That system is under desk ...somewhere ... not on but I am sure if I turned it on, I would have same result as always.

Good Luck!
__________________
When two people meet and exchange gifts, each has one object.
When two people meet and exchange ideas, each has two ideas.
... Open Source. Just do it.

---------------------------------
System: BFG GTX260^2 graphics but has ** TERRIBLE BLINKING OS **
SuperMicro H8DCi+AMI BIOS;dual Opt'285;8GB;LSI 320-2x w/ 6xU320 Fuji' MAXs in RAID 10; 4xSATAII on LSI 3041E for backup. Multi-boot Mandriva Linux, openSUSE, WinXPx64 & Win2k-AS; Creative Audigy2-Digital audio.
Gigabyte GA-2CEWH & NVRAID are GONE ... Finally!!
fhj52 is offline   Reply With Quote
Old 01-04-06, 12:25 AM   #3
Patator
Registered User
 
Join Date: Jan 2006
Location: Paris
Posts: 6
Default Re: Getting an old RIVA TNT running on Mdk 10.2 (LE2006)

Well, thanks for the input. However, problem is not with kde or any other window manager, I have the same issue by simply typing X

And it did work fine until 9.2. on 10.1, I had to switch to reglar drivers from Mandriva as I did not find anyother way at that time. Becasue of stability issues, I tried 10.2 and the native driver does not work and this, is not so far very conclusive unfortunately.

But you are right, exept forall the DDC @ 0MHZ (surprising, no?) everything seems to be loading properly. May be the problem lies in the twik I had to make by following this: http://www.nvnews.net/vbulletin/showthread.php?t=58097
Patator is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Riva TNT 2 - Debian (Woody) chipset problem sindra NVIDIA Linux 4 08-26-02 03:21 AM

All times are GMT -5. The time now is 05:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.