Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-04-06, 04:20 AM   #1
debian_penguin
Linux Addicted
 
debian_penguin's Avatar
 
Join Date: Aug 2005
Posts: 61
Default nvsound on nforce3 audio

Hi all,

I have some problems with nvsound and nvmixer with any version of the nforce drivers (tried up to the newest 1.0-0310): I have an nforce3 chipset audio card (on a laptop) and with nvmixer I have no access to the PCM (or wave, or whatever) volume control, nor to the headphones output volume control. It is a problem because the driver doesn't recognize when the headphones are plugged, and I cannot thus separately mute the external speaker and enable the heaphones alone. With older versions of ALSA (snd-intel8x0 kernel module) the jack plug was not sensed as well, but I had separate control over each input-output channel: I could mute speakers and/or headphones (note: their name were correctly recognized, so that speakers was "master" and headphones was "headphones", not some strange "line#" or the like) and set separate output level for each one. With newer alsa drivers (from the ones in stock kernel 2.6.12, if I'm not wrong), I also get in alsamixer the swich for "hp jack sense" which works perfectly, muting the speakers when hp are plugged in. But with nvmixer I can only change the master volume (wich works on the hp output level as well), but it doesn't mute the speaker in any way. I can post some screenshots of the mixers if you think they're useful.

I'll also post a bug-report as soon as I have some time to reboot the machine.

Thank you, as always,

d_p
__________________
Laptop HP Pavilion zv5000: AMD Athlon 3000+ (32 bit); Nvidia GeForce4 440 Go! 64 Mb, 8774 driver revision; 768 MB PCI2700; nForce3 mobo chipset and audiocard, other uninteresting stuff... Debian unstable-experimental, custom 2.6.17 kernel debian-patched
Any sufficiently advanced bug is indistinguishable from a feature.

Last edited by debian_penguin; 01-04-06 at 04:30 AM.
debian_penguin is offline   Reply With Quote
Old 01-04-06, 04:40 AM   #2
debian_penguin
Linux Addicted
 
debian_penguin's Avatar
 
Join Date: Aug 2005
Posts: 61
Default Re: nvsound on nforce3 audio

Here are the bug-report and the screenshots.

In "bug_report_screenshots" you'll find the nforce_bug_report.log file, with some screenshots taken from the nvmixer application and from kmix's input and output tabs.

In "kmix_alsa_screenshot" you'll find the three screenshots taken from kmix with the alsa driver (kernel.org's stock 2.6.15-rc5 kernel) of the input/output/switches tabs.

Thank you,

d_p
Attached Files
File Type: zip kmix_alsa_screenshots.ZIP (56.9 KB, 144 views)
File Type: zip bug_report_screenshots_nforce.ZIP (85.9 KB, 134 views)
__________________
Laptop HP Pavilion zv5000: AMD Athlon 3000+ (32 bit); Nvidia GeForce4 440 Go! 64 Mb, 8774 driver revision; 768 MB PCI2700; nForce3 mobo chipset and audiocard, other uninteresting stuff... Debian unstable-experimental, custom 2.6.17 kernel debian-patched
Any sufficiently advanced bug is indistinguishable from a feature.
debian_penguin is offline   Reply With Quote
Old 01-28-06, 02:57 AM   #3
debian_penguin
Linux Addicted
 
debian_penguin's Avatar
 
Join Date: Aug 2005
Posts: 61
Default Re: nvsound on nforce3 audio

I don't want to appear boring, but this thread (and another related) did not receive any reply by any moderator. Did anyone read this?

An answer like "we cannot currently look at this" would be appreciated as well, just to know that you are aware of the existence of this problem.

Thank you, sorry for the insistence,

d_p
__________________
Laptop HP Pavilion zv5000: AMD Athlon 3000+ (32 bit); Nvidia GeForce4 440 Go! 64 Mb, 8774 driver revision; 768 MB PCI2700; nForce3 mobo chipset and audiocard, other uninteresting stuff... Debian unstable-experimental, custom 2.6.17 kernel debian-patched
Any sufficiently advanced bug is indistinguishable from a feature.
debian_penguin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT: audio on TV with a DVI(PC) to HDMI(TV) cable? legluondunet NVIDIA Linux 0 06-23-12 07:58 AM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
No HDMI audio on 302.07 fldc NVIDIA Linux 5 06-01-12 04:46 PM
nForce Audio pergamon NVIDIA Linux 6 12-25-02 11:38 PM
Bohooo HELP, new Nforce 1.13 Audio Utilities won INITIALIZE nanyangview CPUs, Motherboards And Memory 1 09-04-02 07:40 PM

All times are GMT -5. The time now is 02:23 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.