Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-14-03, 06:14 PM   #1
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Thumbs up need a help ! RH 8.0 kernel 2.4.18-19.8.0 THANKX WHO HELPED ME!!

Hi,
My Kernel is 2.4.18-19.8.0. I am beginer in Linux. After I executed nv _check.sh.txt I got this :
Welcome to the NVidia Driver Installation Checker.
This shell script is meant to help you debug your installation
of the beta NVidia Linux drivers. It is not 100% foolproof.
In particular, you will definitely want to make sure you have
the correct options in your XF86Config to make X work properly.
This script cannot debug your X setup. That being said, it
should prove useful if are having problems with the drivers and
want to check the validity of your driver install.

At no time will this script EVER make changes to your system.
It is simply a diagnostic tool - fixes of any kind will have to
come from you.

Press enter to continue...

OK, the first thing we need to do is make sure your XF86Config file
is set up correctly. In order to do this, I'm first going to try
and find where this file might be...
checking /usr/X11R6/lib/X11/XF86Config...
found
checking /usr/X11R6/etc/X11/XF86Config...
not found
checking /etc/XF86Config...
not found
checking /etc/X11/XF86Config...
found
checking /etc/X11/XF86Config-4...
not found
I'm going to be doing my checking using /etc/X11/XF86Config. If this is not
actually your X config, then quit this script with Ctrl-C, remove
or rename the file, then run this script again.
Press enter to continue

I'm going to check your XF86Config file for the following things:
1) Loading the GLcore and glx modules
2) Specifying the nvidia driver instead of nv

Checking for the Load glx statement...
Load "glx"
It seems to be intact. Now lets see if you're loading the correct
video driver...
Driver "nvidia"
Everything seems fine in your X config file. This is not 100%
guaranteed to be accurate, but lets continue anyway (press enter)...

The next step involves making sure you have the proper files in
the right places, and that the kernel module loaded correctly.
Press enter to begin the test.

First lets make sure you don't have the old modules still present
by mistake...
Checking /usr/X11R6/lib/modules/extensions/libglx.a...
Checking /usr/X11R6/lib/modules/extensions/libGLcore.a...
You don't appear to have any conflicting older drivers. Now lets check
if the new driver files are in place...
Checking /usr/X11R6/lib/modules/drivers/nvidia_drv.o...
Checking /usr/X11R6/lib/modules/extensions/libglx.so...
Checking /usr/lib/libGL.so...
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x4005b000)
Checking /usr/lib/libGLcore.so.1...
All the files seem to exist. Now I'm going to see if your kernel
module is loaded correctly...
the NVdriver kernel module does not seem to be loaded. The 3D
drivers will not work without it...please compile it for your
kernel, set it up to insert the module on boot, then run
this script again.
Remember if you are having trouble compiling the module,
try adding -D_LOOSE_KERNEL_NAMES to the Makefile.

My problem is I don't know how I can compile NVdriver kernel module for my kernel and set it up to insert the module on boot.
Somebody help me,plz !
I used
rpmbuild --rebuild VIDIA_kernel-1.0-4191.src.rpm
rpm -ivh usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-4191.i386.rpm
rpm -ivh NVIDIA_GLX-1.0-4191.i386.rpm
I can see NVIDIA log screen before I log in.
Thank you so much..

Last edited by vvnnyc; 01-15-03 at 04:14 PM.
vvnnyc is offline   Reply With Quote
Old 01-14-03, 06:47 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

If you're using driver 4191, the problem is most likely with the nv_check.sh script. It only checks for a kernel module name of "NVdriver", which was the name of the module in release 3123 and previous. nVidia decided to be fun and change the name of the module with the release of 4191 (little friendly jab at the developers there... ), and it's caused headaches like this ever since.

So... you're probably OK anyway, especially if you can see the nVidia logo screen. If you really want, you can open up the nv_check.sh script in a text editor, search and replace "NVdriver" to "nvidia" (without the quotes), and rerun the checker, but I'm not entirely sure that's necessary.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-14-03, 07:30 PM   #3
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Default vvnnyc

Thank you,bwkaz!
I checked and replace nv_check script and got the same result . Is there a way to check did I install it correct or not? And how can I check I am able to run 3D?
Thanx a lot .
vvnnyc is offline   Reply With Quote
Old 01-14-03, 08:25 PM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

What does lsmod after you've started up X tell you? Does it list nvidia?

If so, that's all that the script is looking for at that point. If you want, I have a version that may do a little better; I'll attach it here.
Attached Files
File Type: zip nv_check_new.zip (3.2 KB, 140 views)
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 01-14-03, 08:26 PM   #5
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Default

I executed this:
rpm -qa | grep kernel

and got this :
kernel-2.4.18-19.8.0
kernel-pcmcia-cs-3.1.31-9
kernel-source-2.4.18-19.8.0
NVIDIA_kernel-1.0-4191
kernel-2.4.18-14

Does that mean I installed Nvidia correct? and one more question, I can see kernel-2.4.18-14.So,do Ineed this kernel or not, if not how can remove it?
Thanx again
P.S it so hard to be a beginer in Linux,you know ))

Last edited by vvnnyc; 01-14-03 at 09:35 PM.
vvnnyc is offline   Reply With Quote
Old 01-14-03, 08:49 PM   #6
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Default

Thanx for yor script.
after I exec it I commented Load "dri".Then run thic script again .Well, everythig looks fine.But anyway, how can I know I can run 3D?
Where do I need to use lsmod ?
vvnnyc is offline   Reply With Quote
Old 01-14-03, 08:58 PM   #7
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

try running 'glxgears', that will tell you that the 3D is working, or even run TuxRacer..
Wolfman [TWP] is offline   Reply With Quote
Old 01-14-03, 09:37 PM   #8
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Default thanx to Wolfman [TWP]

I run this 'glxgears' and it's working. So,that means I have 3D working properly?
vvnnyc is offline   Reply With Quote

Old 01-14-03, 10:48 PM   #9
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Yeap! If glxgears runs, then the 3D stuff is working. Run TuxRacer, as it uses 3d Accel, and if that works, then it's most definately working...
Wolfman [TWP] is offline   Reply With Quote
Old 01-14-03, 11:01 PM   #10
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Default to Wolfman [TWP]

TuxRacer: command not found
what I do wrong?
vvnnyc is offline   Reply With Quote
Old 01-14-03, 11:22 PM   #11
vvnnyc
Registered User
 
Join Date: Jan 2003
Location: New York
Posts: 10
Default

if I installed right (i still dont know that ) is in Display settings an option Enable Hardware 3D Acceleration gonna be enable or not?
Who knows that?
vvnnyc is offline   Reply With Quote
Old 01-15-03, 04:19 AM   #12
LordMorgul
Electrical Engineer
 
LordMorgul's Avatar
 
Join Date: Dec 2002
Location: San Luis Obispo, CA
Posts: 872
Default

If, when you login, you see the Nvidia splash screen, then you are INDEED running the nvidia video driver. Whether 3d acceleration will work could be more complicated, but if the driver is running, then you are most likely ready to go. The best way to be sure is to install a game and see if you get 0.005 fps or something more reasonable :-D

[edit] Running 'glxinfo' will tell you if openGL acceleration is possible in hardware for the system as it is currently running, you should see the line:
direct rendering: Yes
[/edit]

If you've got the driver running, which it appears to be :-D then Hardware acceleration will be taking place, its not necessary to go click any check boxes. It is possible to adjust many things with driver options in your config file /etc/X11/XF86Config however. The nvidia FAQ has these options given for you.

Last edited by LordMorgul; 01-15-03 at 05:40 AM.
LordMorgul is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 09:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.