Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-06, 11:01 AM   #1
nmsdrg
Registered User
 
Join Date: Jan 2006
Posts: 2
Question Unable to get 8178 working under FreeBSD 6.0

Hello,

I'm using FreeBSD 6.0 and I installed nvidia-driver from ports. But I can't get it to work. Here are the errors :

(--) PCI:*(0:5:0) nVidia Corporation unknown chipset (0x0242) rev 162, Mem @ 0xf2000000/24, 0xe0000000/28, 0xf3000000/24

later ...

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(==) NVIDIA(0): Using HW cursor
(==) NVIDIA(0): Video key set to default value of 0x101fe
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(--) NVIDIA(0): Linear framebuffer at 0xE0000000
(--) NVIDIA(0): MMIO registers at 0xF2000000
(--) NVIDIA(0): Found 2 CRTCs on board
(II) NVIDIA(0): Supported display device(s): CRT-0
(WW) NVIDIA(0): Failed to determine if system is mobile
(II) NVIDIA(0): Boot display device(s): CRT-0
(WW) NVIDIA(0): Failed to determine chip name
(II) NVIDIA(0): NVIDIA GPU detected as: Unknown
(II) NVIDIA(0): Chip Architecture: 0x40
(II) NVIDIA(0): Chip Implementation: 0x4e
(II) NVIDIA(0): Chip Revision: 0xa2
(--) NVIDIA(0): VideoBIOS: 05.51.22.22.05
(EE) NVIDIA(0): Failed to determine display capabilities
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.


I have the same kind of error with both a Geforce 2 MX 400 and a Geforce 6100.
Kernel module is succesfully loaded :
nvidia0: <GeForce 6100> mem 0xf2000000-0xf2ffffff,0xe0000000-0xefffffff,0xf3000000-0xf3ffffff irq 16 at device 5.0 on pci0
nvidia0: [GIANT-LOCKED]

does anybody have an idea ?
nmsdrg is offline   Reply With Quote
Old 01-06-06, 06:47 AM   #2
nmsdrg
Registered User
 
Join Date: Jan 2006
Posts: 2
Default Re: Unable to get 8178 working under FreeBSD 6.0

Ok, I just found out the reason ... I need to compile my kernel and userland with KVA_PAGES=768. It seems to break binary compatibility with nvidia drivers... Sorry for the noise !
nmsdrg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.