Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-26-06, 09:33 AM   #1
ashrack
Registered User
 
Join Date: Jan 2006
Posts: 7
Default Hibernation WORKS with NVIDIA but not the terminals

Got SWSUP2 workin flawlesly on my notebook.
Im using UBUNTU 5.10, kernel 2.6.12 with patched SWSUP2.
Using NVIDIA 7676 drivers with the hack so SUSP2 works.
As usuall theres a but

When I resume from hibernation the X starts fine and all is great. But the TERMINALs (1-6) are all garbeld up. Showing an interleaced screen of my desktop in X
Help would be greatly appreciated. My system specs in the sig

btw. With the native NV driver all works great
__________________
UBUNTU 5.10 Brezzy Badger
NOTEBOOK:
Celeron 2400, 512MB RAM, GeForce FX 5500, ReiserFS
ash'rack

Last edited by ashrack; 01-27-06 at 05:11 AM.
ashrack is offline   Reply With Quote
Old 01-26-06, 10:34 PM   #2
Sean84
Registered User
 
Join Date: Jul 2004
Posts: 13
Default Re: Hibernation WORKS with NVIDIA but not the terminals

Its not just nvidia's cards with this problem, but most video cards
read Documentation/power/video.txt found in the linux kernel sources

Quote:
Video issues with S3 resume
~~~~~~~~~~~~~~~~~~~~~~~~~~~
2003-2005, Pavel Machek

During S3 resume, hardware needs to be reinitialized. For most
devices, this is easy, and kernel driver knows how to do
it. Unfortunately there's one exception: video card. Those are usually
initialized by BIOS, and kernel does not have enough information to
boot video card. (Kernel usually does not even contain video card
driver -- vesafb and vgacon are widely used).
<snip>
there are some possible tricks/workarounds listed, good luck
Sean84 is offline   Reply With Quote
Old 01-27-06, 03:05 AM   #3
IIIu30uD
Registered User
 
Join Date: Jan 2006
Location: Russia
Posts: 1
Default Re: Hibernation WORKS with NVIDIA but not the terminals

Strange,
when I used standart nv driver, ACPI worked correctly.
with driver from nvidia I have some problem. (kernel 2.6.12.3)
Now I'm trying to use kernel 2.6.14.2 but
Quote:
Stopping tasks: ================================================== ============|
ACPI: PCI interrupt for device 0000:02:0b.0 disabled
ACPI: PCI interrupt for device 0000:02:08.0 disabled
NVRM: ACPI: unsupported event: 2
Could not suspend device 0000:01:00.0: error -1
ACPI: PCI Interrupt 0000:02:08.0[A] -> Link [LNKE] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt 0000:02:0b.0[A] -> Link [LNKA] -> GSI 3 (level, low) -> IRQ 3
Some devices failed to suspend
Restarting tasks... done
(device 0000:01:00.0 is AGP)

-------------------------------------------------------------------
Toshiba Satellite M35-S320
NVIDIA GeForce FX Go5200 32MB
Gentoo Linux
kernels (2.6.12.3 and 2.6.12.4)
NVIDIA drivers (7667, 7676, 8178)
IIIu30uD is offline   Reply With Quote
Old 01-27-06, 03:45 AM   #4
JensG
Registered User
 
JensG's Avatar
 
Join Date: Nov 2004
Posts: 6
Default Re: Hibernation WORKS with NVIDIA but not the terminals

Hello ashrack,
interesting to hear that for you suspend2 works, put aside the terminal
problem that you mention. I will give it another try, too.

What currently works for me is suspend to memory, but also with the terminal
garbled. I did not figure out a way to correct that automatically, but manually
it works with vbetool. I blindly type

vbetool vbemode set 16660

in the terminal in question and it restores it. This is not an optimal procedure
but I am not using my console too often... Probably the number given as an
argument will be different for you, you will have to find that out with a freshly
booted machine and something like

vbetool vbemode get

or so in the console.

Hope this helps

Jens
JensG is offline   Reply With Quote
Old 01-27-06, 05:23 AM   #5
ashrack
Registered User
 
Join Date: Jan 2006
Posts: 7
Default Re: Hibernation WORKS with NVIDIA but not the terminals

@JensG
Could U tell me more about this VBETOOL and how would I go about doing it?
It sounds like a valuble workarround. At least until NVIDIA starts shipping drivers that support HIBERNATION

@all
Ive set up hibernation with SWSUP2 on 4different computers so far. And they are all rock solid and the terminals work. As long as they dont use properiety graphic drivers (ATI, NVIDIA)
ps. does any1 know why ATI,NVIDIA dont fix the them hibernation error? Since its very strange that the native NV or RADEON driver work great.

@IIIu30uD
Are U using SUSPEND2 or the standard suspend1?
__________________
UBUNTU 5.10 Brezzy Badger
NOTEBOOK:
Celeron 2400, 512MB RAM, GeForce FX 5500, ReiserFS
ash'rack
ashrack is offline   Reply With Quote
Old 01-27-06, 07:18 AM   #6
JensG
Registered User
 
JensG's Avatar
 
Join Date: Nov 2004
Posts: 6
Default Re: Hibernation WORKS with NVIDIA but not the terminals

ashrack,
I don't remember quite well where I got it, but it seems that I installed
an rpm some day: vbetool-0.2-1.1.fc3.rf. This works for me although
I don't have Fedora but Mandriva as a distribution.

Yes, it is strange that nvidia is not able to adress these issues and that their
acpi support (including hibernating etc.) is still so restricted. It is really amazing
that they get along with this, many machines only have acpi nowadays.

Jens
JensG is offline   Reply With Quote
Old 01-28-06, 11:07 AM   #7
ashrack
Registered User
 
Join Date: Jan 2006
Posts: 7
Default Re: Hibernation WORKS with NVIDIA but not the terminals

JENSQ
Just did
Code:
apt-cache show vbetool
and what do U know I have it installed already

Tank U mean this is a good temporary workaround. It's just ashame that only lasts until I get to X
__________________
UBUNTU 5.10 Brezzy Badger
NOTEBOOK:
Celeron 2400, 512MB RAM, GeForce FX 5500, ReiserFS
ash'rack

Last edited by ashrack; 01-28-06 at 12:53 PM.
ashrack is offline   Reply With Quote
Old 02-05-06, 02:57 PM   #8
ashrack
Registered User
 
Join Date: Jan 2006
Posts: 7
Default Found A Workin Solution

I append the following in the kernel line of GRUB
Code:
vga=0x318
WHich sets the FRAMEBUFFER to 1024x768x24
Which is also the the same as in X
And now the terminals work correctly.
__________________
UBUNTU 5.10 Brezzy Badger
NOTEBOOK:
Celeron 2400, 512MB RAM, GeForce FX 5500, ReiserFS
ash'rack
ashrack is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia: This is how GeForce GRID works and what it means for you:http://t.co/kIJtERDV News Archived News Items 0 06-04-12 07:40 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
NVIDIA Drivers + Linux 7.3 Works once then quits Yupper3d NVIDIA Linux 3 08-01-02 04:03 AM

All times are GMT -5. The time now is 11:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.