Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-22-06, 03:30 PM   #1
zvrastil
Registered User
 
Join Date: Apr 2005
Posts: 1
Default Unable to compile kernel module for kernel 2.6.16 on Debian

I'm unable to finish 8178 nvidia graphics driver installation on Debian Unstable with Debian kernel linux-image-2.6.16-1-k7, due to errors during compilation of the kernel module. With linux-image-2.6.15-1-k7 it works without problem.


The /var/log/nvidia-installer.log follows (center part removed to make the post shorter):


creation time: Wed Mar 22 22:13:52 2006

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
8178). As part of installing this driver (version: 1.0-8178), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC test with CC="cc".
-> Kernel source path: '/lib/modules/2.6.16-1-k7/build'
-> Kernel output path: '/lib/modules/2.6.16-1-k7/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o nv-vm.o os-agp.o os-interface.o os-registry.o nv.o nv-vm.o os-
agp.o os-interface.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
rm -f -f stprof stprof.o symtab.h
rm -f -rf .tmp_versions
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.16-1-k7/bui
ld SYSOUT=/lib/modules/2.6.16-1-k7/build'...

NVIDIA: calling KBUILD...
make CC=cc KBUILD_VERBOSE=1 -C /lib/modules/2.6.16-1-k7/build SUBDIRS=/tmp/
selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv modules
mkdir -p /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/.tmp_vers
ions
make -f scripts/Makefile.build obj=/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178
-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz5984/NVI
DIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv_compiler.h

... removed files, that compiled without problems ...

cc -Wp,-MD,/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/.os-i
nterface.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.0.3/include -
D__KERNEL__ -Iinclude -include include/linux/autoconf.h -Wall -Wundef -Wstr
ict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -ffreestandin
g -Os -fomit-frame-pointer -pipe -msoft-float -mpreferred-stack-boundary
=2 -march=athlon -Iinclude/asm-i386/mach-default -Wdeclaration-after-statem
ent -Wno-pointer-sign -I/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/s
rc/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wp
arentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD -Ws
ign-compare -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DM
ODULE -DNTRM -DNVRM -DDYNAMIC_SLI -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=
0 -DNV_PATCHLEVEL=8178 -UDEBUG -U_DEBUG -DNDEBUG -DNV_MULTIPLE_BRIDGE_AGPGA
RT_PRESENT -DNV_CHANGE_PAGE_ATTR_PRESENT -DMODULE -D"KBUILD_STR(s)=#s" -D"K
BUILD_BASENAME=KBUILD_STR(os_interface)" -D"KBUILD_MODNAME=KBUILD_STR(nvidi
a)" -c -o /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/.tmp_os-
interface.o /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/os-int
erface.c
In file included from include/linux/list.h:7,
from include/linux/wait.h:23,
from include/asm/semaphore.h:41,
from include/linux/sched.h:20,
from include/linux/module.h:10,
from /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv/nv-linux.h:47,
from /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv/os-interface.c:26:
include/linux/prefetch.h: In function 'prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type 'void *' used in arith
metic
In file included from include/linux/dmapool.h:14,
from include/linux/pci.h:522,
from /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv/nv-linux.h:71,
from /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv/os-interface.c:26:
include/asm/io.h: In function 'check_signature':
include/asm/io.h:258: warning: wrong type argument to increment
In file included from /tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv/os-interface.c:26:
/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/nv-linux.h:677:2:
warning: #warning "conftest.sh failed, assuming remap_page_range(4)!"
/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/os-interface.c: In
function 'os_set_mlock_capability':
/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/os-interface.c:137
5: error: 'struct task_struct' has no member named 'rlim'
make[3]: *** [/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src/nv/os-i
nterface.o] Error 1
make[2]: *** [_module_/tmp/selfgz5984/NVIDIA-Linux-x86-1.0-8178-pkg1/usr/src
/nv] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [mdl] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
zvrastil is offline   Reply With Quote
Old 03-22-06, 03:44 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Unable to compile kernel module for kernel 2.6.16 on Debian

Please see: http://www.nvnews.net/vbulletin/showthread.php?t=62021.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM

All times are GMT -5. The time now is 09:32 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.