Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-15-03, 07:47 PM   #1
eric42
Registered User
 
Join Date: Jan 2003
Posts: 13
Default Quadro 4 OpenGL Problem

Hi
I'm having problems with Gambit (mesh generation program) under linux. I'm getting the following errors in to the console whenever the screen does something. The program does not crash, but it won't zoom or rotate my drawing quite right and just keeps spewing these error messages to me. If anyone can help I'd appreciate it.
Thanks,
Eric
Here is the error message:

Received X Error <164: GLXBadRenderRequest>.
XErrorEvent:
display = :0.0
type = 0
resourceid = 30
serial = 21468
error_code = 164
request_code = 144
minor_code = 1


My System:
Dell Precision 530
Red Hat 7.3
2.4.18-3smp kernel
Quadro4 700 card 64MB
2GB Ram
Nvidia 4191 drivers installed. (First nvidia drivers for this computer)
eric42 is offline   Reply With Quote
Old 01-16-03, 09:41 AM   #2
merlin42
Registered User
 
Join Date: Sep 2002
Posts: 52
Default map1f

A quick grep of the glx source code available from SGI suggests that request code 144 corresponds to X_GLrop_Map1f which is the glx code for glMap1f

What I am not clear on is the exact meaning of GLXBadRenderRequest
1) Does it mean that the nvidia drivers are not recognizing code 144(X_GLrop_Map1f )? If so then this is a bug in the nvidia drivers and should be reported to linux-bugs@nvidia.com
2) Does it mean that bad/unusable values were passed into the glMap1f call? If so then this is probably a bug in the program you are using.

What sort of confuses me is that you are seeing GLX errors popping up. My understanding (which could very well be mistaken) is that if you are running an application locally then it will use "DirectRendering" which bypasses GLX for most/all normal rendering operations.

Please run glxinfo and see if it reports
direct rendering: Yes
and that both the GLX vendors and the OpenGL vendor are listed as nvidia.

If not then the drivers are not properly installed.
merlin42 is offline   Reply With Quote
Old 01-16-03, 12:50 PM   #3
eric42
Registered User
 
Join Date: Jan 2003
Posts: 13
Default

Thanks for replying,

I am running this program locally, and it is supposed to spport RH 7.3 and this specific graphics card. (It's listed as supported on their website). But fluent doesn't list a specific driver for support.

After running glxinfo the values for both vendors and the direct rendering are all right.
direct rendering =yes
glx vendor = NVIDIA corporation
OpenGL vendor = NVIDIA corporation.

If there is any way to work around this I'd appreciate it. Thanks again.
Eric
eric42 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 09:55 AM
Choosing The Right GPU To Take Adobe Workflows To The Max News Archived News Items 0 05-29-12 06:40 PM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 10:58 PM
Problem when compiling with SDL on Nvidia/Nforce... superconti NVIDIA Linux 3 09-13-02 01:25 AM
Multiple OpenGL applications and NVidia gbrauer NVIDIA Linux 7 09-01-02 05:47 PM

All times are GMT -5. The time now is 11:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.