Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-11-06, 06:10 PM   #1
bw_hh
Registered User
 
Join Date: Jan 2006
Location: Hamburg, Germany
Posts: 5
Default Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Hi,

I have some strange effects when trying to install the Nvidia driver on my system. After first install of Suse, I installed the driver via Yast online-update - worked without problems, 3D functionality included. I had problems with Suse and ACPI and therefore installed again with boot-option ACPI=off. 3D did not work anymore - neither by installing via YAST (fetchnvidia.sh) nor by manually install of the newest drivers.

When I'm running binary install, the words are mashed together, the screen is mixed up. The installation seems to work though - on first sight. No warnings, and xorg.conf is updated in the section "Device" (from "Driver nv" to "Driver Nvidia"). I installed driver 8178 with Patch (but same result with different drivers).

Sax2 stops with an error when running "sax2 -m 0=nvidia. SaX.log says:

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.
NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
(EE) NVIDIA(0): interrupts generated by the NVIDIA graphics device.
(EE) Screen(s) found, but none have a usable configuration.

In Xorg.0.log I found:
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib64/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.8178
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX

(II) Loading /usr/X11R6/lib64/modules/drivers/nv_drv.o
(II) Module nv: vendor="X.Org Foundation"
compiled for 6.8.2, module version = 1.0.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 0.7

What am I doing wrong here - any ideas? Any more information I could provide? Thanks in advance for your help!
bw_hh is offline   Reply With Quote
Old 01-11-06, 06:15 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Please generate and post an nvidia-bug-report.log for review.

You might also want to try installing the official 1.0-8178 driver package.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-11-06, 07:08 PM   #3
bw_hh
Registered User
 
Join Date: Jan 2006
Location: Hamburg, Germany
Posts: 5
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Hi,
I did install the 8178-driver. In detail:
su - root
init 3
cd nvidia
sh NVIDIA-Linux-x86_64-1.0-8178-pkg2.run --extract-only
cd NVIDIA-Linux-x86_64-1.0-8178-pkg2
patch -p0 ../NVIDIA_kernel-1.0-8178-U011106.diff.txt
./nvidia-installer -n

I attached the nvidia-bug-report.log - had to split it into 2 parts though, due to size-limitations of the server. Hope that helps.
Attached Files
File Type: txt part1.txt (96.2 KB, 157 views)
File Type: txt part2.txt (72.0 KB, 136 views)
bw_hh is offline   Reply With Quote
Old 01-11-06, 09:05 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Here's your problem:
(EE) NVIDIA(0): The NVIDIA kernel module does not appear to be receiving
(EE) NVIDIA(0): interrupts generated by the NVIDIA graphics device.
(EE) NVIDIA(0): Please see the FREQUENTLY ASKED QUESTIONS section in the
(EE) NVIDIA(0): README for additional information.

However, your card is identifying itself as a GeForce 6700 XL, not a GeForce 6600GT. Are you certain that you have a 6600GT? The 6700XL is not supported in 1.0-8178.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-12-06, 12:06 AM   #5
bw_hh
Registered User
 
Join Date: Jan 2006
Location: Hamburg, Germany
Posts: 5
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Hi,

the PC is from the company Medion, and according to several forums and newspapers, it ships with a 6600 GT that pretends to be a 6700 XL. Obviously, to Medion this sounds nicer.

However: I would think that this cannot be the problem. Otherwise I wouldn't have had 3D in the first place, right? Also, the NVidia-drivers work very well in Windows XP. (Also, Medion does not offer any Linux-Support, because the PC does have a preinstalled XP, but not a preinstalled Suse).

The first error in SaX.log is "Failed to inititialize the GLX module", the second one is about not being able to receive interrupts. Maybe after initializing the glx module the second error does not occur anymore. But what is the reason for the not-initialized glx module?

Thanks,
bw_hh
bw_hh is offline   Reply With Quote
Old 01-12-06, 12:18 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

If the only problem was loading the GLX module, you should be able to temporarily comment it out in your X configuration, and X should start up fine. Is that the case? If so, then we can focus on fixing the GLX module issue, however I doubt that the GLX module failure is the root of your problems. At the end of your bug report I see:
#####
NVRM: loading NVIDIA Linux x86_64 NVIDIA Kernel Module 1.0-8178 Wed Dec 14 16:58:07 PST 2005
irq 145: nobody cared (try booting with the "irqpoll" option)
Call Trace: <IRQ> <ffffffff801653a5>{__report_bad_irq+53} <ffffffff8016561a>{note_interrupt+538}
<ffffffff80164da3>{__do_IRQ+259} <ffffffff80111c48>{do_IRQ+72}
<ffffffff8010f320>{ret_from_intr+0} <EOI> <ffffffff88562cf3>{:nvidia:_nv001909rm+39}
<ffffffff886b202b>{:nvidia:_nv003988rm+31} <ffffffff886b202b>{:nvidia:_nv003988rm+31}
<ffffffff887629bb>{:nvidia:_nv000817rm+15} <ffffffff887616d2>{:nvidia:_nv000828rm+180}
<ffffffff8857559e>{:nvidia:_nv008224rm+0} <ffffffff8856015b>{:nvidia:_nv001754rm+169}
<ffffffff885601b6>{:nvidia:_nv001753rm+10} <ffffffff88574fcd>{:nvidia:_nv008236rm+641}
<ffffffff88579106>{:nvidia:rm_init_adapter+104} <ffffffff88792655>{:nvidia:nv_kern_open+616}
<ffffffff80195543>{chrdev_open+387} <ffffffff8018b5b4>{dentry_open+260}
<ffffffff8018b734>{filp_open+68} <ffffffff8018a9b3>{get_unused_fd+227}
<ffffffff8018b812>{sys_open+82} <ffffffff8010ed7e>{system_call+126}
handlers:
[<ffffffff883344b0>] (azx_interrupt+0x0/0x180 [snd_hda_intel])
[<ffffffff882c0c50>] (usb_hcd_irq+0x0/0x70 [usbcore])
Disabling IRQ #145
NVRM: RmInitAdapter failed! (0x12:0x2b:1438)
NVRM: rm_init_adapter(0) failed
########

Regardless of what is happing with WindowsXP, a 6700GL is not supported in 1.0-8178, and there's an IRQ problem on your system in Linux. The IRQ problem might be addressed per the instructions in the README. However, if you are truly using 6600GT hardware with a VBIOS that identifies itself as a 6700GL, then I can't predict how the Linux driver is going to treat this card.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 01-12-06, 02:36 AM   #7
bw_hh
Registered User
 
Join Date: Jan 2006
Location: Hamburg, Germany
Posts: 5
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Hi,

I'm running out of Linux-knowledge here: how can I analyse those irq-problems? Looks like usb_hcd is occupying the irq 145 that Nvidia needs? Or should I post at opensuse?

And: there is still the fact that the nvidia driver used to work with acpi switched off. Does acpi have anything to do with management of the irqs?

Thanks,
bw_hh
bw_hh is offline   Reply With Quote
Old 01-12-06, 05:33 AM   #8
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

@bw_hh: please see the README for IRQ related troubleshooting hints; please also try the irqpoll option, as suggested by the kernel (see above).
zander is offline   Reply With Quote

Old 01-12-06, 10:02 AM   #9
bw_hh
Registered User
 
Join Date: Jan 2006
Location: Hamburg, Germany
Posts: 5
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

Hi,

I will try that - provided you tell me what README you mean and where I can find it ;-) Also, could you tell me how to apply the irqpoll option?

Thanx,
bw_hh
bw_hh is offline   Reply With Quote
Old 01-12-06, 11:43 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Installing Driver for Nvidia 6600 GT on Suse 10, 64 bit

We're referring to the NVIDIA driver README ( /usr/share/doc/NVIDIA_GLX-1.0/README.txt ).

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
WINDOWS 8 RELEASE PREVIEW ACCEPTS INSTALLING WINDOWS 7 DRIVER 301.42 News Archived News Items 0 06-01-12 05:30 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM

All times are GMT -5. The time now is 06:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.