Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-10-06, 01:42 AM   #1
airflow
Registered User
 
airflow's Avatar
 
Join Date: Jan 2006
Posts: 4
Default vesafb-framebuffer and multiheaded graphicadapters

Hi,

I try to get framebuffer (standard vesafb in kernel) to work with my
multiheaded graphicadapter (nvidia card with dual-dvi). Principially it
works. The problem is, that it seems that the kernel-included vesafb
checks the EDID of *both* the dvi-ports. One of those dvi-ports is
connected to my projector, which is only capable of few, low resolution
modes. As soon as I unplug the projector, everything works as intended
(with my other device, a Samsung LCD-display). It makes no difference,
on which of the two dvi-ports the projector sits, vesafb always checks
both of them and refuses to work if the projector is connected (it is not
enough to turn the projector off, it has to be physically disconnected).

Is there any way to disable activation of framebuffer on one of those
dvi-ports? Of course I only need it on the port where my LCD-display is
connected, but there seems to be no option to specify this?

Another option would perhaps be to use vesafb-tng and to disable
EDID-checking, but perhaps there is a more elegant solution. I also
would rather like to solve the problem without patching the kernel. I
need use of framebuffer on only one of the ports, is this theoretically
possible (standard-console or no console output whatsoever on one
port, framebuffer-video on the other)?

Thanks,
airflow

Last edited by airflow; 01-11-06 at 01:40 AM. Reason: bumping...
airflow is offline   Reply With Quote
Old 01-13-06, 12:25 PM   #2
airflow
Registered User
 
airflow's Avatar
 
Join Date: Jan 2006
Posts: 4
Default Re: vesafb-framebuffer and multiheaded graphicadapters

Hello,

I tried the vesafb-tng instead of the kernel-standard vesafb in the meantime. I set the "noedid"-option to make sure that the resolution is set when the projector is connected. Even this way I can't get the framebuffer to work when both devices (LCD and projector) are connected. 640x480 works, but any resolution higher is not possible. When I disconnect the projector, it works.

I also tried the utility fbset. Same here. As long as only the TFT is connected, I can set all resolutions I want, back and forth. Connecting the projector, too, leads to the errormessage "ioctl FBIOPUT_VSCREENINFO: Invalid argument". Searching the internet did not yield usable results for me... Perhaps you have an idea?

greets,
airflow
airflow is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.